summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-03-26 08:06:17 +0000
committerAli Polatel <hawking@gentoo.org>2008-03-26 08:06:17 +0000
commit40fa9abcda11f175acf6372830df049538ec1f38 (patch)
tree3d3c494a8e31d0a2ecc06cf84444e4a929f22e46 /app-vim
parentversion bump (diff)
downloadgentoo-2-40fa9abcda11f175acf6372830df049538ec1f38.tar.gz
gentoo-2-40fa9abcda11f175acf6372830df049538ec1f38.tar.bz2
gentoo-2-40fa9abcda11f175acf6372830df049538ec1f38.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimcommander/ChangeLog7
-rw-r--r--app-vim/vimcommander/vimcommander-75.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/app-vim/vimcommander/ChangeLog b/app-vim/vimcommander/ChangeLog
index 22da113d4b17..ed3e8c4617b3 100644
--- a/app-vim/vimcommander/ChangeLog
+++ b/app-vim/vimcommander/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/vimcommander
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/ChangeLog,v 1.21 2008/03/24 17:02:22 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/ChangeLog,v 1.22 2008/03/26 08:06:17 hawking Exp $
+
+*vimcommander-75 (26 Mar 2008)
+
+ 26 Mar 2008; Ali Polatel <hawking@gentoo.org> +vimcommander-75.ebuild:
+ Version bump.
24 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
vimcommander-1.54.2.9.ebuild:
diff --git a/app-vim/vimcommander/vimcommander-75.ebuild b/app-vim/vimcommander/vimcommander-75.ebuild
new file mode 100644
index 000000000000..cafb9a4f75ee
--- /dev/null
+++ b/app-vim/vimcommander/vimcommander-75.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/vimcommander-75.ebuild,v 1.1 2008/03/26 08:06:17 hawking Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Total Commander style file explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=808"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimcommander"
+
+function src_unpack() {
+ unpack ${A}
+ mkdir "${S}"/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic documentation install' trick. This
+ # causes problems for us during the unmerge. Fortunately, sed can fix
+ # this for us.
+ sed -e '1,/^=== START_DOC$/d' \
+ -e '/^=== END_DOC/,$d' \
+ -e "s/#version#/v${PV}/" \
+ "${S}"/plugin/vimcommander.vim > "${S}"/doc/vimcommander.txt \
+ || die "help extraction failed"
+
+ echo -ne "\n\n vim:tw=78:ts=8:ft=help:norl:" >> "${S}"/doc/vimcommander.txt
+
+ sed -i -e 's/" \(let b:vimcommander_install_doc=\)[01]/\10/' \
+ "${S}"/plugin/vimcommander.vim \
+ || die "help extract disable failed"
+}