summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-26 21:17:53 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-26 21:17:53 +0000
commitc3209a23364de05c703bdfe10f5e574887bd9a87 (patch)
treebefcefbfd8fac3eabb7871da88061942c68fbe9e /app-vim
parentwhitespace (diff)
downloadgentoo-2-c3209a23364de05c703bdfe10f5e574887bd9a87.tar.gz
gentoo-2-c3209a23364de05c703bdfe10f5e574887bd9a87.tar.bz2
gentoo-2-c3209a23364de05c703bdfe10f5e574887bd9a87.zip
Version bump.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/automatictexplugin/ChangeLog8
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-12.1.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/app-vim/automatictexplugin/ChangeLog b/app-vim/automatictexplugin/ChangeLog
index 38782c540cfc..a7231f29e320 100644
--- a/app-vim/automatictexplugin/ChangeLog
+++ b/app-vim/automatictexplugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/automatictexplugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.35 2012/09/21 22:05:30 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.36 2012/09/26 21:17:53 radhermit Exp $
+
+*automatictexplugin-12.1 (26 Sep 2012)
+
+ 26 Sep 2012; Tim Harder <radhermit@gentoo.org>
+ +automatictexplugin-12.1.ebuild:
+ Version bump.
*automatictexplugin-12 (21 Sep 2012)
diff --git a/app-vim/automatictexplugin/automatictexplugin-12.1.ebuild b/app-vim/automatictexplugin/automatictexplugin-12.1.ebuild
new file mode 100644
index 000000000000..e8626a33de10
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-12.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-12.1.ebuild,v 1.1 2012/09/26 21:17:53 radhermit Exp $
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/releases/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ >=dev-lang/python-2.7
+ dev-python/psutil
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base"