summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-06 13:12:40 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-06 13:12:40 +0000
commitebe9c2202f45884c0271bc367851f659bf12eaf1 (patch)
treebf683af78dc331d41e73acea57b7acc116caae8e /app-vim
parentConvert to python-single-r1, enforce a match on Python version used by vim. (diff)
downloadgentoo-2-ebe9c2202f45884c0271bc367851f659bf12eaf1.tar.gz
gentoo-2-ebe9c2202f45884c0271bc367851f659bf12eaf1.tar.bz2
gentoo-2-ebe9c2202f45884c0271bc367851f659bf12eaf1.zip
Convert to python-single-r1, enforce a match on Python version used by vim.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimpress/ChangeLog8
-rw-r--r--app-vim/vimpress/vimpress-3.2.0.ebuild12
2 files changed, 12 insertions, 8 deletions
diff --git a/app-vim/vimpress/ChangeLog b/app-vim/vimpress/ChangeLog
index 6d86d909e258..3bb9bc6bf054 100644
--- a/app-vim/vimpress/ChangeLog
+++ b/app-vim/vimpress/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-vim/vimpress
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpress/ChangeLog,v 1.8 2012/12/04 11:23:31 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpress/ChangeLog,v 1.9 2015/01/06 13:12:40 mgorny Exp $
+
+ 06 Jan 2015; Michał Górny <mgorny@gentoo.org> vimpress-3.2.0.ebuild:
+ Convert to python-single-r1, enforce a match on Python version used by vim.
04 Dec 2012; <ago@gentoo.org> vimpress-3.2.0.ebuild:
Stable for x86, wrt bug #441132
@@ -32,4 +35,3 @@
10 Jun 2011; Tim Harder <radhermit@gentoo.org> +vimpress-2.1.0.ebuild,
+metadata.xml:
Initial import.
-
diff --git a/app-vim/vimpress/vimpress-3.2.0.ebuild b/app-vim/vimpress/vimpress-3.2.0.ebuild
index 4976a8f0c018..93db7bc1faa6 100644
--- a/app-vim/vimpress/vimpress-3.2.0.ebuild
+++ b/app-vim/vimpress/vimpress-3.2.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpress/vimpress-3.2.0.ebuild,v 1.3 2012/12/04 11:23:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpress/vimpress-3.2.0.ebuild,v 1.4 2015/01/06 13:12:40 mgorny Exp $
EAPI=4
+PYTHON_COMPAT=( python2_7 )
-inherit vim-plugin
+inherit python-single-r1 vim-plugin
DESCRIPTION="vim plugin: manage wordpress blogs from vim"
HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3510"
@@ -12,8 +13,9 @@ LICENSE="vim"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
- || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
dev-python/markdown"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
VIM_PLUGIN_HELPFILES="${PN}.txt"