summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-11-06 04:54:07 +0000
committerTim Harder <radhermit@gentoo.org>2014-11-06 04:54:07 +0000
commitf8ad96eab02e8b25e541cf8a80d316c482db4f53 (patch)
tree2b4fe8263ff4f264c7296896b141fce070a4376a /app-vim
parentRemove old. (diff)
downloadgentoo-2-f8ad96eab02e8b25e541cf8a80d316c482db4f53.tar.gz
gentoo-2-f8ad96eab02e8b25e541cf8a80d316c482db4f53.tar.bz2
gentoo-2-f8ad96eab02e8b25e541cf8a80d316c482db4f53.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/notes/ChangeLog7
-rw-r--r--app-vim/notes/notes-0.28.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-vim/notes/ChangeLog b/app-vim/notes/ChangeLog
index 0d4707dba3dc..00476fbea24a 100644
--- a/app-vim/notes/ChangeLog
+++ b/app-vim/notes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/notes
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/notes/ChangeLog,v 1.19 2014/10/25 08:19:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/notes/ChangeLog,v 1.20 2014/11/06 04:54:07 radhermit Exp $
+
+*notes-0.28.1 (06 Nov 2014)
+
+ 06 Nov 2014; Tim Harder <radhermit@gentoo.org> +notes-0.28.1.ebuild:
+ Version bump.
*notes-0.28 (25 Oct 2014)
diff --git a/app-vim/notes/notes-0.28.1.ebuild b/app-vim/notes/notes-0.28.1.ebuild
new file mode 100644
index 000000000000..c2a5888bb568
--- /dev/null
+++ b/app-vim/notes/notes-0.28.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/notes/notes-0.28.1.ebuild,v 1.1 2014/11/06 04:54:07 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: easy note taking in vim"
+HOMEPAGE="http://peterodding.com/code/vim/notes/"
+SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-vim/vim-misc-1.16.1"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim-${P}
+
+src_prepare() {
+ # remove unnecessary files
+ rm addon-info.json INSTALL.md README.md || die
+
+ python_fix_shebang .
+}