summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-07-23 01:22:47 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-07-23 01:22:47 +0000
commitbfd442a72c56c86ed48f3a076a7e7fab1f188ad6 (patch)
treeab4d22511aa58084edaaa89023e67ab8049930f8 /dev-ada
parentBump for gaim-encryption bugfix (2.02) (diff)
downloadgentoo-2-bfd442a72c56c86ed48f3a076a7e7fab1f188ad6.tar.gz
gentoo-2-bfd442a72c56c86ed48f3a076a7e7fab1f188ad6.tar.bz2
gentoo-2-bfd442a72c56c86ed48f3a076a7e7fab1f188ad6.zip
new revision, bringing the library into compliance with GNAE
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/xmlada/ChangeLog10
-rw-r--r--dev-ada/xmlada/Manifest4
-rw-r--r--dev-ada/xmlada/files/digest-xmlada-0.7.1-r11
-rw-r--r--dev-ada/xmlada/xmlada-0.7.1-r1.ebuild69
4 files changed, 81 insertions, 3 deletions
diff --git a/dev-ada/xmlada/ChangeLog b/dev-ada/xmlada/ChangeLog
index e03393263a90..e7161a54a97c 100644
--- a/dev-ada/xmlada/ChangeLog
+++ b/dev-ada/xmlada/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for dev-ada/xmlada
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/ChangeLog,v 1.1 2003/07/22 07:53:55 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/ChangeLog,v 1.2 2003/07/23 01:22:45 george Exp $
-*XmlAda-0.7.1 (20 Nov 2002)
+*xmlada-0.7.1-r1 (22 Nov 2002)
+
+ 22 Jul 2003; George Shapovalov <george@gentoo.org> xmlada-0.7.1-r1.ebuild :
+ made few changes to where the library gets installed, to bring it into
+ compliance with GNAE.
+
+*xmlada-0.7.1 (20 Nov 2002)
21 Jul 2003; George Shapovalov <george@gentoo.org> xmlada-0.7.1.ebuild :
cleaned-up and added to the tree (#12081)
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
index bff9de4c67ac..5a52cad027ec 100644
--- a/dev-ada/xmlada/Manifest
+++ b/dev-ada/xmlada/Manifest
@@ -1,3 +1,5 @@
MD5 2feab8d991e711195c443e263aaba4f0 xmlada-0.7.1.ebuild 1320
-MD5 6be193bdd6256ad3823d299ef98f2013 ChangeLog 618
+MD5 0f3b748ad72737f43d9905432c14f117 xmlada-0.7.1-r1.ebuild 1575
+MD5 87d05a2cead9c71cc6a4c06ce9d93496 ChangeLog 827
+MD5 9d2b99c18fffcb88c4d56d762a271e19 files/digest-xmlada-0.7.1-r1 61
MD5 9d2b99c18fffcb88c4d56d762a271e19 files/digest-xmlada-0.7.1 61
diff --git a/dev-ada/xmlada/files/digest-xmlada-0.7.1-r1 b/dev-ada/xmlada/files/digest-xmlada-0.7.1-r1
new file mode 100644
index 000000000000..9480560adca5
--- /dev/null
+++ b/dev-ada/xmlada/files/digest-xmlada-0.7.1-r1
@@ -0,0 +1 @@
+MD5 385631115aa6546aaf6790e0ad59e399 XmlAda-0.7.1.tgz 312248
diff --git a/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild b/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..e3abb99e11ab
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild,v 1.1 2003/07/23 01:22:45 george Exp $
+
+inherit gnat
+
+IUSE=""
+
+Name="XmlAda"
+
+DESCRIPTION="XML library for Ada"
+HOMEPAGE="http://libre.act-europe.fr/xmlada/"
+SRC_URI="http://libre.act-europe.fr/xmlada/${Name}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="dev-lang/gnat"
+
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ #making .dvi docs is problemmatic. Skip that for now
+ sed -i -e "s/all: obj test docs/all: obj test/" Makefile.in
+ #increase stack size
+ cd sax
+ sed -i -e "s/Stack_Size : constant Natural := 64;/Stack_Size : constant Natural := 128;/" sax-readers.adb
+}
+
+src_compile()
+{
+ export CFLAGS=$ADACFLAGS
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --with-system-zlib || die
+
+ export COMPILER=gnatmake
+ make || die "make failed"
+}
+
+src_install ()
+{
+ make PREFIX=${D}/usr install || die "install failed"
+
+ #move components to GNAE compliant directories
+ dodir /usr/lib/ada/adalib/${PN} /usr/lib/ada/adainclude
+ cd ${D}/usr/lib/
+ mv * ${D}/usr/lib/ada/adalib/${PN}/
+ cd ${D}/usr/include
+ mv ${PN} ${D}/usr/lib/ada/adainclude/
+ cd ..
+ rmdir include
+ cd ${S}
+
+ dodoc AUTHORS COPYING README TODO docs/xml.ps
+ dohtml docs/*.html
+ doinfo docs/*.info
+ #need to give a proper name to info file
+ cd ${D}/usr/share/info
+ mv xml.info.gz ${PN}.info.gz
+}