summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-11 16:21:56 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-11 16:21:56 +0000
commitacafa0d55bf3197bca62d36284a847966d53d097 (patch)
tree77830c397bd7cb762aca3620bdfdcb689d1ca7b1 /dev-cpp/asio
parentremove old version (diff)
downloadgentoo-2-acafa0d55bf3197bca62d36284a847966d53d097.tar.gz
gentoo-2-acafa0d55bf3197bca62d36284a847966d53d097.tar.bz2
gentoo-2-acafa0d55bf3197bca62d36284a847966d53d097.zip
Version bump.
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-cpp/asio')
-rw-r--r--dev-cpp/asio/ChangeLog7
-rw-r--r--dev-cpp/asio/asio-1.1.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-cpp/asio/ChangeLog b/dev-cpp/asio/ChangeLog
index 56d69ca37aba..3b7e074a996c 100644
--- a/dev-cpp/asio/ChangeLog
+++ b/dev-cpp/asio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/asio
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.14 2008/02/05 23:43:27 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.15 2008/06/11 16:21:56 drac Exp $
+
+*asio-1.1.0 (11 Jun 2008)
+
+ 11 Jun 2008; Samuli Suominen <drac@gentoo.org> +asio-1.1.0.ebuild:
+ Version bump.
05 Feb 2008; Tiziano Müller <dev-zero@gentoo.org>
-files/asio-0.3.7-recursive_init.patch, -asio-0.3.7.ebuild:
diff --git a/dev-cpp/asio/asio-1.1.0.ebuild b/dev-cpp/asio/asio-1.1.0.ebuild
new file mode 100644
index 000000000000..ae6e76a14ee3
--- /dev/null
+++ b/dev-cpp/asio/asio-1.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-1.1.0.ebuild,v 1.1 2008/06/11 16:21:56 drac Exp $
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples ssl test"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/boost-1.34.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use test ; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF
+all:
+
+install:
+ EOF
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README
+
+ if use doc ; then
+ dohtml -r doc/*
+ fi
+ if use examples ; then
+
+ if use test ; then
+ # Get rid of the object files
+ emake clean || die "emake clean failed"
+ fi
+
+ insinto /usr/share/doc/${PF}
+ doins -r src/examples
+ fi
+}