summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-12-07 23:30:27 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-12-07 23:30:27 +0000
commit4c6459d4707c1f2a5c372cd91c9614f2ad9f9498 (patch)
treefa5ace5019bb246f7975ebfaaa275bc11463cc4c /dev-cpp/commoncpp2
parentstable (diff)
downloadgentoo-2-4c6459d4707c1f2a5c372cd91c9614f2ad9f9498.tar.gz
gentoo-2-4c6459d4707c1f2a5c372cd91c9614f2ad9f9498.tar.bz2
gentoo-2-4c6459d4707c1f2a5c372cd91c9614f2ad9f9498.zip
moved commoncpp2 from dev-libs to dev-cpp
Diffstat (limited to 'dev-cpp/commoncpp2')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog38
-rw-r--r--dev-cpp/commoncpp2/Manifest7
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.0.12.ebuild45
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild45
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.0.9.ebuild45
-rw-r--r--dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.121
-rw-r--r--dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.131
-rw-r--r--dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.91
8 files changed, 183 insertions, 0 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
new file mode 100644
index 000000000000..a3c6599b7b2a
--- /dev/null
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for dev-libs/commoncpp2
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header:
+
+*commoncpp2-1.0.9 (08 Dec 2003)
+
+ 08 Dec 2003; Heinrich Wendel <lanius@gentoo.org> commoncpp2-1.0.12.ebuild,
+ commoncpp2-1.0.13.ebuild, commoncpp2-1.0.9.ebuild:
+ moved from dev-libs to dev-cpp
+
+ 08 Dec 2003; Heinrich Wendel <lanius@gentoo.org> commoncpp2-1.0.12.ebuild:
+ ~x86 -> x86
+
+ 07 Dec 2003; Heinrich Wendel <lanius@gentoo.org> commoncpp2-1.0.13.ebuild:
+ bump
+
+*commoncpp2-1.0.12 (21 Jul 2003)
+
+ 21 Jul 2003; Michael Nazaroff <naz@gentoo.org> commoncpp2-1.0.12.ebuild :
+ Version bump
+
+*commoncpp2-1.0.9 (10 May 2003)
+
+ 10 May 2003; foser <foser@gentoo.org> commoncpp2-1.0.9.ebuild :
+ New version, now install html docs correctly
+
+*commoncpp2-1.0.3 (27 Oct 2002)
+
+ 27 Oct 2002; foser <foser@gentoo.org> commoncpp2-1.0.3.ebuild :
+ New version
+
+*commoncpp2-1.0.1 (03 Oct 2002)
+
+ 03 Oct 2002; Matt Keadle <mkeadle@gentoo.org> commoncpp2-1.0.1:
+ This changelog is for the initial release of commoncpp2-1.0.1.ebuild which is
+ just a library needed for a few gnu applications. It is the new branch of
+ commonc++. Thanks to foser <foser@gentoo.org> for the ebuild!
+
diff --git a/dev-cpp/commoncpp2/Manifest b/dev-cpp/commoncpp2/Manifest
new file mode 100644
index 000000000000..ac307887bea2
--- /dev/null
+++ b/dev-cpp/commoncpp2/Manifest
@@ -0,0 +1,7 @@
+MD5 2247aaa8e461cd4868c38e8c4d0fbf9f commoncpp2-1.0.13.ebuild 1130
+MD5 e4aa2598ed29586f71e7bd9a8b3b19c3 commoncpp2-1.0.9.ebuild 1119
+MD5 e351ad83a38942691d3e9465f3654557 commoncpp2-1.0.12.ebuild 1129
+MD5 755f6313b47b6f97fc97d4a4afead1a1 ChangeLog 1212
+MD5 7c9a86d8c669237c73dc6a5427daf856 files/digest-commoncpp2-1.0.9 68
+MD5 4414fd7500e4bd6537c60b97372c3500 files/digest-commoncpp2-1.0.12 69
+MD5 781ce9f97c4496dcb0ec078a74cba8d2 files/digest-commoncpp2-1.0.13 69
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.0.12.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.0.12.ebuild
new file mode 100644
index 000000000000..8adc83052977
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.0.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.0.12.ebuild,v 1.1 2003/12/07 23:30:22 lanius Exp $
+
+IUSE="doc xml2"
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
+threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
+and system services"
+SRC_URI="mirror://gnu/commonc++/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commonc++/"
+
+DEPEND="xml2? ( dev-libs/libxml2 )
+ doc? ( app-doc/doxygen )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf=""
+
+ use xml2 \
+ && myconf="${myconf} --with-xml" \
+ || myconf="${myconf} --without-xml"
+
+ econf ${myconf} --with-ftp || die "./configure failed"
+
+ emake || die
+
+ # kdoc disabled for now, it errors out
+ use doc && make doxy
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ THANKS TODO COPYING COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml docs/html/*
+}
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild
new file mode 100644
index 000000000000..34b32929059f
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild,v 1.1 2003/12/07 23:30:22 lanius Exp $
+
+IUSE="doc xml2"
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
+threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
+and system services"
+SRC_URI="mirror://gnu/commonc++/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commonc++/"
+
+DEPEND="xml2? ( dev-libs/libxml2 )
+ doc? ( app-doc/doxygen )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf=""
+
+ use xml2 \
+ && myconf="${myconf} --with-xml" \
+ || myconf="${myconf} --without-xml"
+
+ econf ${myconf} --with-ftp || die "./configure failed"
+
+ emake || die
+
+ # kdoc disabled for now, it errors out
+ use doc && make doxy
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ THANKS TODO COPYING COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml docs/html/*
+}
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.0.9.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.0.9.ebuild
new file mode 100644
index 000000000000..0f3870bf8c2f
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.0.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.0.9.ebuild,v 1.1 2003/12/07 23:30:22 lanius Exp $
+
+IUSE="doc xml2"
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
+threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
+and system services"
+SRC_URI="mirror://gnu/commonc++/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commonc++/"
+
+DEPEND="xml2? ( dev-libs/libxml2 )
+ doc? ( app-doc/doxygen )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf=""
+
+ use xml2 \
+ && myconf="${myconf} --with-xml" \
+ || myconf="${myconf} --without-xml"
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die
+
+ # kdoc disabled for now, it errors out
+ use doc && make doxy
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ THANKS TODO COPYING COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml docs/html/*
+}
diff --git a/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.12 b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.12
new file mode 100644
index 000000000000..3cb0cc8c03a1
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.12
@@ -0,0 +1 @@
+MD5 82ab4b53ca42490a5f06def587fc347d commoncpp2-1.0.12.tar.gz 719754
diff --git a/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.13 b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.13
new file mode 100644
index 000000000000..6fe2c805367e
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.13
@@ -0,0 +1 @@
+MD5 7f1c5754ecd4a8c7524beb55b49a1fbf commoncpp2-1.0.13.tar.gz 830489
diff --git a/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.9 b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.9
new file mode 100644
index 000000000000..0b2a56379c96
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.0.9
@@ -0,0 +1 @@
+MD5 a2df94db6ef66312cc6dae513aa160dc commoncpp2-1.0.9.tar.gz 696130