summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-01-28 11:10:11 +0000
committerTim Harder <radhermit@gentoo.org>2011-01-28 11:10:11 +0000
commite8b634a0227f57ff9044f25323c7de2aaa2590be (patch)
tree750a9f91419ddb290e9f36a18490ca45fad01c93 /dev-cpp/ctemplate
parentVersion bump, remove old. (diff)
downloadgentoo-2-e8b634a0227f57ff9044f25323c7de2aaa2590be.tar.gz
gentoo-2-e8b634a0227f57ff9044f25323c7de2aaa2590be.tar.bz2
gentoo-2-e8b634a0227f57ff9044f25323c7de2aaa2590be.zip
Version bump, add static-libs USE flag, and remove old.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/ChangeLog10
-rw-r--r--dev-cpp/ctemplate/ctemplate-0.99.ebuild (renamed from dev-cpp/ctemplate/ctemplate-0.95.ebuild)16
2 files changed, 20 insertions, 6 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index 355a45efc87d..3c72dc8f04bf 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/ctemplate
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.8 2010/10/26 07:41:45 radhermit Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.9 2011/01/28 11:10:11 radhermit Exp $
+
+*ctemplate-0.99 (28 Jan 2011)
+
+ 28 Jan 2011; Tim Harder <radhermit@gentoo.org> -ctemplate-0.95.ebuild,
+ +ctemplate-0.99.ebuild:
+ Version bump, add static-libs USE flag, and remove old.
*ctemplate-0.98 (26 Oct 2010)
diff --git a/dev-cpp/ctemplate/ctemplate-0.95.ebuild b/dev-cpp/ctemplate/ctemplate-0.99.ebuild
index 6a7c845536c0..04a2ee79e90c 100644
--- a/dev-cpp/ctemplate/ctemplate-0.95.ebuild
+++ b/dev-cpp/ctemplate/ctemplate-0.99.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-0.95.ebuild,v 1.4 2010/10/20 13:54:28 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-0.99.ebuild,v 1.1 2011/01/28 11:10:11 radhermit Exp $
EAPI="3"
@@ -9,10 +9,11 @@ inherit elisp-common
DESCRIPTION="A simple but powerful template language for C++"
HOMEPAGE="http://code.google.com/p/google-ctemplate/"
SRC_URI="http://google-ctemplate.googlecode.com/files/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax"
+IUSE="doc emacs vim-syntax static-libs"
DEPEND=""
RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
@@ -20,6 +21,13 @@ RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
SITEFILE="70ctemplate-gentoo.el"
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
src_compile() {
emake || die "emake failed"
@@ -29,7 +37,7 @@ src_compile() {
}
src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
# Installs just every piece
rm -rf "${ED}/usr/share/doc"