summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-17 16:15:54 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-17 16:15:54 +0000
commit5d923a7b34b4311152ae605e1378e11fee3573ac (patch)
tree3e2b52422cb428711564d71987cc737c46518a97 /dev-cpp/glibmm
parentDefine CRYPTO on src_install. Fixes bug #324469 (diff)
downloadgentoo-2-5d923a7b34b4311152ae605e1378e11fee3573ac.tar.gz
gentoo-2-5d923a7b34b4311152ae605e1378e11fee3573ac.tar.bz2
gentoo-2-5d923a7b34b4311152ae605e1378e11fee3573ac.zip
Version
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/glibmm')
-rw-r--r--dev-cpp/glibmm/ChangeLog9
-rw-r--r--dev-cpp/glibmm/glibmm-2.24.2.ebuild60
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-cpp/glibmm/ChangeLog b/dev-cpp/glibmm/ChangeLog
index 56bd6b89624a..a2cbaab55931 100644
--- a/dev-cpp/glibmm/ChangeLog
+++ b/dev-cpp/glibmm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/glibmm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.147 2010/05/31 20:36:48 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.148 2010/06/17 16:15:53 pacho Exp $
+
+*glibmm-2.24.2 (17 Jun 2010)
+
+ 17 Jun 2010; Pacho Ramos <pacho@gentoo.org> +glibmm-2.24.2.ebuild:
+ Version bump: adds API for the new Network I/O classes that were added in
+ glib 2.22.x, adds the BalancedTree class (wrapping GTree) and other new
+ additions. Also contains several bugfixes.
31 May 2010; Gilles Dartiguelongue <eva@gentoo.org> -glibmm-2.16.4.ebuild,
-glibmm-2.20.1.ebuild:
diff --git a/dev-cpp/glibmm/glibmm-2.24.2.ebuild b/dev-cpp/glibmm/glibmm-2.24.2.ebuild
new file mode 100644
index 000000000000..4c490c54cca9
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.24.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.24.2.ebuild,v 1.1 2010/06/17 16:15:54 pacho Exp $
+
+EAPI="3"
+inherit gnome2
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="|| ( LGPL-2.1 GPL-2 )"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-libs/libsigc++-2.2
+ >=dev-libs/glib-2.24.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+ fi
+}
+
+src_test() {
+ cd "${S}/tests/"
+ emake check || die "emake check failed"
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+src_install() {
+ gnome2_src_install
+
+ if ! use doc && ! use examples; then
+ rm -fr "${ED}usr/share/doc/glibmm*"
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ dodoc examples
+ fi
+}