summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-10-16 13:38:32 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-10-16 13:38:32 +0000
commit2d38d6d89df24463c1dd20652560b3c8e1ace8e3 (patch)
tree7fc41febc42053c41d8ccf53aa120b13a2218e58 /dev-cpp/ice
parentAdd patch from upstream to fix khtml rendering. (diff)
downloadgentoo-2-2d38d6d89df24463c1dd20652560b3c8e1ace8e3.tar.gz
gentoo-2-2d38d6d89df24463c1dd20652560b3c8e1ace8e3.tar.bz2
gentoo-2-2d38d6d89df24463c1dd20652560b3c8e1ace8e3.zip
version bump
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'dev-cpp/ice')
-rw-r--r--dev-cpp/ice/ChangeLog8
-rw-r--r--dev-cpp/ice/files/digest-ice-3.1.13
-rw-r--r--dev-cpp/ice/files/ice-3.1.1-makefile.patch68
-rw-r--r--dev-cpp/ice/ice-3.1.1.ebuild64
4 files changed, 142 insertions, 1 deletions
diff --git a/dev-cpp/ice/ChangeLog b/dev-cpp/ice/ChangeLog
index 1f2778d8d7de..3165d9176553 100644
--- a/dev-cpp/ice/ChangeLog
+++ b/dev-cpp/ice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/ice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.11 2006/08/06 00:56:40 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.12 2006/10/16 13:38:32 caleb Exp $
+
+*ice-3.1.1 (16 Oct 2006)
+
+ 16 Oct 2006; Caleb Tennis <caleb@gentoo.org>
+ +files/ice-3.1.1-makefile.patch, +ice-3.1.1.ebuild:
+ version bump
05 Aug 2006; Chris White <chriswhite@gentoo.org> ice-3.1.0-r6.ebuild:
Fixed sys-libs/db dep atom for bug #142045.
diff --git a/dev-cpp/ice/files/digest-ice-3.1.1 b/dev-cpp/ice/files/digest-ice-3.1.1
new file mode 100644
index 000000000000..7f0a44a55a18
--- /dev/null
+++ b/dev-cpp/ice/files/digest-ice-3.1.1
@@ -0,0 +1,3 @@
+MD5 2bb84e1e8cf1cf67370467d6aee6659d Ice-3.1.1.tar.gz 2183969
+RMD160 737f453d8d3b44fecbbee10f13d84658675c8e91 Ice-3.1.1.tar.gz 2183969
+SHA256 b20286bbdb4100d5120e27b6bf3d8babab39a75b1b4bf4c8e743ed6789df0a80 Ice-3.1.1.tar.gz 2183969
diff --git a/dev-cpp/ice/files/ice-3.1.1-makefile.patch b/dev-cpp/ice/files/ice-3.1.1-makefile.patch
new file mode 100644
index 000000000000..689c28abdb6a
--- /dev/null
+++ b/dev-cpp/ice/files/ice-3.1.1-makefile.patch
@@ -0,0 +1,68 @@
+--- Makefile.orig 2006-01-25 16:25:45.000000000 -0500
++++ Makefile 2006-01-25 16:28:04.000000000 -0500
+@@ -19,7 +19,7 @@
+ @if test ! -d $(prefix) ; \
+ then \
+ echo "Creating $(prefix)..." ; \
+- $(call mkdir,$(prefix)) ; \
++ mkdir -p $(prefix) ; \
+ fi
+
+ @for subdir in $(INSTALL_SUBDIRS); \
+@@ -47,8 +47,8 @@
+ then \
+ ( cd doc && $(MAKE) install ) || exit 1 ; \
+ fi
+- $(call installdata,ICE_LICENSE,$(prefix))
+- $(call installdata,LICENSE,$(prefix))
++ $(call installdata,ICE_LICENSE,$(install_docdir))
++ $(call installdata,LICENSE,$(install_docdir))
+
+ clean::
+ @if test -d doc ; \
+--- config/Make.rules.old 2006-10-16 09:05:48.000000000 -0400
++++ config/Make.rules 2006-10-16 09:07:30.000000000 -0400
+@@ -11,7 +11,7 @@
+ # Select an installation base directory. The directory will be created
+ # if it does not exist.
+ #
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= $(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+@@ -125,9 +125,9 @@
+ install_bindir = $(prefix)/bin
+
+ install_includedir = $(prefix)/include
+-install_slicedir = $(prefix)/slice
+-install_schemadir = $(prefix)/schema
+-install_docdir = $(prefix)/doc
++install_slicedir = $(prefix)/share/ice-$(VERSION)/slice
++install_schemadir = $(prefix)/share/ice-$(VERSION)/schema
++install_docdir = $(prefix)/share/doc/ice-$(VERSION)
+
+ INSTALL = cp -fp
+ INSTALL_PROGRAM = ${INSTALL}
+@@ -179,8 +179,8 @@
+ BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
+ BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
+
+-DB_FLAGS = $(if $(DB_HOME),-I$(DB_HOME)/include)
+-DB_LIBS = $(if $(DB_HOME),-L$(DB_HOME)/$(libsubdir)) -ldb_cxx
++DB_FLAGS = -I/usr/include/db4.3
++DB_LIBS = -ldb_cxx-4.3
+ DB_RPATH_LINK = $(if $(DB_HOME),$(call rpathlink,$(DB_HOME)/$(libsubdir)))
+
+ EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
+--- config/Make.rules.orig 2006-10-16 09:23:27.000000000 -0400
++++ config/Make.rules 2006-10-16 09:23:34.000000000 -0400
+@@ -17,7 +17,7 @@
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
diff --git a/dev-cpp/ice/ice-3.1.1.ebuild b/dev-cpp/ice/ice-3.1.1.ebuild
new file mode 100644
index 000000000000..b42bb4ceaa95
--- /dev/null
+++ b/dev-cpp/ice/ice-3.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ice-3.1.1.ebuild,v 1.1 2006/10/16 13:38:32 caleb Exp $
+
+inherit eutils
+
+MY_P=${PN/i/I}-${PV}
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.1/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ncurses test debug"
+
+DEPEND="ncurses? ( sys-libs/ncurses sys-libs/readline )
+ test? ( >=dev-lang/python-2.2 )
+ ~sys-libs/db-4.3.29
+ >=dev-libs/openssl-0.9.7"
+RDEPEND=">=dev-libs/expat-1.9
+ >=app-arch/bzip2-1.0"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ built_with_use sys-libs/db nocxx && die "DB must be compiled with C++ support!"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/ice-3.1-patches/ice-makefile-speedup.patch
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use ncurses; then
+ sed -i -e "s# USE_READLINE.*# USE_READLINE := no#g" \
+ ${S}/config/Make.rules || die "Failed to set no readline"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+ make test || die "Test failed"
+}