summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-10-06 18:25:21 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-10-06 18:25:21 +0000
commit2de961d02e85460897318a218dcd9a1f8155d235 (patch)
treea24caf26c29643205e28aefee51fe083aa5b7362 /dev-cpp/libherdstat
parentStable on sparc (diff)
downloadgentoo-2-2de961d02e85460897318a218dcd9a1f8155d235.tar.gz
gentoo-2-2de961d02e85460897318a218dcd9a1f8155d235.tar.bz2
gentoo-2-2de961d02e85460897318a218dcd9a1f8155d235.zip
Initial commit.
(Portage version: 2.0.53_rc4)
Diffstat (limited to 'dev-cpp/libherdstat')
-rw-r--r--dev-cpp/libherdstat/ChangeLog10
-rw-r--r--dev-cpp/libherdstat/Manifest4
-rw-r--r--dev-cpp/libherdstat/files/digest-libherdstat-0.1.0_beta11
-rw-r--r--dev-cpp/libherdstat/libherdstat-0.1.0_beta1.ebuild42
-rw-r--r--dev-cpp/libherdstat/metadata.xml16
5 files changed, 73 insertions, 0 deletions
diff --git a/dev-cpp/libherdstat/ChangeLog b/dev-cpp/libherdstat/ChangeLog
new file mode 100644
index 000000000000..1e6b7fcf5040
--- /dev/null
+++ b/dev-cpp/libherdstat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-cpp/libherdstat
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libherdstat/ChangeLog,v 1.1 2005/10/06 18:25:21 ka0ttic Exp $
+
+*libherdstat-0.1.0_beta1 (06 Oct 2005)
+
+ 06 Oct 2005; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+ +libherdstat-0.1.0_beta1.ebuild:
+ Initial commit.
+
diff --git a/dev-cpp/libherdstat/Manifest b/dev-cpp/libherdstat/Manifest
new file mode 100644
index 000000000000..19311f1b9a28
--- /dev/null
+++ b/dev-cpp/libherdstat/Manifest
@@ -0,0 +1,4 @@
+MD5 a51ded0a0befd8a4582bb9dc1942ef00 ChangeLog 278
+MD5 201bde6172a1da320e27c881b86211d3 files/digest-libherdstat-0.1.0_beta1 77
+MD5 a1a76a7d5b02d38f0f132740b7f4329a libherdstat-0.1.0_beta1.ebuild 1071
+MD5 98dd6c8bcfa84065160f1889043f9ce7 metadata.xml 597
diff --git a/dev-cpp/libherdstat/files/digest-libherdstat-0.1.0_beta1 b/dev-cpp/libherdstat/files/digest-libherdstat-0.1.0_beta1
new file mode 100644
index 000000000000..c53046503416
--- /dev/null
+++ b/dev-cpp/libherdstat/files/digest-libherdstat-0.1.0_beta1
@@ -0,0 +1 @@
+MD5 410adc6e0d6c3e3332667c14aabe2644 libherdstat-0.1.0_beta1.tar.bz2 1600591
diff --git a/dev-cpp/libherdstat/libherdstat-0.1.0_beta1.ebuild b/dev-cpp/libherdstat/libherdstat-0.1.0_beta1.ebuild
new file mode 100644
index 000000000000..a6983c392083
--- /dev/null
+++ b/dev-cpp/libherdstat/libherdstat-0.1.0_beta1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libherdstat/libherdstat-0.1.0_beta1.ebuild,v 1.1 2005/10/06 18:25:21 ka0ttic Exp $
+
+DESCRIPTION="C++ library offering interfaces for portage-related things such as Gentoo-specific XML files, package searching, and version sorting"
+HOMEPAGE="http://developer.berlios.de/projects/libherdstat/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+RESTRICT="primaryuri"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="debug doc curl ncurses static"
+
+RDEPEND=">=dev-libs/xmlwrapp-0.5.0
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ !curl? ( net-misc/wget )"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable static) \
+ $(use_with ncurses) \
+ $(use_with curl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO NEWS
+
+ if use doc ; then
+ dohtml -r doc/${PV}/html/*
+ doman doc/${PV}/man/*/*.[0-9]
+ fi
+}
diff --git a/dev-cpp/libherdstat/metadata.xml b/dev-cpp/libherdstat/metadata.xml
new file mode 100644
index 000000000000..1cd8c27dd121
--- /dev/null
+++ b/dev-cpp/libherdstat/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ka0ttic@gentoo.org</email>
+ <name>Aaron Walker</name>
+ </maintainer>
+ <longdescription lang="en">
+C++ library offering interfaces for portage-related things such as
+Gentoo-specific XML files, package searching, and version sorting. In
+addition, other general-purpose utility classes/functions are offered, such as
+regular expressions, pattern matching, algorithms, and string manipulation.
+ </longdescription>
+</pkgmetadata>
+