summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-17 16:54:33 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-17 16:54:33 +0000
commitb956e5064bf01149bedae3a9e0b681422bca5062 (patch)
tree54c177002c98e6ccec0820fbd01bc4ba309d1f17 /dev-cpp/libxmlpp
parentBumping to third beta release (diff)
downloadgentoo-2-b956e5064bf01149bedae3a9e0b681422bca5062.tar.gz
gentoo-2-b956e5064bf01149bedae3a9e0b681422bca5062.tar.bz2
gentoo-2-b956e5064bf01149bedae3a9e0b681422bca5062.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/libxmlpp')
-rw-r--r--dev-cpp/libxmlpp/ChangeLog8
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.30.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-cpp/libxmlpp/ChangeLog b/dev-cpp/libxmlpp/ChangeLog
index a1cc8bb59329..7379d8d9e38f 100644
--- a/dev-cpp/libxmlpp/ChangeLog
+++ b/dev-cpp/libxmlpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libxmlpp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.93 2010/06/02 19:34:35 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.94 2010/06/17 16:54:33 pacho Exp $
+
+*libxmlpp-2.30.1 (17 Jun 2010)
+
+ 17 Jun 2010; Pacho Ramos <pacho@gentoo.org> +libxmlpp-2.30.1.ebuild:
+ Version bump with documentation fixes, build system rewrite, use mm-common
+ for reference documentation generation and others.
02 Jun 2010; Gilles Dartiguelongue <eva@gentoo.org>
-libxmlpp-2.24.3.ebuild, -libxmlpp-2.26.0.ebuild:
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.30.1.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.30.1.ebuild
new file mode 100644
index 000000000000..56b10fa8ef65
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.30.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.30.1.ebuild,v 1.1 2010/06/17 16:54:33 pacho Exp $
+
+EAPI="3"
+inherit gnome2 eutils
+
+MY_PN="${PN/pp/++}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.1
+ >=dev-cpp/glibmm-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README*"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # don't waste time building the examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm -fr "${ED}"usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/${PV%.*}/html/*
+}