summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-05-10 17:54:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-05-10 17:54:29 +0000
commit52452c61699a4b04be562bb19442396dbe15e5e0 (patch)
tree5e5f0beab78e9348ef358a5a8dfc4cd4f3ac6b12 /dev-cpp/muParser
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-52452c61699a4b04be562bb19442396dbe15e5e0.tar.gz
gentoo-2-52452c61699a4b04be562bb19442396dbe15e5e0.tar.bz2
gentoo-2-52452c61699a4b04be562bb19442396dbe15e5e0.zip
Version bump
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/muParser')
-rw-r--r--dev-cpp/muParser/ChangeLog9
-rw-r--r--dev-cpp/muParser/muParser-2.2.2.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-cpp/muParser/ChangeLog b/dev-cpp/muParser/ChangeLog
index 8265f937b5c6..eb23604196df 100644
--- a/dev-cpp/muParser/ChangeLog
+++ b/dev-cpp/muParser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/muParser
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.23 2011/12/21 08:41:14 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.24 2012/05/10 17:54:28 bicatali Exp $
+
+*muParser-2.2.2 (10 May 2012)
+
+ 10 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +muParser-2.2.2.ebuild:
+ Version bump
21 Dec 2011; Justin Lecher <jlec@gentoo.org> -muParser-1.32-r1.ebuild:
Cleaned old
diff --git a/dev-cpp/muParser/muParser-2.2.2.ebuild b/dev-cpp/muParser/muParser-2.2.2.ebuild
new file mode 100644
index 000000000000..546daa9ff9da
--- /dev/null
+++ b/dev-cpp/muParser/muParser-2.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-2.2.2.ebuild,v 1.1 2012/05/10 17:54:29 bicatali Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_PN=${PN/P/p}
+MY_P=${MY_PN}_v${PV/./}
+
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="http://muparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/P/p}/${PN/P/p}/Version%20${PV}/${PN/P/p}_v${PV//./_}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/${PN/P/p}_v${PV//./_}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.32-build.patch \
+ "${FILESDIR}"/${PN}-1.32-parallel-build.patch
+ sed -i \
+ -e 's:-O2::g' \
+ configure || die
+}
+
+src_configure() {
+ chmod +x configure || die
+ econf $(use_enable test samples)
+}
+
+src_test() {
+ cat > test.sh <<- EOFTEST
+ LD_LIBRARY_PATH=${S}/lib samples/example1/example1 <<- EOF
+ quit
+ EOF
+ EOFTEST
+ sh ./test.sh || die "test failed"
+}
+
+src_install() {
+ default
+ dodoc Changes.txt
+ use doc && dohtml -r docs/html/*
+}