summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-20 19:51:32 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-20 19:51:32 +0000
commit8e353c0ce23bfedf546ab7797c050ea1e8197536 (patch)
tree7c0d98d9771e0da703855250a1095d5f541b4f5c /dev-cpp/muParser
parentunmask >=sci-libs/clapack-3.2.1.-r1 (diff)
downloadgentoo-2-8e353c0ce23bfedf546ab7797c050ea1e8197536.tar.gz
gentoo-2-8e353c0ce23bfedf546ab7797c050ea1e8197536.tar.bz2
gentoo-2-8e353c0ce23bfedf546ab7797c050ea1e8197536.zip
Parallel build fix, #310037, Thanks Kacper Kowalik for patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/muParser')
-rw-r--r--dev-cpp/muParser/ChangeLog8
-rw-r--r--dev-cpp/muParser/files/muParser-1.32-parallel-build.patch15
-rw-r--r--dev-cpp/muParser/muParser-1.32-r1.ebuild52
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-cpp/muParser/ChangeLog b/dev-cpp/muParser/ChangeLog
index e827ddb1c2a5..301a9a422137 100644
--- a/dev-cpp/muParser/ChangeLog
+++ b/dev-cpp/muParser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/muParser
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.13 2010/02/14 20:45:26 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.14 2010/03/20 19:51:30 jlec Exp $
+
+*muParser-1.32-r1 (20 Mar 2010)
+
+ 20 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +muParser-1.32-r1.ebuild, +files/muParser-1.32-parallel-build.patch:
+ Parallel build fix, #310037, Thanks Kacper Kowalik for patch
*muParser-1.32 (14 Feb 2010)
diff --git a/dev-cpp/muParser/files/muParser-1.32-parallel-build.patch b/dev-cpp/muParser/files/muParser-1.32-parallel-build.patch
new file mode 100644
index 000000000000..1681c6e68034
--- /dev/null
+++ b/dev-cpp/muParser/files/muParser-1.32-parallel-build.patch
@@ -0,0 +1,15 @@
+Fixing parallel build issue
+
+http://bugs.gentoo.org/show_bug.cgi?id=310037
+
+--- muparser_v132/Makefile.in
++++ muparser_v132/Makefile.in
+@@ -291,7 +291,7 @@
+ @COND_SHARED_1@ rm -f $(DESTDIR)$(prefix)/$$f; \
+ @COND_SHARED_1@ done
+
+-@COND_SAMPLES_1@$(top_builddir)/samples/example1/example1$(EXEEXT): $(EXAMPLE1_OBJECTS) $(__muParser_lib___depname)
++@COND_SAMPLES_1@$(top_builddir)/samples/example1/example1$(EXEEXT): $(EXAMPLE1_OBJECTS) $(__muParser_lib___depname) lib
+ @COND_SAMPLES_1@ $(CXX) -o $@ $(EXAMPLE1_OBJECTS) -L$(top_builddir)/lib -L$(srcdir)/lib $(LDFLAGS) -lmuparser$(DEBUG_BUILD_POSTFIX) $(LIBS)
+ @COND_SAMPLES_1@
+ @COND_SAMPLES_1@ $(__example1___mac_setfilecmd)
diff --git a/dev-cpp/muParser/muParser-1.32-r1.ebuild b/dev-cpp/muParser/muParser-1.32-r1.ebuild
new file mode 100644
index 000000000000..66fccba446d8
--- /dev/null
+++ b/dev-cpp/muParser/muParser-1.32-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-1.32-r1.ebuild,v 1.1 2010/03/20 19:51:30 jlec Exp $
+
+EAPI=2
+inherit eutils
+
+MY_PN=${PN/P/p}
+MY_P=${MY_PN}_v${PV/./}
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="http://muparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # fix destdir and respect cxxflags
+ # cant really use autotools cause muparser use bakefile
+ # and too lasy to make an ebuild for it.
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-parallel-build.patch
+}
+
+src_configure() {
+ econf $(use_enable test samples)
+}
+
+src_test() {
+ cat > test.sh <<-EOFTEST
+ LD_LIBRARY_PATH=${S}/lib samples/example1/example1 << EOF
+ quit
+ EOF
+ EOFTEST
+ sh ./test.sh || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changes.txt Credits.txt || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r docs/html || die
+ fi
+}