summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-06-17 13:27:14 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-06-17 13:27:14 +0000
commit0823f456c3a7abbb62e61db95338d46989e9c4d2 (patch)
treee10633bcb411a575d4dbd11b196082e024b106ad /dev-cpp
parentRemove old development versions (diff)
downloadgentoo-2-0823f456c3a7abbb62e61db95338d46989e9c4d2.tar.gz
gentoo-2-0823f456c3a7abbb62e61db95338d46989e9c4d2.tar.bz2
gentoo-2-0823f456c3a7abbb62e61db95338d46989e9c4d2.zip
Fix openssl/gnutls selection and build without ssl.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog8
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild (renamed from dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild)19
-rw-r--r--dev-cpp/commoncpp2/files/1.8.1-fix-no-ssl-build.patch12
3 files changed, 30 insertions, 9 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 1638e526cb77..f14c6000f16a 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.56 2013/06/17 13:12:24 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.57 2013/06/17 13:27:14 dev-zero Exp $
+
+*commoncpp2-1.8.1-r1 (17 Jun 2013)
+
+ 17 Jun 2013; Tiziano Müller <dev-zero@gentoo.org> +commoncpp2-1.8.1-r1.ebuild,
+ +files/1.8.1-fix-no-ssl-build.patch, -commoncpp2-1.8.1.ebuild:
+ Fix openssl/gnutls selection and build without ssl.
*commoncpp2-1.8.1 (17 Jun 2013)
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild
index 673cd55966fd..6a9e72a53083 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild,v 1.1 2013/06/17 13:12:24 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild,v 1.1 2013/06/17 13:27:14 dev-zero Exp $
EAPI="5"
@@ -12,11 +12,12 @@ HOMEPAGE="http://www.gnu.org/software/commoncpp/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="debug doc examples ipv6 gnutls static-libs"
+IUSE="debug doc examples ipv6 gnutls ssl static-libs"
+REQUIRED_USE="gnutls? ( ssl )"
-RDEPEND="gnutls? ( dev-libs/libgcrypt
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
+RDEPEND="ssl? ( gnutls? ( dev-libs/libgcrypt
+ net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl ) )
sys-libs/zlib"
DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
${RDEPEND}"
@@ -26,7 +27,8 @@ src_prepare() {
"${FILESDIR}/1.8.1-configure_detect_netfilter.patch" \
"${FILESDIR}/1.8.0-glibc212.patch" \
"${FILESDIR}/1.8.1-autoconf-update.patch" \
- "${FILESDIR}/1.8.1-fix-buffer-overflow.patch"
+ "${FILESDIR}/1.8.1-fix-buffer-overflow.patch" \
+ "${FILESDIR}/1.8.1-fix-no-ssl-build.patch"
eautoreconf
}
@@ -35,10 +37,11 @@ src_configure() {
sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
local myconf
+
if use gnutls; then
- myconf="--with-gnutls --without-openssl"
+ myconf="--with-gnutls"
else
- myconf="--without-gnutls --with-openssl"
+ use ssl && myconf="--with-openssl"
fi
econf \
diff --git a/dev-cpp/commoncpp2/files/1.8.1-fix-no-ssl-build.patch b/dev-cpp/commoncpp2/files/1.8.1-fix-no-ssl-build.patch
new file mode 100644
index 000000000000..768dd20ea68d
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.8.1-fix-no-ssl-build.patch
@@ -0,0 +1,12 @@
+diff --git a/src/applog.cpp b/src/applog.cpp
+index b5c02b0..d5b1f9e 100755
+--- a/src/applog.cpp
++++ b/src/applog.cpp
+@@ -45,6 +45,7 @@
+ #include <cstdlib>
+ #include <stdarg.h>
+ #include <errno.h>
++#include <sys/stat.h>
+
+ // TODO sc: test if has to move up now that it is into commoncpp
+ // NOTE: the order of inclusion is important do not move following include line