summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-06-17 13:12:24 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-06-17 13:12:24 +0000
commit9b886ad9d93fc3f658b138909a6755bbc3a722db (patch)
tree89528e3460920aed5d050d0ec66a31a3c03939e8 /dev-cpp
parentVersion bump (bug #454704), also patch commoncpp2 to fix bugs #421383 (buffer... (diff)
downloadgentoo-2-9b886ad9d93fc3f658b138909a6755bbc3a722db.tar.gz
gentoo-2-9b886ad9d93fc3f658b138909a6755bbc3a722db.tar.bz2
gentoo-2-9b886ad9d93fc3f658b138909a6755bbc3a722db.zip
Version bump (bug #454704), also patch commoncpp2 to fix bugs #421383 (buffer overflow) and #467628 (automake-1.13 build failures). Update ebuild to EAPI 5 and add USE=static-libs (bug #439302). Drop old versions and their patches.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog17
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild73
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild74
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild (renamed from dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild)44
-rw-r--r--dev-cpp/commoncpp2/files/1.6.1-autoconf.patch11
-rw-r--r--dev-cpp/commoncpp2/files/1.6.2-autoconf.patch11
-rw-r--r--dev-cpp/commoncpp2/files/1.6.3-autoconf.patch12
-rw-r--r--dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch49
-rw-r--r--dev-cpp/commoncpp2/files/1.8.1-configure_detect_netfilter.patch14
-rw-r--r--dev-cpp/commoncpp2/files/1.8.1-fix-buffer-overflow.patch13
-rw-r--r--dev-cpp/commoncpp2/files/commoncpp2-1.6.3-glibc-2.10.patch21
11 files changed, 110 insertions, 229 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 4f931a1a173f..1638e526cb77 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-cpp/commoncpp2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.55 2010/10/23 22:24:23 halcy0n Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.56 2013/06/17 13:12:24 dev-zero Exp $
+
+*commoncpp2-1.8.1 (17 Jun 2013)
+
+ 17 Jun 2013; Tiziano Müller <dev-zero@gentoo.org> +commoncpp2-1.8.1.ebuild,
+ +files/1.8.1-autoconf-update.patch,
+ +files/1.8.1-configure_detect_netfilter.patch,
+ +files/1.8.1-fix-buffer-overflow.patch, -commoncpp2-1.6.1.ebuild,
+ -commoncpp2-1.6.2.ebuild, -commoncpp2-1.6.3.ebuild,
+ -files/1.6.1-autoconf.patch, -files/1.6.2-autoconf.patch,
+ -files/1.6.3-autoconf.patch, -files/commoncpp2-1.6.3-glibc-2.10.patch:
+ Version bump (bug #454704), also patch commoncpp2 to fix bugs #421383 (buffer
+ overflow) and #467628 (automake-1.13 build failures). Update ebuild to EAPI 5
+ and add USE=static-libs (bug #439302). Drop old versions and their patches.
23 Oct 2010; Mark Loeser <halcy0n@gentoo.org> commoncpp2-1.8.0.ebuild:
Mark stable on ppc64; bug #321931
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild
deleted file mode 100644
index 615d2751852f..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild,v 1.8 2009/03/07 14:57:13 armin76 Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
-SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/commoncpp/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="debug doc examples ipv6 gnutls"
-
-RDEPEND="gnutls? ( dev-libs/libgcrypt
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PV}-gcc42_atomicity.patch"
- epatch "${FILESDIR}/${PV}-autoconf.patch"
- epatch "${FILESDIR}/1.6.2-configure_detect_netfilter.patch"
- AT_M4DIR="m4" eautoreconf
-}
-
-src_compile() {
- use doc || \
- sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
-
- local myconf
- use gnutls || myconf="--with-openssl"
-
- econf \
- $(use_enable debug) \
- $(use_with ipv6 ) \
- ${myconf} || die "econf failed"
- emake -j1 || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- cd demo
- doins *.cpp *.h *.xml README
- fi
-}
-
-pkg_postinst() {
- ewarn "There's a change in the ABI between version 1.5.x and 1.6.x, please"
- ewarn "run the following command to find broken packages and rebuild them:"
- ewarn " revdep-rebuild --library=libccext2-1.5.so"
-}
-
-# Some of the tests hang forever
-#src_test() {
-# cd "${S}/tests"
-# emake || die "emake tests failed"
-# ./test.sh || die "tests failed"
-#}
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild
deleted file mode 100644
index 0c467b3d230e..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild,v 1.6 2009/03/22 17:45:22 maekke Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
-SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/commoncpp/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="debug doc examples ipv6 gnutls"
-
-RDEPEND="gnutls? ( dev-libs/libgcrypt
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/1.6.1-gcc42_atomicity.patch"
- epatch "${FILESDIR}/${PV}-autoconf.patch"
- epatch "${FILESDIR}/${PV}-configure_detect_netfilter.patch" # bug 236177
-
- AT_M4DIR="m4" eautoreconf
-}
-
-src_compile() {
- use doc || \
- sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
-
- local myconf
- use gnutls || myconf="--with-openssl"
-
- econf \
- $(use_enable debug) \
- $(use_with ipv6 ) \
- ${myconf} || die "econf failed"
- emake -j1 || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- cd demo
- doins *.cpp *.h *.xml README
- fi
-}
-
-pkg_postinst() {
- ewarn "There's a change in the ABI between version 1.5.x and 1.6.x, please"
- ewarn "run the following command to find broken packages and rebuild them:"
- ewarn " revdep-rebuild --library=libccext2-1.5.so"
-}
-
-# Some of the tests hang forever
-#src_test() {
-# cd "${S}/tests"
-# emake || die "emake tests failed"
-# ./test.sh || die "tests failed"
-#}
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild
index bc224b0d2b18..673cd55966fd 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild,v 1.4 2009/07/30 07:58:34 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.8.1.ebuild,v 1.1 2013/06/17 13:12:24 dev-zero Exp $
+
+EAPI="5"
inherit eutils autotools
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+DESCRIPTION="C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/commoncpp/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="debug doc examples ipv6 gnutls"
+IUSE="debug doc examples ipv6 gnutls static-libs"
RDEPEND="gnutls? ( dev-libs/libgcrypt
net-libs/gnutls )
@@ -19,19 +21,16 @@ RDEPEND="gnutls? ( dev-libs/libgcrypt
DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/1.6.1-gcc42_atomicity.patch"
- epatch "${FILESDIR}/${PV}-autoconf.patch"
- epatch "${FILESDIR}/1.6.2-configure_detect_netfilter.patch" # bug 236177
- epatch "${FILESDIR}/${P}-glibc-2.10.patch"
-
- AT_M4DIR="m4" eautoreconf
+src_prepare() {
+ epatch \
+ "${FILESDIR}/1.8.1-configure_detect_netfilter.patch" \
+ "${FILESDIR}/1.8.0-glibc212.patch" \
+ "${FILESDIR}/1.8.1-autoconf-update.patch" \
+ "${FILESDIR}/1.8.1-fix-buffer-overflow.patch"
+ eautoreconf
}
-src_compile() {
+src_configure() {
use doc || \
sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
@@ -44,15 +43,16 @@ src_compile() {
econf \
$(use_enable debug) \
- $(use_with ipv6 ) \
+ $(use_with ipv6) \
+ $(use_enable static-libs static) \
${myconf}
- emake -j1 || die "emake failed"
}
src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
+ prune_libtool_files
- dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
+ dodoc COPYING.addendum
# Only install html docs
# man and latex available, but seems a little wasteful
@@ -65,12 +65,6 @@ src_install () {
fi
}
-pkg_postinst() {
- ewarn "There's a change in the ABI between version 1.5.x and 1.6.x, please"
- ewarn "run the following command to find broken packages and rebuild them:"
- ewarn " revdep-rebuild --library=libccext2-1.5.so"
-}
-
# Some of the tests hang forever
#src_test() {
# cd "${S}/tests"
diff --git a/dev-cpp/commoncpp2/files/1.6.1-autoconf.patch b/dev-cpp/commoncpp2/files/1.6.1-autoconf.patch
deleted file mode 100644
index b2befd567582..000000000000
--- a/dev-cpp/commoncpp2/files/1.6.1-autoconf.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2008-05-06 10:41:53.000000000 +0200
-+++ configure.ac 2008-05-06 10:42:19.000000000 +0200
-@@ -10,6 +10,8 @@
-
- AC_INIT(src/thread.cpp)
-
-+m4_pattern_allow([^LT_VERSION$])
-+
- VERSION="1.6.1"
- LT_RELEASE="1.6"
- LT_VERSION="0:1"
diff --git a/dev-cpp/commoncpp2/files/1.6.2-autoconf.patch b/dev-cpp/commoncpp2/files/1.6.2-autoconf.patch
deleted file mode 100644
index fcba56dccb4b..000000000000
--- a/dev-cpp/commoncpp2/files/1.6.2-autoconf.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2008-05-06 10:41:53.000000000 +0200
-+++ configure.ac 2008-05-06 10:42:19.000000000 +0200
-@@ -10,6 +10,8 @@
-
- AC_INIT(src/thread.cpp)
-
-+m4_pattern_allow([^LT_VERSION$])
-+
- VERSION="1.6.2"
- LT_RELEASE="1.6"
- LT_VERSION="0:2"
diff --git a/dev-cpp/commoncpp2/files/1.6.3-autoconf.patch b/dev-cpp/commoncpp2/files/1.6.3-autoconf.patch
deleted file mode 100644
index a94ac91d8b03..000000000000
--- a/dev-cpp/commoncpp2/files/1.6.3-autoconf.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur commoncpp2-1.6.3.orig/configure.ac commoncpp2-1.6.3/configure.ac
---- commoncpp2-1.6.3.orig/configure.ac 2009-03-07 16:03:44.000000000 +0100
-+++ commoncpp2-1.6.3/configure.ac 2009-03-07 16:04:25.000000000 +0100
-@@ -10,6 +10,8 @@
-
- AC_INIT(src/thread.cpp)
-
-+m4_pattern_allow([^LT_VERSION$])
-+
- VERSION="1.6.3"
- LT_RELEASE="1.6"
- LT_VERSION="0:2"
diff --git a/dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch b/dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch
new file mode 100644
index 000000000000..d50a3405ee6c
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch
@@ -0,0 +1,49 @@
+diff --git a/configure.ac b/configure.ac
+index 80518db..64221e0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,8 @@
+ # WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+-AC_INIT(src/thread.cpp)
++AC_INIT
++AC_CONFIG_SRCDIR([src/thread.cpp])
+ AC_CONFIG_MACRO_DIR([m4])
+ m4_pattern_allow(LT_VERSION)
+
+@@ -81,17 +82,17 @@ fi
+ AC_SUBST(ccincludedir)
+
+ AC_CONFIG_AUX_DIR(autoconf)
+-AC_CANONICAL_SYSTEM
++AC_CANONICAL_TARGET
+ AC_PROG_CPP
+ AC_PROG_CC
+ AC_PROG_CXXCPP
+ AC_PROG_CXX
+ OST_PROG_CC_POSIX
+ NP_PROG_MSC
+-AC_LIBTOOL_WIN32_DLL
+-AM_PROG_LIBTOOL
++
++LT_INIT([win32-dll,disable-static])
+ AM_INIT_AUTOMAKE(commoncpp2, [$VERSION])
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS([config.h])
+
+ AC_C_RESTRICT
+ AC_C_VOLATILE
+@@ -408,10 +409,11 @@ LIB_MAJOR=`echo $LT_VERSION | sed -e 's/[:].*$//'`
+ AC_SUBST(LIB_VERSION)
+ AC_SUBST(LIB_MAJOR)
+
+-AC_OUTPUT([src/ccgnu2-config src/libccext2.pc src/libccgnu2.pc
++AC_CONFIG_FILES([src/ccgnu2-config src/libccext2.pc src/libccgnu2.pc
+ src/Makefile w32/Makefile w32/vs2008/Makefile w32/vs2008/ccext2.vcproj w32/vs2008/ccgnu2.vcproj w32/vs2008/common.sln m4/Makefile doc/Doxyfile
+ doc/Makefile demo/Makefile inc/Makefile inc/cc++/Makefile Makefile
+ commoncpp2.spec tests/Makefile commoncpp2.list w32/ccgnu2.dsp w32/ccext2.dsp w32/ccgnu2.vcproj w32/ccext2.vcproj])
++AC_OUTPUT
+
+ # if test ! -f inc/cc++/thread.h ; then
+ # cp ${srcdir}/inc/cc++/*.h inc/cc++ ; fi
diff --git a/dev-cpp/commoncpp2/files/1.8.1-configure_detect_netfilter.patch b/dev-cpp/commoncpp2/files/1.8.1-configure_detect_netfilter.patch
new file mode 100644
index 000000000000..b6ebf0e0f4a4
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.8.1-configure_detect_netfilter.patch
@@ -0,0 +1,14 @@
+diff --git a/m4/ost_socket.m4 b/m4/ost_socket.m4
+index bd9db7c..122c938 100644
+--- a/m4/ost_socket.m4
++++ b/m4/ost_socket.m4
+@@ -93,6 +93,9 @@ AC_DEFUN([OST_SYS_SOCKET],[
+ AC_CHECK_HEADERS([linux/netfilter_ipv4.h linux/netfilter_ipv6.h],,,
+ [#ifdef HAVE_LIMITS_H
+ #include <limits.h>
++ #endif
++ #ifdef HAVE_NETINET_IN_H
++ #include <netinet/in.h>
+ #endif])
+ if test "$ac_cv_header_linux_netfilter_ipv4_h" = "yes" &&
+ [ test "$ac_cv_header_linux_netfilter_ipv6_h" = "yes" &&
diff --git a/dev-cpp/commoncpp2/files/1.8.1-fix-buffer-overflow.patch b/dev-cpp/commoncpp2/files/1.8.1-fix-buffer-overflow.patch
new file mode 100644
index 000000000000..e68b00576cdb
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.8.1-fix-buffer-overflow.patch
@@ -0,0 +1,13 @@
+diff --git a/src/inaddr.cpp b/src/inaddr.cpp
+index 5a4b9c4..50127f3 100644
+--- a/src/inaddr.cpp
++++ b/src/inaddr.cpp
+@@ -333,7 +333,7 @@ void IPV4Address::setAddress(const char *host)
+ if(ipaddr)
+ delete[] ipaddr;
+ ipaddr = new struct in_addr[1];
+- memset((void *)&ipaddr[0], 0, sizeof(ipaddr));
++ memset((void *)&ipaddr[0], 0, sizeof(*ipaddr));
+ return;
+ }
+
diff --git a/dev-cpp/commoncpp2/files/commoncpp2-1.6.3-glibc-2.10.patch b/dev-cpp/commoncpp2/files/commoncpp2-1.6.3-glibc-2.10.patch
deleted file mode 100644
index 1f7d445d8ae9..000000000000
--- a/dev-cpp/commoncpp2/files/commoncpp2-1.6.3-glibc-2.10.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naurp commoncpp2-1.6.3-orig/src/cidr.cpp commoncpp2-1.6.3/src/cidr.cpp
---- commoncpp2-1.6.3-orig/src/cidr.cpp 2008-06-23 07:02:09.000000000 -0600
-+++ commoncpp2-1.6.3/src/cidr.cpp 2009-07-30 01:17:49.276744991 -0600
-@@ -198,7 +198,7 @@ void IPV4Cidr::set(const char *cp)
- memset(&netmask, 0, sizeof(netmask));
- bitset((bit_t *)&netmask, getMask(cp));
- setString(cbuf, sizeof(cbuf), cp);
-- ep = strchr(cp, '/');
-+ ep = (char *)strchr(cp, '/');
- if(ep)
- *ep = 0;
-
-@@ -326,7 +326,7 @@ void IPV6Cidr::set(const char *cp)
- memset(&netmask, 0, sizeof(netmask));
- bitset((bit_t *)&netmask, getMask(cp));
- setString(cbuf, sizeof(cbuf), cp);
-- ep = strchr(cp, '/');
-+ ep = (char *)strchr(cp, '/');
- if(ep)
- *ep = 0;
-