summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2006-01-20 04:16:21 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2006-01-20 04:16:21 +0000
commita927e53e4377ab8d5b0d665adc0c28190d60602b (patch)
treebbc126d901ce1b50951cdf6c577d668feb9aa94f /dev-cpp
parentApplied small patch to ebuild to get rid of insecure RUNPATHs in enhance. Thi... (diff)
downloadgentoo-2-a927e53e4377ab8d5b0d665adc0c28190d60602b.tar.gz
gentoo-2-a927e53e4377ab8d5b0d665adc0c28190d60602b.tar.bz2
gentoo-2-a927e53e4377ab8d5b0d665adc0c28190d60602b.zip
New version(Portage version: 2.1_pre3-r1 Death to the demoness Allegra Gellar!)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libebt/ChangeLog7
-rw-r--r--dev-cpp/libebt/Manifest12
-rw-r--r--dev-cpp/libebt/files/digest-libebt-1.2.21
-rw-r--r--dev-cpp/libebt/libebt-1.2.2.ebuild28
4 files changed, 37 insertions, 11 deletions
diff --git a/dev-cpp/libebt/ChangeLog b/dev-cpp/libebt/ChangeLog
index 82c4aac1f378..766558e23efd 100644
--- a/dev-cpp/libebt/ChangeLog
+++ b/dev-cpp/libebt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libebt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/ChangeLog,v 1.13 2006/01/16 12:31:15 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/ChangeLog,v 1.14 2006/01/20 04:16:21 ciaranm Exp $
+
+*libebt-1.2.2 (20 Jan 2006)
+
+ 20 Jan 2006; Ciaran McCreesh <ciaranm@gentoo.org> +libebt-1.2.2.ebuild:
+ New version
16 Jan 2006; Aaron Walker <ka0ttic@gentoo.org> libebt-1.2.1.ebuild:
Added ~mips.
diff --git a/dev-cpp/libebt/Manifest b/dev-cpp/libebt/Manifest
index 78e054d5bdcb..18660d651334 100644
--- a/dev-cpp/libebt/Manifest
+++ b/dev-cpp/libebt/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 02367d1d92e4c019097d3a2e8e4b14ff ChangeLog 1613
MD5 786cc3956463cc0e30923e345f715881 files/digest-libebt-1.1.0 65
MD5 2ab7b111ff831610b3bbf2573349439b files/digest-libebt-1.2.0 65
MD5 cdc68cbdeff730b875b64b291d5df020 files/digest-libebt-1.2.1 65
+MD5 6ec17bffc212683636f10d15eabd6dbf files/digest-libebt-1.2.2 65
MD5 1266ac70f6598fbb24bf2a26b7007a7b libebt-1.1.0.ebuild 828
MD5 d57f9e87ab460e7e6296a3bf5057609a libebt-1.2.0.ebuild 845
MD5 d485b3a31bf3010e2f65d82d9b4ddeaf libebt-1.2.1.ebuild 859
+MD5 d485b3a31bf3010e2f65d82d9b4ddeaf libebt-1.2.2.ebuild 859
MD5 49b5ca6a324b8f95eba6721c1e5e7793 metadata.xml 582
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDy5IuEZCkKN40op4RAvopAJ9VzR/bAo6VjoXxIV9OF5pH8M6I2QCdF8BL
-3Io0VoYHXgGGrLBveQbkZiE=
-=a7jB
------END PGP SIGNATURE-----
diff --git a/dev-cpp/libebt/files/digest-libebt-1.2.2 b/dev-cpp/libebt/files/digest-libebt-1.2.2
new file mode 100644
index 000000000000..93b518f2a120
--- /dev/null
+++ b/dev-cpp/libebt/files/digest-libebt-1.2.2
@@ -0,0 +1 @@
+MD5 32a6cdce4e3ad5e4ea2874babe7e4f61 libebt-1.2.2.tar.bz2 144750
diff --git a/dev-cpp/libebt/libebt-1.2.2.ebuild b/dev-cpp/libebt/libebt-1.2.2.ebuild
new file mode 100644
index 000000000000..1555844d03a0
--- /dev/null
+++ b/dev-cpp/libebt/libebt-1.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/libebt-1.2.2.ebuild,v 1.1 2006/01/20 04:16:21 ciaranm Exp $
+
+DESCRIPTION="A pure C++ template library that provides a clean way of getting human-readable backtrace messages."
+HOMEPAGE="http://libebt.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+RESTRICT="primaryuri"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ use doc && { emake doxygen || die "failed to build API docs" ; }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README
+ use doc && dohtml -r doc/html/*
+}