summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 13:19:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 13:19:49 +0000
commitb7831fcb209e08da0638fe9bff53baa83e6d22d0 (patch)
treeb7d500b479db7fe092bdfed3734c150ae90c92fb /dev-cpp
parentStable on sparc (diff)
downloadgentoo-2-b7831fcb209e08da0638fe9bff53baa83e6d22d0.tar.gz
gentoo-2-b7831fcb209e08da0638fe9bff53baa83e6d22d0.tar.bz2
gentoo-2-b7831fcb209e08da0638fe9bff53baa83e6d22d0.zip
Added mxmlplus snapshot from CVS. Moved from dev-libs/mxmlplus to dev-cpp/libmxmlplus.
(Portage version: 2529-svn)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libmxmlplus/ChangeLog21
-rw-r--r--dev-cpp/libmxmlplus/Manifest4
-rw-r--r--dev-cpp/libmxmlplus/files/digest-libmxmlplus-0.9.2_p200601111
-rw-r--r--dev-cpp/libmxmlplus/libmxmlplus-0.9.2_p20060111.ebuild41
-rw-r--r--dev-cpp/libmxmlplus/metadata.xml10
5 files changed, 77 insertions, 0 deletions
diff --git a/dev-cpp/libmxmlplus/ChangeLog b/dev-cpp/libmxmlplus/ChangeLog
new file mode 100644
index 000000000000..7655f49b54cf
--- /dev/null
+++ b/dev-cpp/libmxmlplus/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for dev-libs/mxmlplus
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libmxmlplus/ChangeLog,v 1.1 2006/01/11 13:19:49 flameeyes Exp $
+
+*libmxmlplus-0.9.2_p20060111 (11 Jan 2006)
+
+ 11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ +libmxmlplus-0.9.2_p20060111.ebuild:
+ Added mxmlplus snapshot from CVS. Moved from dev-libs/mxmlplus to
+ dev-cpp/libmxmlplus.
+
+ 21 Sep 2005; Mark Loeser <halcy0n@gentoo.org> metadata.xml:
+ Putting under cpp herd, adding Flameeyes as primary maintainer
+
+*mxmlplus-0.9.2 (07 Nov 2004)
+
+ 07 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+ +files/mxmlplus-0.9.2-fixblanks.patch, +mxmlplus-0.9.2.ebuild:
+ Initial import. Ebuild submitted by Diego 'Flameeyes' Pettenò
+ <dgp85@users.sourceforge.net>; bug #59979.
+
diff --git a/dev-cpp/libmxmlplus/Manifest b/dev-cpp/libmxmlplus/Manifest
new file mode 100644
index 000000000000..76c5593189fc
--- /dev/null
+++ b/dev-cpp/libmxmlplus/Manifest
@@ -0,0 +1,4 @@
+MD5 7570d0fd47a33b566452609b5976c25d ChangeLog 607
+MD5 99d273f2248e608149e1c653aff2a3a3 files/digest-libmxmlplus-0.9.2_p20060111 79
+MD5 a2c2e77441b7c584a9200a7aa1775a9d libmxmlplus-0.9.2_p20060111.ebuild 769
+MD5 c5dc16f20f72291d7a931b2e97d244d8 metadata.xml 487
diff --git a/dev-cpp/libmxmlplus/files/digest-libmxmlplus-0.9.2_p20060111 b/dev-cpp/libmxmlplus/files/digest-libmxmlplus-0.9.2_p20060111
new file mode 100644
index 000000000000..786e0202f245
--- /dev/null
+++ b/dev-cpp/libmxmlplus/files/digest-libmxmlplus-0.9.2_p20060111
@@ -0,0 +1 @@
+MD5 d3cb99df6cfee776694739693326114f libmxmlplus-0.9.2_p20060111.tar.gz 344116
diff --git a/dev-cpp/libmxmlplus/libmxmlplus-0.9.2_p20060111.ebuild b/dev-cpp/libmxmlplus/libmxmlplus-0.9.2_p20060111.ebuild
new file mode 100644
index 000000000000..3aaef9c03165
--- /dev/null
+++ b/dev-cpp/libmxmlplus/libmxmlplus-0.9.2_p20060111.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libmxmlplus/libmxmlplus-0.9.2_p20060111.ebuild,v 1.1 2006/01/11 13:19:49 flameeyes Exp $
+
+inherit libtool
+
+DESCRIPTION="Minimal XML DOM Library"
+
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://mxml.sourceforge.net/"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --enable-shared \
+ $(use_enable doc) \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use doc; then
+ dodir /usr/share/doc/${PF}
+ dohtml -r ${S}/doc/html/*
+ fi
+}
diff --git a/dev-cpp/libmxmlplus/metadata.xml b/dev-cpp/libmxmlplus/metadata.xml
new file mode 100644
index 000000000000..2b394fbca024
--- /dev/null
+++ b/dev-cpp/libmxmlplus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <name>Diego Pettenò</name>
+ </maintainer>
+ <longdescription lang="en">MXMLPlus is a C++ library based on the engine of MXML (but integrated with stl:: classes) that merges the power and DOM concepts you find in MXML with a real object oriented environment.</longdescription>
+</pkgmetadata>