summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-08-03 12:49:30 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-08-03 12:49:30 +0000
commitf5000c4b051c0c82a8c6fa0f5cfe573839682442 (patch)
treec5ef08771a865049c55ff593fe182c6a9eaa76ec /dev-cpp
parentVersion bump (0.9.0). Marked version 0.8.0 stable for x86. Wiped out older ve... (diff)
downloadgentoo-2-f5000c4b051c0c82a8c6fa0f5cfe573839682442.tar.gz
gentoo-2-f5000c4b051c0c82a8c6fa0f5cfe573839682442.tar.bz2
gentoo-2-f5000c4b051c0c82a8c6fa0f5cfe573839682442.zip
Remove building of test and demos during normal compilation. Speeds things up tremendously
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ice/ChangeLog7
-rw-r--r--dev-cpp/ice/files/ice-3.1-patches/ice-makefile-speedup.patch17
-rw-r--r--dev-cpp/ice/ice-3.1.0-r6.ebuild7
3 files changed, 29 insertions, 2 deletions
diff --git a/dev-cpp/ice/ChangeLog b/dev-cpp/ice/ChangeLog
index 4ec62f01fc53..ca7a1246297a 100644
--- a/dev-cpp/ice/ChangeLog
+++ b/dev-cpp/ice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/ice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.9 2006/07/31 13:37:49 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.10 2006/08/03 12:49:30 caleb Exp $
+
+ 03 Aug 2006; Caleb Tennis <caleb@gentoo.org>
+ +files/ice-3.1-patches/ice-makefile-speedup.patch, ice-3.1.0-r6.ebuild:
+ Remove building of test and demos during normal compilation. Speeds things
+ up tremendously
*ice-3.1.0-r6 (31 Jul 2006)
diff --git a/dev-cpp/ice/files/ice-3.1-patches/ice-makefile-speedup.patch b/dev-cpp/ice/files/ice-3.1-patches/ice-makefile-speedup.patch
new file mode 100644
index 000000000000..6c00214968a8
--- /dev/null
+++ b/dev-cpp/ice/files/ice-3.1-patches/ice-makefile-speedup.patch
@@ -0,0 +1,17 @@
+--- Makefile.orig 2006-08-03 08:11:09.000000000 -0400
++++ Makefile 2006-08-03 08:12:06.000000000 -0400
+@@ -11,7 +11,7 @@
+
+ include $(top_srcdir)/config/Make.rules
+
+-SUBDIRS = config src include test demo slice
++SUBDIRS = config src include slice
+
+ INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
+
+@@ -57,4 +57,5 @@
+ fi
+
+ test::
++ @( cd test && $(MAKE) ) || exit 1
+ @python $(top_srcdir)/allTests.py
diff --git a/dev-cpp/ice/ice-3.1.0-r6.ebuild b/dev-cpp/ice/ice-3.1.0-r6.ebuild
index 2f50f211e0be..1552cad3f1e9 100644
--- a/dev-cpp/ice/ice-3.1.0-r6.ebuild
+++ b/dev-cpp/ice/ice-3.1.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ice-3.1.0-r6.ebuild,v 1.1 2006/07/31 13:37:49 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ice-3.1.0-r6.ebuild,v 1.2 2006/08/03 12:49:30 caleb Exp $
inherit eutils
@@ -39,6 +39,7 @@ src_unpack() {
epatch "${FILESDIR}"/ice-3.1-patches/patch.icegrid.txt
epatch "${FILESDIR}"/ice-3.1-patches/patch.icegrid-5.txt
epatch "${FILESDIR}"/ice-3.1-patches/patch.slice2cpp.txt
+ epatch "${FILESDIR}"/ice-3.1-patches/ice-makefile-speedup.patch
if use amd64; then
sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
@@ -63,3 +64,7 @@ src_unpack() {
src_install() {
make DESTDIR="${D}" install || die "Install Failed!"
}
+
+src_test() {
+ make test || die "Test failed"
+}