summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2007-06-05 22:58:46 +0000
committerIlya Volynets <iluxa@gentoo.org>2007-06-05 22:58:46 +0000
commitf8209c81e50a1e07cb0a83f94636dc38abae2b72 (patch)
tree7073af1c00300cd933a860d2468888ba739a0784 /dev-cpp
parentVersion bump. (diff)
downloadgentoo-2-f8209c81e50a1e07cb0a83f94636dc38abae2b72.tar.gz
gentoo-2-f8209c81e50a1e07cb0a83f94636dc38abae2b72.tar.bz2
gentoo-2-f8209c81e50a1e07cb0a83f94636dc38abae2b72.zip
SPTK 3.5.1 is out
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/files/digest-sptk-3.5.13
-rw-r--r--dev-cpp/sptk/sptk-3.5.1.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index b3f9ab997127..c3295efd0b2f 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.23 2007/03/13 23:01:43 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.24 2007/06/05 22:58:46 iluxa Exp $
+
+*sptk-3.5.1 (05 Jun 2007)
+
+ 05 Jun 2007; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.1.ebuild:
+ 3.5.1 is out
*sptk-3.4.1 (13 Mar 2007)
diff --git a/dev-cpp/sptk/files/digest-sptk-3.5.1 b/dev-cpp/sptk/files/digest-sptk-3.5.1
new file mode 100644
index 000000000000..aba09dd32e54
--- /dev/null
+++ b/dev-cpp/sptk/files/digest-sptk-3.5.1
@@ -0,0 +1,3 @@
+MD5 2d65be83dc076a1f1f61b7fb41da96dc sptk-3.5.1.tbz2 5089003
+RMD160 96f51f8f140f0731d89ec4ec6e6d3619d57be233 sptk-3.5.1.tbz2 5089003
+SHA256 f2acebb26f890467c3797d48c95be887f0210c537f5ab114e0cdb6daf3ea8465 sptk-3.5.1.tbz2 5089003
diff --git a/dev-cpp/sptk/sptk-3.5.1.ebuild b/dev-cpp/sptk/sptk-3.5.1.ebuild
new file mode 100644
index 000000000000..7b42df43a12e
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2006-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.1.ebuild,v 1.1 2007/06/05 22:58:46 iluxa Exp $
+
+inherit autotools
+
+IUSE="fltk odbc doc sqlite3 excel"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( FLTK GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="fltk? ( x11-libs/fltk )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # This fixes double ./configure run
+ eautoreconf
+}
+
+src_compile() {
+
+ local myconf
+ myconf="--enable-shared"
+
+ econf \
+ --prefix=/usr \
+ `use_enable odbc` \
+ `use_enable fltk` \
+ `use_enable sqlite3` \
+ `use_enable excel` \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r ${S}/docs/* ${D}/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr ${D}/usr/share/doc/${PF}/latex
+ cp -r ${S}/pictures ${D}/usr/share/doc/${PF}
+ fi
+}