summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2010-04-27 18:43:25 +0000
committerJesus Rivero <neurogeek@gentoo.org>2010-04-27 18:43:25 +0000
commitfe47b28243e6c7ad17518a5f0c016f5ab37a7fd1 (patch)
tree505df6827991334798e6e1a43c4c275ede84b2a5 /dev-db/desktopcouch
parentold (diff)
downloadgentoo-2-fe47b28243e6c7ad17518a5f0c016f5ab37a7fd1.tar.gz
gentoo-2-fe47b28243e6c7ad17518a5f0c016f5ab37a7fd1.tar.bz2
gentoo-2-fe47b28243e6c7ad17518a5f0c016f5ab37a7fd1.zip
Fixed dependency for dev-python/couchdb-python wrt bug #315743. Fixed python ebuild related code wrt bug #312135. Removed older versions.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-db/desktopcouch')
-rw-r--r--dev-db/desktopcouch/ChangeLog11
-rw-r--r--dev-db/desktopcouch/desktopcouch-0.6.4.ebuild51
-rw-r--r--dev-db/desktopcouch/files/desktopcouch-0.6.4-setup_hardlinks.patch (renamed from dev-db/desktopcouch/files/desktopcouch-setup_hardlinks.patch)13
3 files changed, 68 insertions, 7 deletions
diff --git a/dev-db/desktopcouch/ChangeLog b/dev-db/desktopcouch/ChangeLog
index 8c82d6f53f21..21b38e792879 100644
--- a/dev-db/desktopcouch/ChangeLog
+++ b/dev-db/desktopcouch/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/desktopcouch
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/ChangeLog,v 1.2 2010/04/01 02:22:49 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/ChangeLog,v 1.3 2010/04/27 18:43:25 neurogeek Exp $
+
+*desktopcouch-0.6.4 (27 Apr 2010)
+
+ 27 Apr 2010; Jesus Rivero <neurogeek@gentoo.org>
+ +desktopcouch-0.6.4.ebuild,
+ +files/desktopcouch-0.6.4-setup_hardlinks.patch,
+ -files/desktopcouch-setup_hardlinks.patch:
+ Fixed dependency for dev-python/couchdb-python wrt bug #315743. Fixed
+ python ebuild related code wrt bug #312135. Removed older versions.
*desktopcouch-0.6.1-r1 (01 Apr 2010)
diff --git a/dev-db/desktopcouch/desktopcouch-0.6.4.ebuild b/dev-db/desktopcouch/desktopcouch-0.6.4.ebuild
new file mode 100644
index 000000000000..18f6e58a28d8
--- /dev/null
+++ b/dev-db/desktopcouch/desktopcouch-0.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/desktopcouch-0.6.4.ebuild,v 1.1 2010/04/27 18:43:25 neurogeek Exp $
+
+PYTHONDEPEND="2"
+EAPI="2"
+
+inherit distutils eutils
+
+DESCRIPTION="Desktop-oriented interface to CouchDB"
+HOMEPAGE="https://launchpad.net/desktopcouch"
+SRC_URI="http://launchpad.net/desktopcouch/trunk/${PV}/+download/${P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-python/python-distutils-extra-2.12"
+RDEPEND=">=dev-db/couchdb-0.10.0
+ >=dev-python/gnome-keyring-python-2.22.3-r1
+ <dev-python/couchdb-python-0.7
+ >=dev-python/oauth-1.0.1
+ >=dev-python/simplejson-2.0.9-r1
+ >=dev-python/twisted-8.2.0-r2
+ >=net-dns/avahi-0.6.24-r2[python]"
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-setup_hardlinks.patch"
+}
+
+src_install() {
+
+ python_convert_shebangs -r 2 "bin/"
+
+ distutils_src_install
+
+ exeinto "${ROOT}/usr/lib/${PN}"
+ doexe "bin/desktopcouch-stop"
+ doexe "bin/desktopcouch-service"
+ doexe "bin/desktopcouch-get-port"
+
+ if use doc; then
+ insinto "${ROOT}/usr/share/doc/${PF}/api"
+ doins "desktopcouch/records/doc/records.txt"
+ doins "desktopcouch/records/doc/field_registry.txt"
+ doins "desktopcouch/contacts/schema.txt"
+
+ doman "docs/man/desktopcouch-pair.1"
+ fi
+}
diff --git a/dev-db/desktopcouch/files/desktopcouch-setup_hardlinks.patch b/dev-db/desktopcouch/files/desktopcouch-0.6.4-setup_hardlinks.patch
index 40d12b4205d3..7810ccc713e4 100644
--- a/dev-db/desktopcouch/files/desktopcouch-setup_hardlinks.patch
+++ b/dev-db/desktopcouch/files/desktopcouch-0.6.4-setup_hardlinks.patch
@@ -1,23 +1,24 @@
---- setup.py.orig 2010-03-12 22:30:22.000000000 +0000
-+++ setup.py 2010-03-12 22:42:57.000000000 +0000
-@@ -31,18 +31,11 @@
+--- setup.py.orig 2010-04-23 05:19:54.000000000 +0000
++++ setup.py 2010-04-23 05:32:47.000000000 +0000
+@@ -31,19 +31,10 @@
test_suite="runtests.get_test_suite",
packages=find_packages(),
scripts=['bin/desktopcouch-pair'],
- data_files = [('/usr/lib/desktopcouch/', ['bin/desktopcouch-service',
+- 'bin/desktopcouch-get-port',
- 'bin/desktopcouch-stop']),
- # Be sure all additions are reflected in MANIFEST.in !
- ('/usr/share/doc/python-desktopcouch-records/api/',
- ['desktopcouch/records/doc/records.txt',
- 'desktopcouch/records/doc/field_registry.txt',
- 'desktopcouch/contacts/schema.txt']),
-+ data_files = [# Be sure all additions are reflected in MANIFEST.in !
- ('/etc/xdg/desktop-couch/',
+- ('/etc/xdg/desktop-couch/',
++ data_files = [('/etc/xdg/desktop-couch/',
['config/desktop-couch/compulsory-auth.ini']),
('/usr/share/desktopcouch/', ['data/couchdb.tmpl']),
- ('/usr/share/dbus-1/services/', ['org.desktopcouch.CouchDB.service']),
- ('share/man/man1/', ['docs/man/desktopcouch-pair.1'])],
-+ ('/usr/share/dbus-1/services/', ['org.desktopcouch.CouchDB.service']),],
++ ('/usr/share/dbus-1/services/', ['org.desktopcouch.CouchDB.service'])],
cmdclass = { "build" : build_extra.build_extra,
"build_i18n" : build_i18n.build_i18n }
)