summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-11-11 10:32:49 +0000
committerPeter Volkov <pva@gentoo.org>2007-11-11 10:32:49 +0000
commit832d1bb2cbe5cb3bccd9803537107dc330211c7f (patch)
tree946f2c7f93b323ae885c354e7d1e3f92fa3a963d /dev-db/gigabase
parentStable on x86 wrt bug #198718 (diff)
downloadgentoo-2-832d1bb2cbe5cb3bccd9803537107dc330211c7f.tar.gz
gentoo-2-832d1bb2cbe5cb3bccd9803537107dc330211c7f.tar.bz2
gentoo-2-832d1bb2cbe5cb3bccd9803537107dc330211c7f.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-db/gigabase')
-rw-r--r--dev-db/gigabase/ChangeLog7
-rw-r--r--dev-db/gigabase/files/digest-gigabase-3.613
-rw-r--r--dev-db/gigabase/gigabase-3.61.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index 6431fc71c4fb..f90af8a96895 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.27 2007/11/01 12:31:56 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.28 2007/11/11 10:32:48 pva Exp $
+
+*gigabase-3.61 (11 Nov 2007)
+
+ 11 Nov 2007; <pva@gentoo.org> +gigabase-3.61.ebuild:
+ Version bump.
*gigabase-3.60 (01 Nov 2007)
diff --git a/dev-db/gigabase/files/digest-gigabase-3.61 b/dev-db/gigabase/files/digest-gigabase-3.61
new file mode 100644
index 000000000000..ba54eb1b4540
--- /dev/null
+++ b/dev-db/gigabase/files/digest-gigabase-3.61
@@ -0,0 +1,3 @@
+MD5 9bc3d8b2cb00ea827d745d9adedf5948 gigabase-3.61.tar.gz 1434011
+RMD160 0e4f606c1e855d8ed32d3d19d44a7c00141bceab gigabase-3.61.tar.gz 1434011
+SHA256 29cccea5da9d50bf98b59b295da8df01718864dcadd5931b7d3e261f0e4bd101 gigabase-3.61.tar.gz 1434011
diff --git a/dev-db/gigabase/gigabase-3.61.ebuild b/dev-db/gigabase/gigabase-3.61.ebuild
new file mode 100644
index 000000000000..a49e56d6bf21
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.61.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.61.ebuild,v 1.1 2007/11/11 10:32:48 pva Exp $
+
+inherit eutils libtool multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+DEPEND=""
+
+S=${WORKDIR}/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}