summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-12-19 20:42:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-12-19 20:42:27 +0000
commitee7e607f11f0924f9734e73f5b07504803f62c40 (patch)
treec2aba6b243b91f77dacadfeaf033bd14984c176d /dev-db/kyotocabinet
parentVersion bump and install udev rules under proper path (bug #348708 by Ben Sag... (diff)
downloadgentoo-2-ee7e607f11f0924f9734e73f5b07504803f62c40.tar.gz
gentoo-2-ee7e607f11f0924f9734e73f5b07504803f62c40.tar.bz2
gentoo-2-ee7e607f11f0924f9734e73f5b07504803f62c40.zip
Bump for #349112
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/ChangeLog7
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.30.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index ec11d78d090a..24bad36c2d42 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.4 2010/12/10 23:47:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.5 2010/12/19 20:42:27 patrick Exp $
+
+*kyotocabinet-1.2.30 (19 Dec 2010)
+
+ 19 Dec 2010; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.30.ebuild:
+ Bump for #349112
*kyotocabinet-1.2.29 (10 Dec 2010)
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.30.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.30.ebuild
new file mode 100644
index 000000000000..1b2b34db2fcb
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.30.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.30.ebuild,v 1.1 2010/12/19 20:42:27 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath-1.2.4.patch"
+ epatch "${FILESDIR}/remove_ldconfig-1.2.4.patch"
+ epatch "${FILESDIR}/remove_docinst-1.2.29.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug) --enable-lzma
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}