summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-01-31 12:51:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-01-31 12:51:05 +0000
commitf743dd9479f8723c7040c737d8e9c96e2079a2ae (patch)
treed48c11987da1895c53a25ae22a4a34a7e34794b3 /dev-db/kyotocabinet
parentRDEPENDs on x11-themes/hicolor-icon-theme as reported in bug #350377 by Oscht... (diff)
downloadgentoo-2-f743dd9479f8723c7040c737d8e9c96e2079a2ae.tar.gz
gentoo-2-f743dd9479f8723c7040c737d8e9c96e2079a2ae.tar.bz2
gentoo-2-f743dd9479f8723c7040c737d8e9c96e2079a2ae.zip
Bump
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/ChangeLog7
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.38.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index 5162030884bf..e082493ba19f 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.6 2011/01/16 09:42:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.7 2011/01/31 12:51:05 patrick Exp $
+
+*kyotocabinet-1.2.38 (31 Jan 2011)
+
+ 31 Jan 2011; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.38.ebuild:
+ Bump
*kyotocabinet-1.2.34 (16 Jan 2011)
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.38.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.38.ebuild
new file mode 100644
index 000000000000..61e0291b489d
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.38.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.38.ebuild,v 1.1 2011/01/31 12:51:05 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath-1.2.4.patch"
+ epatch "${FILESDIR}/remove_ldconfig-1.2.4.patch"
+ epatch "${FILESDIR}/remove_docinst-1.2.29.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug) --enable-lzma
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}