summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-07-10 23:47:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-07-10 23:47:49 +0000
commitbdf4d353da9b6fa15caeac5cad38f54a7f3b1014 (patch)
tree369f8d24dd8c7e832a330627c7a67f218621e1e4 /dev-db/myodbc
parentwhitespace (diff)
downloadgentoo-2-bdf4d353da9b6fa15caeac5cad38f54a7f3b1014.tar.gz
gentoo-2-bdf4d353da9b6fa15caeac5cad38f54a7f3b1014.tar.bz2
gentoo-2-bdf4d353da9b6fa15caeac5cad38f54a7f3b1014.zip
Old versions don't work on newer unixODBC, so clean them up. Latest is stable anyway.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/myodbc')
-rw-r--r--dev-db/myodbc/ChangeLog9
-rw-r--r--dev-db/myodbc/myodbc-3.51.06.ebuild87
-rw-r--r--dev-db/myodbc/myodbc-3.51.11.ebuild90
-rw-r--r--dev-db/myodbc/myodbc-3.51.12.ebuild95
-rw-r--r--dev-db/myodbc/myodbc-3.51.26_p1127-r1.ebuild112
-rw-r--r--dev-db/myodbc/myodbc-3.51.26_p1127.ebuild95
-rw-r--r--dev-db/myodbc/myodbc-3.51.27_p695.ebuild112
-rw-r--r--dev-db/myodbc/myodbc-5.1.5_p1144.ebuild112
8 files changed, 8 insertions, 704 deletions
diff --git a/dev-db/myodbc/ChangeLog b/dev-db/myodbc/ChangeLog
index 388c9c86121c..b7fb38f1c6c6 100644
--- a/dev-db/myodbc/ChangeLog
+++ b/dev-db/myodbc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/myodbc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/ChangeLog,v 1.29 2010/06/26 15:14:45 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/ChangeLog,v 1.30 2010/07/10 23:47:49 robbat2 Exp $
+
+ 10 Jul 2010; Robin H. Johnson <robbat2@gentoo.org> -myodbc-3.51.06.ebuild,
+ -myodbc-3.51.11.ebuild, -myodbc-3.51.12.ebuild,
+ -myodbc-3.51.26_p1127.ebuild, -myodbc-3.51.26_p1127-r1.ebuild,
+ -myodbc-3.51.27_p695.ebuild, -myodbc-5.1.5_p1144.ebuild:
+ Old versions don't work on newer unixODBC, so clean them up. Latest is
+ stable anyway.
26 Jun 2010; <nixnut@gentoo.org> myodbc-5.1.6.ebuild:
ppc stable #322277
diff --git a/dev-db/myodbc/myodbc-3.51.06.ebuild b/dev-db/myodbc/myodbc-3.51.06.ebuild
deleted file mode 100644
index 05956b16cd37..000000000000
--- a/dev-db/myodbc/myodbc-3.51.06.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.06.ebuild,v 1.11 2007/01/31 13:46:14 genone Exp $
-
-MY_PN="MyODBC"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/MyODBC3/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0 dev-db/unixODBC sys-devel/m4"
-# perl is required for building docs
-DEPEND="${RDEPEND} doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} `use_with doc docs` `use_with debug`"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir=${D}/usr/sbin \
- sysconfdir=${D}/etc/myodbc \
- localstatedir=${D}/var/lib/myodbc
- dodoc INSTALL RELEASE-NOTES README
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die "Sorry, non-standard \$ROOT setting is not supported :-("
-
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- /usr/bin/m4 -D__PN__=${PN} -D__PF__=${PF} ${FILESDIR}/${i}.m4 >${T}/${i}
- done;
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${PN}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f ${T}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${PN}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f ${T}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
-}
diff --git a/dev-db/myodbc/myodbc-3.51.11.ebuild b/dev-db/myodbc/myodbc-3.51.11.ebuild
deleted file mode 100644
index 688899be1a62..000000000000
--- a/dev-db/myodbc/myodbc-3.51.11.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.11.ebuild,v 1.8 2007/01/31 13:46:14 genone Exp $
-
-MY_PN="MyODBC"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/MyODBC3/${MY_P}.tar.gz"
-RESTRICT="primaryuri"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0 dev-db/unixODBC sys-devel/m4"
-# perl is required for building docs
-DEPEND="${RDEPEND} doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} `use_with doc docs` `use_with debug`"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- --disable-test \
- --without-samples \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir=${D}/usr/sbin \
- sysconfdir=${D}/etc/myodbc \
- localstatedir=${D}/var/lib/myodbc
- dodoc INSTALL RELEASE-NOTES README
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die "Sorry, non-standard \$ROOT setting is not supported :-("
-
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- /usr/bin/m4 -D__PN__=${PN} -D__PF__=${PF} ${FILESDIR}/${i}.m4 >${T}/${i}
- done;
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${PN}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f ${T}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${PN}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f ${T}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
-}
diff --git a/dev-db/myodbc/myodbc-3.51.12.ebuild b/dev-db/myodbc/myodbc-3.51.12.ebuild
deleted file mode 100644
index 4e668a996908..000000000000
--- a/dev-db/myodbc/myodbc-3.51.12.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.12.ebuild,v 1.6 2009/02/26 15:46:04 josejx Exp $
-
-MY_PN="mysql-connector-odbc"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/MyODBC3/${MY_P}.tar.gz"
-RESTRICT="primaryuri"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0 dev-db/unixODBC sys-devel/m4"
-# perl is required for building docs
-DEPEND="${RDEPEND} doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} $(use_with doc docs) $(use_with debug)"
- myconf="${myconf} --disable-gui"
- #TODO: the configure test against qt 4 enter in an endless loop
- #myconf="${myconf} $(use_enable qt gui)"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- --enable-myodbc3i \
- --enable-myodbc3m \
- --disable-test \
- --without-samples \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir=${D}/usr/sbin \
- sysconfdir=${D}/etc/myodbc \
- localstatedir=${D}/var/lib/myodbc
- dodoc INSTALL RELEASE-NOTES README
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die "Sorry, non-standard \$ROOT setting is not supported :-("
-
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- /usr/bin/m4 -D__PN__=${PN} -D__PF__=${PF} ${FILESDIR}/${i}.m4 >${T}/${i}
- done;
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${PN}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f ${T}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${PN}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f ${T}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
-}
diff --git a/dev-db/myodbc/myodbc-3.51.26_p1127-r1.ebuild b/dev-db/myodbc/myodbc-3.51.26_p1127-r1.ebuild
deleted file mode 100644
index 902946818aac..000000000000
--- a/dev-db/myodbc/myodbc-3.51.26_p1127-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.26_p1127-r1.ebuild,v 1.4 2010/04/11 12:33:35 nixnut Exp $
-
-inherit eutils versionator
-
-MAJOR="$(get_version_component_range 1-2 $PV)"
-MY_PN="mysql-connector-odbc"
-MY_P="${MY_PN}-${PV/_p/r}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/Connector-ODBC/${MAJOR}/${MY_P}.tar.gz"
-RESTRICT="primaryuri"
-LICENSE="GPL-2"
-SLOT="${MAJOR}"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0
- dev-db/unixODBC"
-# perl is required for building docs
-DEPEND="${RDEPEND}
- doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-# Careful!
-DRIVER_NAME="${PN}-${SLOT}"
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} $(use_with doc docs) $(use_with debug)"
- myconf="${myconf} --disable-gui"
- #TODO: the configure test against qt 4 enter in an endless loop
- #myconf="${myconf} $(use_enable qt gui)"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- --enable-myodbc3i \
- --enable-myodbc3m \
- --disable-test \
- --without-samples \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir="${D}"/usr/sbin \
- sysconfdir="${D}"/etc/myodbc \
- localstatedir="${D}"/var/lib/myodbc \
- pkgdatadir="${D}"/usr/share/doc/${PF}
- dodoc INSTALL README
- prepalldocs
- dodir /usr/share/${PN}-${SLOT}
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- sed \
- -e "s,__PN__,${DRIVER_NAME},g" \
- -e "s,__PF__,${PF},g" \
- -e "s,libmyodbc3.so,libmyodbc${SLOT:0:1}.so,g" \
- >"${D}"/usr/share/${PN}-${SLOT}/${i} \
- <"${FILESDIR}"/${i}.m4 \
- || die "Failed to build $i"
- done;
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die 'Sorry, non-standard ROOT setting is not supported :-('
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${DRIVER_NAME}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f /usr/share/${PN}-${SLOT}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${DRIVER_NAME}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f /usr/share/${PN}-${SLOT}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
- elog "Please note that the driver name used to form the DSN now includes the SLOT."
-}
diff --git a/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild b/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild
deleted file mode 100644
index 0aa6787209b6..000000000000
--- a/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild,v 1.1 2008/11/01 09:15:25 robbat2 Exp $
-
-MY_PN="mysql-connector-odbc"
-MY_P="${MY_PN}-${PV/_p/r}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/Connector-ODBC/3.51/${MY_P}.tar.gz"
-RESTRICT="primaryuri"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0 dev-db/unixODBC sys-devel/m4"
-# perl is required for building docs
-DEPEND="${RDEPEND} doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} $(use_with doc docs) $(use_with debug)"
- myconf="${myconf} --disable-gui"
- #TODO: the configure test against qt 4 enter in an endless loop
- #myconf="${myconf} $(use_enable qt gui)"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- --enable-myodbc3i \
- --enable-myodbc3m \
- --disable-test \
- --without-samples \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir=${D}/usr/sbin \
- sysconfdir=${D}/etc/myodbc \
- localstatedir=${D}/var/lib/myodbc
- dodoc INSTALL RELEASE-NOTES README
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die "Sorry, non-standard \$ROOT setting is not supported :-("
-
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- /usr/bin/m4 -D__PN__=${PN} -D__PF__=${PF} ${FILESDIR}/${i}.m4 >${T}/${i}
- done;
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${PN}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f ${T}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${PN}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f ${T}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
-}
diff --git a/dev-db/myodbc/myodbc-3.51.27_p695.ebuild b/dev-db/myodbc/myodbc-3.51.27_p695.ebuild
deleted file mode 100644
index 1601ee1de352..000000000000
--- a/dev-db/myodbc/myodbc-3.51.27_p695.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.27_p695.ebuild,v 1.1 2010/01/31 05:25:46 robbat2 Exp $
-
-inherit eutils versionator
-
-MAJOR="$(get_version_component_range 1-2 $PV)"
-MY_PN="mysql-connector-odbc"
-MY_P="${MY_PN}-${PV/_p/r}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/Connector-ODBC/${MAJOR}/${MY_P}.tar.gz"
-RESTRICT="primaryuri"
-LICENSE="GPL-2"
-SLOT="${MAJOR}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0
- dev-db/unixODBC"
-# perl is required for building docs
-DEPEND="${RDEPEND}
- doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-# Careful!
-DRIVER_NAME="${PN}-${SLOT}"
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} $(use_with doc docs) $(use_with debug)"
- myconf="${myconf} --disable-gui"
- #TODO: the configure test against qt 4 enter in an endless loop
- #myconf="${myconf} $(use_enable qt gui)"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- --enable-myodbc3i \
- --enable-myodbc3m \
- --disable-test \
- --without-samples \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir="${D}"/usr/sbin \
- sysconfdir="${D}"/etc/myodbc \
- localstatedir="${D}"/var/lib/myodbc \
- pkgdatadir="${D}"/usr/share/doc/${PF}
- dodoc INSTALL README
- prepalldocs
- dodir /usr/share/${PN}-${SLOT}
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- sed \
- -e "s,__PN__,${DRIVER_NAME},g" \
- -e "s,__PF__,${PF},g" \
- -e "s,libmyodbc3.so,libmyodbc${SLOT:0:1}.so,g" \
- >"${D}"/usr/share/${PN}-${SLOT}/${i} \
- <"${FILESDIR}"/${i}.m4 \
- || die "Failed to build $i"
- done;
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die 'Sorry, non-standard ROOT setting is not supported :-('
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${DRIVER_NAME}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f /usr/share/${PN}-${SLOT}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${DRIVER_NAME}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f /usr/share/${PN}-${SLOT}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
- elog "Please note that the driver name used to form the DSN now includes the SLOT."
-}
diff --git a/dev-db/myodbc/myodbc-5.1.5_p1144.ebuild b/dev-db/myodbc/myodbc-5.1.5_p1144.ebuild
deleted file mode 100644
index 014cbce25e71..000000000000
--- a/dev-db/myodbc/myodbc-5.1.5_p1144.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-5.1.5_p1144.ebuild,v 1.4 2010/04/11 12:33:35 nixnut Exp $
-
-inherit eutils versionator
-
-MAJOR="$(get_version_component_range 1-2 $PV)"
-MY_PN="mysql-connector-odbc"
-MY_P="${MY_PN}-${PV/_p/r}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/Connector-ODBC/${MAJOR}/${MY_P}.tar.gz"
-RESTRICT="primaryuri"
-LICENSE="GPL-2"
-SLOT="${MAJOR}"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0
- dev-db/unixODBC"
-# perl is required for building docs
-DEPEND="${RDEPEND}
- doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-# Careful!
-DRIVER_NAME="${PN}-${SLOT}"
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} $(use_with doc docs) $(use_with debug)"
- myconf="${myconf} --disable-gui"
- #TODO: the configure test against qt 4 enter in an endless loop
- #myconf="${myconf} $(use_enable qt gui)"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- --enable-myodbc3i \
- --enable-myodbc3m \
- --disable-test \
- --without-samples \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir="${D}"/usr/sbin \
- sysconfdir="${D}"/etc/myodbc \
- localstatedir="${D}"/var/lib/myodbc \
- pkgdatadir="${D}"/usr/share/doc/${PF}
- dodoc INSTALL README
- prepalldocs
- dodir /usr/share/${PN}-${SLOT}
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- sed \
- -e "s,__PN__,${DRIVER_NAME},g" \
- -e "s,__PF__,${PF},g" \
- -e "s,libmyodbc3.so,libmyodbc${SLOT:0:1}.so,g" \
- >"${D}"/usr/share/${PN}-${SLOT}/${i} \
- <"${FILESDIR}"/${i}.m4 \
- || die "Failed to build $i"
- done;
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die 'Sorry, non-standard ROOT setting is not supported :-('
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${DRIVER_NAME}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f /usr/share/${PN}-${SLOT}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${DRIVER_NAME}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f /usr/share/${PN}-${SLOT}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
- elog "Please note that the driver name used to form the DSN now includes the SLOT."
-}