summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-05-06 03:13:55 +0000
committerBrian Evans <grknight@gentoo.org>2014-05-06 03:13:55 +0000
commitfbdf2b2b3b64b912fbab65f2bb0060d7924acee5 (patch)
treefa68052b39f96d22e021aa9b7155f8498d833493 /dev-db/mysql++/mysql++-3.2.1.ebuild
parentVersion bump for Cinnamon 2.2 (diff)
downloadgentoo-2-fbdf2b2b3b64b912fbab65f2bb0060d7924acee5.tar.gz
gentoo-2-fbdf2b2b3b64b912fbab65f2bb0060d7924acee5.tar.bz2
gentoo-2-fbdf2b2b3b64b912fbab65f2bb0060d7924acee5.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-db/mysql++/mysql++-3.2.1.ebuild')
-rw-r--r--dev-db/mysql++/mysql++-3.2.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/mysql++/mysql++-3.2.1.ebuild b/dev-db/mysql++/mysql++-3.2.1.ebuild
new file mode 100644
index 000000000000..98de0454e23d
--- /dev/null
+++ b/dev-db/mysql++/mysql++-3.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-3.2.1.ebuild,v 1.1 2014/05/06 03:13:55 grknight Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="C++ API interface to the MySQL database"
+HOMEPAGE="http://tangentsoft.net/mysql++/"
+SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=virtual/mysql-4.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gold.patch"
+ epatch_user
+}
+
+src_configure() {
+ local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
+ econf ${myconf}
+}
+
+src_install() {
+ default
+ # install the docs and HTML pages
+ dodoc CREDITS* HACKERS.txt Wishlist doc/ssqls-pretty
+ dodoc -r doc/pdf/ doc/refman/ doc/userman/
+ dohtml -r doc/html/
+}