summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2006-11-23 13:58:06 +0000
committerFrancesco Riosa <vivo@gentoo.org>2006-11-23 13:58:06 +0000
commit88bbeb5c20ed55116e54e69164f59bf4d39589c3 (patch)
tree3529a1f7e98583e78dd9181816b19369c75eed54 /dev-db/mysql-community/mysql-community-5.0.27.ebuild
parentenable community (diff)
downloadgentoo-2-88bbeb5c20ed55116e54e69164f59bf4d39589c3.tar.gz
gentoo-2-88bbeb5c20ed55116e54e69164f59bf4d39589c3.tar.bz2
gentoo-2-88bbeb5c20ed55116e54e69164f59bf4d39589c3.zip
init
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-db/mysql-community/mysql-community-5.0.27.ebuild')
-rw-r--r--dev-db/mysql-community/mysql-community-5.0.27.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/mysql-community/mysql-community-5.0.27.ebuild b/dev-db/mysql-community/mysql-community-5.0.27.ebuild
new file mode 100644
index 000000000000..bdc5a6868ed7
--- /dev/null
+++ b/dev-db/mysql-community/mysql-community-5.0.27.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/mysql-community-5.0.27.ebuild,v 1.1 2006/11/23 13:58:06 vivo Exp $
+
+# Leave this empty
+MYSQL_VERSION_ID=""
+MYSQL_RERELEASE=""
+# Set the patchset revision to use, must be either empty or a decimal number
+MYSQL_PATCHSET_REV="1"
+
+inherit mysql
+
+#REMEMBER!!!: update also eclass/mysql*.eclass prior to commit
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+src_test() {
+ cd "${S}"
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! useq "minimal" ; then
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ cd mysql-test
+ sed -i -e "s|PORT=3306|PORT=3307|g" mysql-test-run
+ ./mysql-test-run
+ retstatus=$?
+
+ # Just to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus -eq 0 ]] || die "make test failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}