summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2006-12-10 03:28:59 +0000
committerFrancesco Riosa <vivo@gentoo.org>2006-12-10 03:28:59 +0000
commite5e8e274a57cd6d5a8df6d3243dcfd5ef7fc7139 (patch)
tree60bd00b553a949490647caf20d64f04594a0a34d /dev-db/mysql-community
parentmysql raid (diff)
downloadgentoo-2-e5e8e274a57cd6d5a8df6d3243dcfd5ef7fc7139.tar.gz
gentoo-2-e5e8e274a57cd6d5a8df6d3243dcfd5ef7fc7139.tar.bz2
gentoo-2-e5e8e274a57cd6d5a8df6d3243dcfd5ef7fc7139.zip
version bump
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'dev-db/mysql-community')
-rw-r--r--dev-db/mysql-community/ChangeLog8
-rw-r--r--dev-db/mysql-community/files/digest-mysql-community-4.1.226
-rw-r--r--dev-db/mysql-community/mysql-community-4.1.22.ebuild38
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-db/mysql-community/ChangeLog b/dev-db/mysql-community/ChangeLog
index 2c3d19894d11..cc34e34b8a2d 100644
--- a/dev-db/mysql-community/ChangeLog
+++ b/dev-db/mysql-community/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql-community
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/ChangeLog,v 1.6 2006/12/10 00:34:04 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/ChangeLog,v 1.7 2006/12/10 03:28:59 vivo Exp $
+
+*mysql-community-4.1.22 (10 Dec 2006)
+
+ 10 Dec 2006; Francesco Riosa <vivo@gentoo.org>
+ +mysql-community-4.1.22.ebuild:
+ version bump for 4.1
*mysql-community-5.1.14_beta (10 Dec 2006)
diff --git a/dev-db/mysql-community/files/digest-mysql-community-4.1.22 b/dev-db/mysql-community/files/digest-mysql-community-4.1.22
new file mode 100644
index 000000000000..dd64a8d16d1a
--- /dev/null
+++ b/dev-db/mysql-community/files/digest-mysql-community-4.1.22
@@ -0,0 +1,6 @@
+MD5 37b4479951fa0cf052269d27c41ca200 mysql-4.1.22.tar.gz 17761101
+RMD160 bfcf5058e4247cf4d7d1550ea54c64ebc8bc615e mysql-4.1.22.tar.gz 17761101
+SHA256 6bd2436fd0f233bb1518e15975cb4e9fa4434acb53c3c3cd7d4648219abf58e9 mysql-4.1.22.tar.gz 17761101
+MD5 7b4430237944b11af3dfa95c659c9e75 mysql-community-patchset-4.1.22-r1.tar.bz2 3850
+RMD160 7c80676a5fe125ca847383c282dcaa67b2e21050 mysql-community-patchset-4.1.22-r1.tar.bz2 3850
+SHA256 811c6cf519360ab22005ec71790866f930e13328e7abf67b0eecc984593a6d52 mysql-community-patchset-4.1.22-r1.tar.bz2 3850
diff --git a/dev-db/mysql-community/mysql-community-4.1.22.ebuild b/dev-db/mysql-community/mysql-community-4.1.22.ebuild
new file mode 100644
index 000000000000..70da2c450bbb
--- /dev/null
+++ b/dev-db/mysql-community/mysql-community-4.1.22.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/mysql-community-4.1.22.ebuild,v 1.1 2006/12/10 03:28:59 vivo Exp $
+
+# Leave this empty
+MYSQL_VERSION_ID=""
+MYSQL_RERELEASE=""
+# Set the patchset revision to use, must be either empty or a decimal number
+MYSQL_PATCHSET_REV="1"
+BASE_URI="mirror://mysql/Downloads/MySQL-${PV%.*}"
+
+inherit mysql
+
+#REMEMBER!!!: update also eclass/mysql*.eclass prior to commit
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+src_test() {
+ cd "${S}"
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! useq "minimal" ; then
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ cd mysql-test
+ sed -i -e "s|PORT=3306|PORT=3307|g" mysql-test-run
+ ./mysql-test-run
+ retstatus=$?
+
+ # Just to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus -eq 0 ]] || die "make test failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}