summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-15 18:37:00 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-15 18:37:00 +0000
commit00a273822960872aa0a46b1826722fa5b083b5aa (patch)
tree765743fe2ed2f0626a5c9e2de8faee6716488874 /dev-db/mysql-workbench/files
parentRemove old versions. (diff)
downloadgentoo-2-00a273822960872aa0a46b1826722fa5b083b5aa.tar.gz
gentoo-2-00a273822960872aa0a46b1826722fa5b083b5aa.tar.bz2
gentoo-2-00a273822960872aa0a46b1826722fa5b083b5aa.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/mysql-workbench/files')
-rw-r--r--dev-db/mysql-workbench/files/mysql-workbench-5.2.31-python-libs.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-db/mysql-workbench/files/mysql-workbench-5.2.31-python-libs.patch b/dev-db/mysql-workbench/files/mysql-workbench-5.2.31-python-libs.patch
new file mode 100644
index 000000000000..5e78761cd8a5
--- /dev/null
+++ b/dev-db/mysql-workbench/files/mysql-workbench-5.2.31-python-libs.patch
@@ -0,0 +1,21 @@
+Use a simpler check for Python's libs that returns an actual linker
+invocation (e.g. -lpython2.6) instead of the .so file. This fixes the
+case with forced as-needed where the .so gets re-ordered to the front
+during link.
+
+--- configure.in.~1~ 2010-12-08 03:20:38.000000000 +0100
++++ configure.in 2010-12-15 19:10:11.716940123 +0100
+@@ -280,12 +280,7 @@
+ AC_CHECK_PROG(PYTHON27, python2.7, [yes])
+ # Python headers
+ AC_MSG_CHECKING(for Python libraries)
+-PYTHON_LIBS=[$(python -c "from distutils import sysconfig
+-import os
+-cfg=sysconfig.get_config_vars()
+-lib = os.path.join(cfg['LIBDIR'], cfg['LDLIBRARY'])
+-if os.path.exists(lib):
+- print lib")]
++PYTHON_LIBS=[$(python -c 'import sys; print("-lpython%s.%s" % sys.version_info[:2])')]
+ PYTHON_CFLAGS=[$(python -c "from distutils import sysconfig
+ print sysconfig.get_python_inc()")]
+ PYTHON_CFLAGS="-I$PYTHON_CFLAGS"