summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-31 22:33:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-31 22:33:37 +0000
commita1f29c51189508182de429248cc1464c4893cf4b (patch)
tree4a6733b0340578ff75eaa9b09d3d80f0423a47ba /dev-db/mysql
parentCleanup of forgotten files, fixes bug 274865 (diff)
downloadgentoo-2-a1f29c51189508182de429248cc1464c4893cf4b.tar.gz
gentoo-2-a1f29c51189508182de429248cc1464c4893cf4b.tar.bz2
gentoo-2-a1f29c51189508182de429248cc1464c4893cf4b.zip
Disable the SSL tests in all old 5.x ebuilds because the SSL certificates have expired now.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/ChangeLog9
-rw-r--r--dev-db/mysql/mysql-5.0.54.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.70-r1.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.72-r1.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.72.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.76-r1.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.76.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.83.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.84-r1.ebuild30
-rw-r--r--dev-db/mysql/mysql-5.0.84.ebuild30
10 files changed, 260 insertions, 19 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 873b543b9054..e81f81b34ee2 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/mysql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.500 2010/01/31 22:29:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.501 2010/01/31 22:33:37 robbat2 Exp $
+
+ 31 Jan 2010; Robin H. Johnson <robbat2@gentoo.org> mysql-5.0.54.ebuild,
+ mysql-5.0.70-r1.ebuild, mysql-5.0.72.ebuild, mysql-5.0.72-r1.ebuild,
+ mysql-5.0.76.ebuild, mysql-5.0.76-r1.ebuild, mysql-5.0.83.ebuild,
+ mysql-5.0.84.ebuild, mysql-5.0.84-r1.ebuild:
+ Disable the SSL tests in all old 5.x ebuilds because the SSL certificates
+ have expired now.
31 Jan 2010; Robin H. Johnson <robbat2@gentoo.org>
-mysql-5.0.26-r2.ebuild, -mysql-5.0.32.ebuild, -mysql-5.0.34.ebuild,
diff --git a/dev-db/mysql/mysql-5.0.54.ebuild b/dev-db/mysql/mysql-5.0.54.ebuild
index 8de84e32a40a..bf2738bcf935 100644
--- a/dev-db/mysql/mysql-5.0.54.ebuild
+++ b/dev-db/mysql/mysql-5.0.54.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.13 2008/11/14 09:42:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.14 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20080124"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -55,6 +55,32 @@ src_test() {
mysql_disable_test \
"subselect" \
"Testcase needs tuning on x86 for oom condition"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# We run the test protocols seperately
make -j1 test-ns force=--force
diff --git a/dev-db/mysql/mysql-5.0.70-r1.ebuild b/dev-db/mysql/mysql-5.0.70-r1.ebuild
index 53ea9aa71a2d..307af1bf7e2e 100644
--- a/dev-db/mysql/mysql-5.0.70-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.70-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.70-r1.ebuild,v 1.7 2009/03/01 10:50:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.70-r1.ebuild,v 1.8 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20081129-1041Z"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -86,6 +86,32 @@ src_test() {
"$t" \
"OpenSSL tests broken on 5.0.56"
done
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# create directories because mysqladmin might right out of order
mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
diff --git a/dev-db/mysql/mysql-5.0.72-r1.ebuild b/dev-db/mysql/mysql-5.0.72-r1.ebuild
index 7e17e4fba182..40f9c1d50227 100644
--- a/dev-db/mysql/mysql-5.0.72-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.72-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.72-r1.ebuild,v 1.4 2008/12/31 03:18:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.72-r1.ebuild,v 1.5 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20081129-1041Z"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -94,6 +94,32 @@ src_test() {
mysql_disable_test \
"status2" \
"Broken in 5.0.72, new test is broken, upstream bug #41066"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# create directories because mysqladmin might right out of order
mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
diff --git a/dev-db/mysql/mysql-5.0.72.ebuild b/dev-db/mysql/mysql-5.0.72.ebuild
index a9ba330a86b7..4bc98837d943 100644
--- a/dev-db/mysql/mysql-5.0.72.ebuild
+++ b/dev-db/mysql/mysql-5.0.72.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.72.ebuild,v 1.2 2008/12/31 03:18:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.72.ebuild,v 1.3 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20080601"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -86,6 +86,32 @@ src_test() {
"$t" \
"OpenSSL tests broken on 5.0.56"
done
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# New test was broken in first time
# Upstream bug 41066
diff --git a/dev-db/mysql/mysql-5.0.76-r1.ebuild b/dev-db/mysql/mysql-5.0.76-r1.ebuild
index c3e5db99bc56..29ab3ecd576a 100644
--- a/dev-db/mysql/mysql-5.0.76-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.76-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.76-r1.ebuild,v 1.1 2009/04/12 00:11:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.76-r1.ebuild,v 1.2 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20090412-0009Z"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -99,6 +99,32 @@ src_test() {
mysql_disable_test \
"status2" \
"Broken in 5.0.72, new test is broken, upstream bug #41066"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# SSL certs expired shortly after the release of 5.0.76. Affects older
# versions as well.
diff --git a/dev-db/mysql/mysql-5.0.76.ebuild b/dev-db/mysql/mysql-5.0.76.ebuild
index 5fea9a95a181..02ffe9ccd359 100644
--- a/dev-db/mysql/mysql-5.0.76.ebuild
+++ b/dev-db/mysql/mysql-5.0.76.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.76.ebuild,v 1.2 2009/02/11 21:25:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.76.ebuild,v 1.3 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20090211-1206Z"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -99,6 +99,32 @@ src_test() {
mysql_disable_test \
"status2" \
"Broken in 5.0.72, new test is broken, upstream bug #41066"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# SSL certs expired shortly after the release of 5.0.76. Affects older
# versions as well.
diff --git a/dev-db/mysql/mysql-5.0.83.ebuild b/dev-db/mysql/mysql-5.0.83.ebuild
index cfbffe5af09b..837a79551fd6 100644
--- a/dev-db/mysql/mysql-5.0.83.ebuild
+++ b/dev-db/mysql/mysql-5.0.83.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.83.ebuild,v 1.4 2009/10/10 23:31:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.83.ebuild,v 1.5 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20090706-1838Z"
EAPI=2
@@ -115,6 +115,32 @@ src_test() {
done
;;
esac
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# create directories because mysqladmin might right out of order
mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
diff --git a/dev-db/mysql/mysql-5.0.84-r1.ebuild b/dev-db/mysql/mysql-5.0.84-r1.ebuild
index f7614bc002ff..6e6f90c2ef2a 100644
--- a/dev-db/mysql/mysql-5.0.84-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.84-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.84-r1.ebuild,v 1.9 2009/11/29 18:13:17 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.84-r1.ebuild,v 1.10 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20090908-1245Z"
EAPI=2
@@ -115,6 +115,32 @@ src_test() {
done
;;
esac
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# create directories because mysqladmin might right out of order
mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
diff --git a/dev-db/mysql/mysql-5.0.84.ebuild b/dev-db/mysql/mysql-5.0.84.ebuild
index f3fa3140bd63..4590594362ff 100644
--- a/dev-db/mysql/mysql-5.0.84.ebuild
+++ b/dev-db/mysql/mysql-5.0.84.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.84.ebuild,v 1.4 2009/10/10 23:31:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.84.ebuild,v 1.5 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20090904-0939Z"
EAPI=2
@@ -115,6 +115,32 @@ src_test() {
done
;;
esac
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# create directories because mysqladmin might right out of order
mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}