summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-29 16:04:28 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-29 16:04:28 +0000
commitb774ad4d80f3facc6160d0aa2cdc1a1c565a6389 (patch)
tree0f3c1961adfb1a2885e00cc767c130562a180cbd /dev-db/mytop
parentBump per bug #465716. (diff)
downloadgentoo-2-b774ad4d80f3facc6160d0aa2cdc1a1c565a6389.tar.gz
gentoo-2-b774ad4d80f3facc6160d0aa2cdc1a1c565a6389.tar.bz2
gentoo-2-b774ad4d80f3facc6160d0aa2cdc1a1c565a6389.zip
revbump -> EAPI 5, add invocation of test, remove old
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-db/mytop')
-rw-r--r--dev-db/mytop/ChangeLog11
-rw-r--r--dev-db/mytop/mytop-1.4.ebuild28
-rw-r--r--dev-db/mytop/mytop-1.6-r4.ebuild (renamed from dev-db/mytop/mytop-1.6-r2.ebuild)20
-rw-r--r--dev-db/mytop/mytop-1.6.ebuild28
4 files changed, 21 insertions, 66 deletions
diff --git a/dev-db/mytop/ChangeLog b/dev-db/mytop/ChangeLog
index 367e7cf0c676..55180a6d6d50 100644
--- a/dev-db/mytop/ChangeLog
+++ b/dev-db/mytop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mytop
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mytop/ChangeLog,v 1.27 2010/01/30 18:34:42 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mytop/ChangeLog,v 1.28 2013/08/29 16:04:28 idella4 Exp $
+
+*mytop-1.6-r4 (29 Aug 2013)
+
+ 29 Aug 2013; Ian Delaney <idella4@gentoo.org> +mytop-1.6-r4.ebuild,
+ -mytop-1.4.ebuild, -mytop-1.6-r2.ebuild, -mytop-1.6.ebuild:
+ revbump -> EAPI 5, add invocation of test, remove old
30 Jan 2010; Raúl Porcel <armin76@gentoo.org> mytop-1.6-r3.ebuild:
sparc stable wrt #296990
@@ -100,4 +106,3 @@
03 May 2004; Robin H. Johnson <robbat2@gentoo.org> mytop-1.4.ebuild:
initial commit, original ebuild from bug #36608, Adam Gent
<adam.gent@hat-technologies.ltd.uk>.
-
diff --git a/dev-db/mytop/mytop-1.4.ebuild b/dev-db/mytop/mytop-1.4.ebuild
deleted file mode 100644
index cdad2a7c829d..000000000000
--- a/dev-db/mytop/mytop-1.4.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mytop/mytop-1.4.ebuild,v 1.18 2008/11/18 16:01:44 tove Exp $
-
-inherit perl-app
-
-DESCRIPTION="mytop - a top clone for mysql"
-HOMEPAGE="http://jeremy.zawodny.com/mysql/mytop/"
-SRC_URI="http://jeremy.zawodny.com/mysql/mytop/${P}.tar.gz"
-
-LICENSE="|| ( Artistic GPL-2 )"
-KEYWORDS="alpha amd64 ppc sparc x86"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-perl/DBD-mysql
- virtual/perl-Getopt-Long
- dev-perl/TermReadKey
- virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes
- >=sys-apps/sed-4"
-
-src_install() {
- perl-module_src_install
- sed -i -r\
- -e "s|socket( +)=> '',|socket\1=> '/var/run/mysqld/mysqld.sock',|g" \
- "${D}"/usr/bin/mytop
-}
diff --git a/dev-db/mytop/mytop-1.6-r2.ebuild b/dev-db/mytop/mytop-1.6-r4.ebuild
index 98137f61d663..7820c4bf7af1 100644
--- a/dev-db/mytop/mytop-1.6-r2.ebuild
+++ b/dev-db/mytop/mytop-1.6-r4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mytop/mytop-1.6-r2.ebuild,v 1.1 2009/02/15 01:38:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mytop/mytop-1.6-r4.ebuild,v 1.1 2013/08/29 16:04:28 idella4 Exp $
-inherit perl-app
+EAPI=5
+
+inherit perl-module
DESCRIPTION="mytop - a top clone for mysql"
HOMEPAGE="http://jeremy.zawodny.com/mysql/mytop/"
@@ -13,15 +15,19 @@ KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
SLOT="0"
IUSE=""
-DEPEND="dev-perl/DBD-mysql
+RDEPEND="dev-perl/DBD-mysql
virtual/perl-Getopt-Long
dev-perl/TermReadKey
virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes
+ virtual/perl-Time-HiRes"
+DEPEND="${RDEPEND}
>=sys-apps/sed-4"
-PATCHES="${FILESDIR}/${P}-global-status.patch
- ${FILESDIR}/${P}-queries-vs-questions-mysql-5.0.76.patch"
+PATCHES=( "${FILESDIR}/${PN}-1.6-global-status.patch"
+ "${FILESDIR}/${PN}-1.6-queries-vs-questions-mysql-5.0.76.patch"
+ "${FILESDIR}/${PN}-1.6-getopt-long-2.38-fixup.patch"
+ )
+SRC_TEST="do"
src_install() {
perl-module_src_install
diff --git a/dev-db/mytop/mytop-1.6.ebuild b/dev-db/mytop/mytop-1.6.ebuild
deleted file mode 100644
index 6d9695ca8b62..000000000000
--- a/dev-db/mytop/mytop-1.6.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mytop/mytop-1.6.ebuild,v 1.3 2008/11/18 16:01:44 tove Exp $
-
-inherit perl-app
-
-DESCRIPTION="mytop - a top clone for mysql"
-HOMEPAGE="http://jeremy.zawodny.com/mysql/mytop/"
-SRC_URI="http://jeremy.zawodny.com/mysql/mytop/${P}.tar.gz"
-
-LICENSE="|| ( Artistic GPL-2 )"
-KEYWORDS="alpha amd64 ppc sparc x86"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-perl/DBD-mysql
- virtual/perl-Getopt-Long
- dev-perl/TermReadKey
- virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes
- >=sys-apps/sed-4"
-
-src_install() {
- perl-module_src_install
- sed -i -r\
- -e "s|socket( +)=> '',|socket\1=> '/var/run/mysqld/mysqld.sock',|g" \
- "${D}"/usr/bin/mytop
-}