summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-11-08 20:47:20 +0000
committerVlastimil Babka <caster@gentoo.org>2009-11-08 20:47:20 +0000
commit58189f82fad24c02e00ee6a90498c214127d588b (patch)
tree2095c56e6c05795cb8f9714dd5be836a20dc5c3d /dev-db/octopus
parentMore fixes (diff)
downloadgentoo-2-58189f82fad24c02e00ee6a90498c214127d588b.tar.gz
gentoo-2-58189f82fad24c02e00ee6a90498c214127d588b.tar.bz2
gentoo-2-58189f82fad24c02e00ee6a90498c214127d588b.zip
Revbump to remove dependency on 1.5 jdk - bug #292001.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/octopus')
-rw-r--r--dev-db/octopus/ChangeLog7
-rw-r--r--dev-db/octopus/octopus-3.0.1-r3.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-db/octopus/ChangeLog b/dev-db/octopus/ChangeLog
index fabe0a3a5b0b..e2758a2aeeee 100644
--- a/dev-db/octopus/ChangeLog
+++ b/dev-db/octopus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/octopus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.14 2009/09/18 07:20:21 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.15 2009/11/08 20:47:20 caster Exp $
+
+*octopus-3.0.1-r3 (08 Nov 2009)
+
+ 08 Nov 2009; Vlastimil Babka <caster@gentoo.org> +octopus-3.0.1-r3.ebuild:
+ Revbump to remove dependency on 1.5 jdk - bug #292001.
*octopus-3.0.1-r2 (18 Sep 2009)
diff --git a/dev-db/octopus/octopus-3.0.1-r3.ebuild b/dev-db/octopus/octopus-3.0.1-r3.ebuild
new file mode 100644
index 000000000000..c168b3d5be3c
--- /dev/null
+++ b/dev-db/octopus/octopus-3.0.1-r3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1-r3.ebuild,v 1.1 2009/11/08 20:47:20 caster Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+JAVA_PKG_WANT_BOOTCLASSPATH="1.5"
+
+inherit versionator java-pkg-2 java-ant-2
+
+MY_PV=${PV//./-}
+MY_PV=${MY_PV/-/.}
+DESCRIPTION="A Java-based Extraction, Transformation, and Loading (ETL) tool."
+SRC_URI="http://download.forge.objectweb.org/${PN}/${PN}-${MY_PV}.src.tar.gz
+ mirror://gentoo/${PN}-xmls-${PV}.tar.bz2"
+HOMEPAGE="http://octopus.objectweb.org"
+LICENSE="LGPL-2.1"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+COMMON_DEP="
+ >=dev-java/xerces-2.7
+ >=dev-java/log4j-1.2.8
+ =dev-java/rhino-1.6*
+ =dev-java/junit-3.8*
+ >=dev-java/ant-core-1.4"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+# uses enum as identifier
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+
+TOPDIR="${PN}-$(get_version_component_range 1-2)"
+S=${WORKDIR}/${TOPDIR}/Octopus-src
+
+java_prepare() {
+ rm -fr ${TOPDIR}/maven
+
+ mv "${WORKDIR}/xmls" "${S}/modules/Octopus"
+
+ cd "${S}"/modules
+ cp "${FILESDIR}/${P}-gentoo-build.xml" build.xml
+ java-ant_rewrite-classpath build.xml
+ java-pkg_filter-compiler jikes
+ java-ant_rewrite-bootclasspath 1.5
+
+ epatch "${FILESDIR}/${PN}-jdk-1.5.patch"
+}
+
+EANT_GENTOO_CLASSPATH="xerces-2,rhino-1.6,ant-core,junit,log4j"
+
+src_compile() {
+ cd "${S}/modules"
+
+ use source && antflags="${antflags} sourcezip-all"
+
+ eant jar-all $(use_doc docs-all) ${antflags}
+}
+
+RESTRICT="test"
+
+# Would need maven to work properly as the build.xml just launches maven
+#src_test() {
+# eant test
+#}
+
+src_install() {
+ dodoc ChangeLog.txt ReleaseNotes.txt
+
+ cd "${S}/modules"
+ java-pkg_dojar dist/*.jar
+
+ if use source; then
+ dodir /usr/share/doc/${PF}/source
+ cp dist/*-src.zip "${D}usr/share/doc/${PF}/source"
+ fi
+ if use doc; then
+ docinto html/api
+ # Has multiple javadoc subdirs here
+ java-pkg_dohtml -r docs/*
+ fi
+}