summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2004-12-22 00:28:30 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2004-12-22 00:28:30 +0000
commit8abb52229e2cde387ff4b9a2c35e2f3c3bc89f16 (patch)
treee0821abe2a9224169a1a19c1014b9500f2d27d03 /dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.3.ebuild
parentnew version. (Manifest recommit) (diff)
downloadgentoo-2-8abb52229e2cde387ff4b9a2c35e2f3c3bc89f16.tar.gz
gentoo-2-8abb52229e2cde387ff4b9a2c35e2f3c3bc89f16.tar.bz2
gentoo-2-8abb52229e2cde387ff4b9a2c35e2f3c3bc89f16.zip
new version
Diffstat (limited to 'dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.3.ebuild')
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.3.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.3.ebuild
new file mode 100644
index 000000000000..e0e9637d6928
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.3.ebuild,v 1.1 2004/12/22 00:26:12 radek Exp $
+
+inherit eutils
+
+MY_P="${P}-1.i386"
+
+S=${WORKDIR}
+DESCRIPTION="Oracle 10g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://otn.oracle.com/software/tech/oci/instantclient/htdocs/linuxsoft.html"
+SRC_URI="${MY_P}.rpm"
+
+LICENSE="OTN"
+SLOT="${KV}"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+IUSE=""
+
+DEPEND="app-arch/rpm2targz
+ >=dev-db/oracle-instantclient-basic-${PV}"
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_install() {
+ dodir /usr/lib/oracle/${PV}/client/lib
+ cd ${S}/usr/lib/oracle/${PV}/client/lib
+ insinto /usr/lib/oracle/${PV}/client/lib
+ doins libheteroxa10.so ocrs12.jar orai18n.jar
+}
+
+pkg_postinst() {
+ einfo "The JDBC supplement package for Oracle 10g has been installed."
+ einfo "You may wish to install the oracle-instantclient-sqlplus (for "
+ einfo "running the SQL*Plus application) package as well."
+}