summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-01-28 21:03:14 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-01-28 21:03:14 +0000
commit2cac309521ddbecacc481ea660f0d570cdd1a802 (patch)
tree33ad524effdce9e1a13cd1e2871ca111f29823ba /dev-db/pgadmin3
parentCleanup (diff)
downloadgentoo-2-2cac309521ddbecacc481ea660f0d570cdd1a802.tar.gz
gentoo-2-2cac309521ddbecacc481ea660f0d570cdd1a802.tar.bz2
gentoo-2-2cac309521ddbecacc481ea660f0d570cdd1a802.zip
Moved pkg_prepare to pkg_setup. Fixes bug 398887.
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/ChangeLog8
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.1-r1.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index f56d93515f3d..6753776bdb9b 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.72 2012/01/11 12:33:13 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.73 2012/01/28 21:03:14 titanofold Exp $
+
+*pgadmin3-1.14.1-r1 (28 Jan 2012)
+
+ 28 Jan 2012; Aaron W. Swenson <titanofold@gentoo.org>
+ +pgadmin3-1.14.1-r1.ebuild:
+ Moved pkg_prepare to pkg_setup. Fixes bug 398887.
11 Jan 2012; Agostino Sarubbo <ago@gentoo.org> pgadmin3-1.14.1.ebuild:
Stable for AMD64, wrt bug #394447
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.1-r1.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.1-r1.ebuild
new file mode 100644
index 000000000000..1cd18dd0d988
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.14.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.1-r1.ebuild,v 1.1 2012/01/28 21:03:14 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit autotools multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="Artistic"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X,debug=]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/ssl-detect-r1.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}