summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-22 05:32:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-22 05:32:16 +0000
commit7e42a507c29ef1ece021fa4711bbc844ebd21dca (patch)
tree22d2f3fff067ef7c50bf58c58b72600da13b43af /dev-db/pgpool2
parentBump (diff)
downloadgentoo-2-7e42a507c29ef1ece021fa4711bbc844ebd21dca.tar.gz
gentoo-2-7e42a507c29ef1ece021fa4711bbc844ebd21dca.tar.bz2
gentoo-2-7e42a507c29ef1ece021fa4711bbc844ebd21dca.zip
Bump
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/pgpool2')
-rw-r--r--dev-db/pgpool2/ChangeLog7
-rw-r--r--dev-db/pgpool2/pgpool2-3.2.3.ebuild117
2 files changed, 123 insertions, 1 deletions
diff --git a/dev-db/pgpool2/ChangeLog b/dev-db/pgpool2/ChangeLog
index 79562d942079..054f1c960093 100644
--- a/dev-db/pgpool2/ChangeLog
+++ b/dev-db/pgpool2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgpool2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/ChangeLog,v 1.15 2013/03/17 05:19:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/ChangeLog,v 1.16 2013/03/22 05:32:16 patrick Exp $
+
+*pgpool2-3.2.3 (22 Mar 2013)
+
+ 22 Mar 2013; Patrick Lauer <patrick@gentoo.org> +pgpool2-3.2.3.ebuild:
+ Bump
*pgpool2-3.2.2 (17 Mar 2013)
diff --git a/dev-db/pgpool2/pgpool2-3.2.3.ebuild b/dev-db/pgpool2/pgpool2-3.2.3.ebuild
new file mode 100644
index 000000000000..60404b8ce1a1
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-3.2.3.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgpool2/pgpool2-3.2.3.ebuild,v 1.1 2013/03/22 05:32:16 patrick Exp $
+
+EAPI=4
+
+[[ ${PV} == 9999 ]] && MY_P=${PN/2/-II} || MY_P="${PN/2/-II}-${PV}"
+
+ECVS_SERVER="cvs.pgfoundry.org:/cvsroot/pgpool"
+ECVS_MODULE="pgpool-II"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="cvs"
+inherit base autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="http://www.pgpool.net/"
+[[ ${PV} == 9999 ]] || SRC_URI="http://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+
+IUSE="memcached pam ssl static-libs"
+
+RDEPEND="
+ dev-db/postgresql-base
+ memcached? ( dev-libs/libmemcached )
+ pam? ( sys-auth/pambase )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ !!dev-db/pgpool
+"
+
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup postgres 70
+ enewuser pgpool -1 -1 -1 postgres
+
+ # We need the postgres user as well so we can set the proper
+ # permissions on the sockets without getting into fights with
+ # PostgreSQL's initialization scripts.
+ enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/pgpool_run_paths.patch"
+
+ local pg_config_manual="$(pg_config --includedir)/pg_config_manual.h"
+ local pgsql_socket_dir=$(grep DEFAULT_PGSOCKET_DIR "${pg_config_manual}" | \
+ sed 's|.*\"\(.*\)\"|\1|g')
+ local pgpool_socket_dir="$(dirname $pgsql_socket_dir)/pgpool"
+
+ sed "s|@PGSQL_SOCKETDIR@|${pgsql_socket_dir}|g" \
+ -i *.conf.sample* pool.h || die
+
+ sed "s|@PGPOOL_SOCKETDIR@|${pgpool_socket_dir}|g" \
+ -i *.conf.sample* pool.h || die
+}
+
+src_configure() {
+ local myconf
+ use memcached && \
+ myconf="--with-memcached=\"${EROOT%/}/usr/include/libmemcached\""
+ use pam && myconf+=' --with-pam'
+
+ econf \
+ --disable-rpath \
+ --sysconfdir="${EROOT%/}/etc/${PN}" \
+ $(use_with ssl openssl) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ cd sql
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd sql
+ emake DESTDIR="${D}" install
+ cd "${S}"
+
+ # `contrib' moved to `extension' with PostgreSQL 9.1
+ local pgslot=$(postgresql-config show)
+ if [[ ${pgslot//.} > 90 ]] ; then
+ cd "${ED%/}$(pg_config --sharedir)"
+ mv contrib extension || die
+ cd "${S}"
+ fi
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ # Documentation
+ dodoc NEWS TODO doc/where_to_send_queries.{pdf,odg}
+ dohtml -r doc
+
+ # Examples and extras
+ insinto "/usr/share/${PN}"
+ doins doc/{pgpool_remote_start,basebackup.sh,recovery.conf.sample}
+ mv "${ED%/}/usr/share/${PN/2/-II}" "${ED%/}/usr/share/${PN}" || die
+
+ # One more thing: Evil la files!
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}