summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-09-30 19:44:04 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-09-30 19:44:04 +0000
commite60cf9b9c104ef3565504b6ab1b18adf1e9d757f (patch)
tree806ef5fc1a86a4be38229f168a630527ac03be59 /dev-db/postgis
parentfixed bug #29184 (diff)
downloadgentoo-2-e60cf9b9c104ef3565504b6ab1b18adf1e9d757f.tar.gz
gentoo-2-e60cf9b9c104ef3565504b6ab1b18adf1e9d757f.tar.bz2
gentoo-2-e60cf9b9c104ef3565504b6ab1b18adf1e9d757f.zip
fixed bug #29184
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/Manifest4
-rw-r--r--dev-db/postgis/files/digest-postgis-0.7.5-r12
-rw-r--r--dev-db/postgis/metadata.xml5
-rw-r--r--dev-db/postgis/postgis-0.7.5-r1.ebuild71
4 files changed, 79 insertions, 3 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index 42485a981538..38481bce8ed0 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -1,8 +1,6 @@
MD5 60120a48e9663bd64c9dd4f9a720e5a3 postgis-0.7.5.ebuild 1830
MD5 f6fa18eec82dc30f3c8ad5ba133e083e ChangeLog 724
MD5 f8d3d207746da2a3cd14dcaab8daab76 metadata.xml 163
-MD5 f5072db3b3fecb766ab73fdc449e4246 postgis-0.7.5-r1.ebuild 1833
-MD5 60120a48e9663bd64c9dd4f9a720e5a3 postgis-0.7.5.ebuild.~1.3.~ 1830
-MD5 60120a48e9663bd64c9dd4f9a720e5a3 postgis-0.7.5-r1.ebuild~ 1830
+MD5 867c142d83927c8bda0084de7b9d6beb postgis-0.7.5-r1.ebuild 1838
MD5 39d5f5f4b112fc4028303fdadd09a54b files/digest-postgis-0.7.5 135
MD5 f718e28928cb252d1804b9d2fca96f74 files/digest-postgis-0.7.5-r1 135
diff --git a/dev-db/postgis/files/digest-postgis-0.7.5-r1 b/dev-db/postgis/files/digest-postgis-0.7.5-r1
new file mode 100644
index 000000000000..de92b564c0da
--- /dev/null
+++ b/dev-db/postgis/files/digest-postgis-0.7.5-r1
@@ -0,0 +1,2 @@
+MD5 6ce60ba78bf133147cc502c27dba2f67 postgis-0.7.5.tar.gz 336368
+MD5 82878d6d74c36384af3595d26ed38067 postgresql-7.3.4.tar.gz 11265028
diff --git a/dev-db/postgis/metadata.xml b/dev-db/postgis/metadata.xml
new file mode 100644
index 000000000000..309b51e9a965
--- /dev/null
+++ b/dev-db/postgis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>postgresql</herd>
+</pkgmetadata>
diff --git a/dev-db/postgis/postgis-0.7.5-r1.ebuild b/dev-db/postgis/postgis-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..ff2019c5a89a
--- /dev/null
+++ b/dev-db/postgis/postgis-0.7.5-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-0.7.5-r1.ebuild,v 1.1 2003/09/30 19:44:00 nakano Exp $
+
+MY_PGSQL="postgresql-7.3.4"
+DESCRIPTION="adds support for geographic objects to PostgreSQL"
+HOMEPAGE="http://postgis.refractions.net/"
+SRC_URI="http://postgis.refractions.net/${P}.tar.gz
+ ftp://ftp8.us.postgresql.org/pub/pgsql/source/v7.3.4/${MY_PGSQL}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tcltk python perl java ssl nls libg++"
+
+DEPEND="~postgresql-7.3.4
+ dev-libs/proj
+ >=sys-apps/sed-4*"
+
+src_unpack() {
+ unpack "${MY_PGSQL}.tar.gz"
+ cd ${MY_PGSQL}/contrib
+ unpack "${P}.tar.gz"
+ cd "${P}"
+ sed -i -e "s:USE_PROJ=0:USE_PROJ=1:g" \
+ -e "s:PROJ_DIR=/usr/local:PROJ_DIR=/usr:g" \
+ Makefile
+}
+
+src_compile() {
+ local myconf
+ cd "${WORKDIR}/${MY_PGSQL}"
+ use tcltk && myconf="--with-tcl"
+ use python && myconf="${myconf} --with-python"
+ use perl && myconf="${myconf} --with-perl"
+ use java && myconf="${myconf} --with-java"
+ use ssl && myconf="${myconf} --with-ssl"
+ use nls && myconf="${myconf} --enable-locale --enable-nls --enable-multibyte"
+ use libg++ && myconf="${myconf} --with-CXX"
+
+ use ppc && CFLAGS="-pipe-fsigned-char"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${MY_PGSQL}-r1 \
+ --libdir=/usr/lib \
+ --enable-syslog \
+ --enable-depend \
+ --with-gnu-ld \
+ --with-pam \
+ --with-maxbackends=1024 \
+ ${myconf} || die
+
+ cd contrib/${P}
+
+ make || die
+}
+
+src_install() {
+ cd ${WORKDIR}/${MY_PGSQL}/contrib/${P}
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${MY_PGSQL} \
+ libdir=${D}/usr/lib/postgresql \
+ install || die
+
+ dodoc CHANGES COPYING CREDITS TODO
+}