summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-17 19:40:09 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-17 19:40:09 +0000
commit091ce10752c1a04f81577de6c5698c20f1e1c0a3 (patch)
tree301680d27609845817ce967f9e35ede27495c508 /dev-db/postgresql
parentThis patch fixes an DESTDIR install bug (diff)
downloadgentoo-2-091ce10752c1a04f81577de6c5698c20f1e1c0a3.tar.gz
gentoo-2-091ce10752c1a04f81577de6c5698c20f1e1c0a3.tar.bz2
gentoo-2-091ce10752c1a04f81577de6c5698c20f1e1c0a3.zip
Fixed bug in patch
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/files/postgresql-7.1-perl5-GNUmakefile-gentoo.diff28
-rw-r--r--dev-db/postgresql/postgresql-7.1.ebuild20
2 files changed, 25 insertions, 23 deletions
diff --git a/dev-db/postgresql/files/postgresql-7.1-perl5-GNUmakefile-gentoo.diff b/dev-db/postgresql/files/postgresql-7.1-perl5-GNUmakefile-gentoo.diff
index a1e4f17aed08..d1483d2f3620 100644
--- a/dev-db/postgresql/files/postgresql-7.1-perl5-GNUmakefile-gentoo.diff
+++ b/dev-db/postgresql/files/postgresql-7.1-perl5-GNUmakefile-gentoo.diff
@@ -1,6 +1,6 @@
---- postgresql-7.1.orig/src/interfaces/perl5/GNUmakefile Fri Nov 17 00:08:57 2000
-+++ postgresql-7.1/src/interfaces/perl5/GNUmakefile Tue Apr 17 19:20:19 2001
-@@ -36,20 +36,26 @@
+--- postgresql-7.1/src/interfaces/perl5/GNUmakefile.orig Tue Apr 17 21:28:21 2001
++++ postgresql-7.1/src/interfaces/perl5/GNUmakefile Tue Apr 17 21:28:27 2001
+@@ -36,20 +36,12 @@
install: Makefile
$(MAKE) -f Makefile clean
@@ -12,26 +12,18 @@
- $(MAKE) -f Makefile install; \
- $(MAKE) clean; \
- else \
+- echo "*****" ;\
+- echo "* Skipping the installation of the Perl module for lack of permissions."; \
+- echo "* To install it, change to the directory "`pwd`","; \
+- echo "* become the appropriate user, and do \`$(MAKE) install'."; \
+- echo "*****"; \
+- fi
+ POSTGRES_LIB="$(DESTDIR)$(libdir)" \
+ POSTGRES_INCLUDE="$(DESTDIR)$(includedir)" \
+ $(PERL) $(srcdir)/Makefile.PL
+ $(MAKE) -f Makefile all; \
-+ PERLDEST="`$(MAKE) --quiet PREFIX=$(DESTDIR)$(prefix) -f Makefile echo-installdir`"; \
-+ if [ ! -d $(PERLDEST) ]; then \
-+ $(mkinstalldirs) $(PERLDEST); \
-+ fi; \
-+ if [ -w $(PERLDEST) ]; then \
+ $(MAKE) PREFIX=$(DESTDIR)$(prefix) INSTALLMAN3DIR=$(DESTDIR)$(mandir)/man3 -f Makefile install; \
-+ $(MAKE) clean; \
-+ else \
- echo "*****" ;\
- echo "* Skipping the installation of the Perl module for lack of permissions."; \
- echo "* To install it, change to the directory "`pwd`","; \
- echo "* become the appropriate user, and do \`$(MAKE) install'."; \
- echo "*****"; \
- fi
-+
-+
++ $(MAKE) clean;
uninstall:
diff --git a/dev-db/postgresql/postgresql-7.1.ebuild b/dev-db/postgresql/postgresql-7.1.ebuild
index f5d5f4f8d943..90396f214121 100644
--- a/dev-db/postgresql/postgresql-7.1.ebuild
+++ b/dev-db/postgresql/postgresql-7.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.1.ebuild,v 1.1 2001/04/16 11:02:34 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.1.ebuild,v 1.2 2001/04/17 19:40:09 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -13,13 +13,17 @@ DEPEND="virtual/glibc
>=sys-libs/readline-4.2
>=sys-libs/ncurses-5.2
tcltk? ( >=dev-lang/tcl-tk-8 )
- perl? ( >=sys-devel/perl )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ java? ( dev-lang/jdk )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
patch -p0 < ${DISTDIR}/rl42-pg.patch
+ patch -p1 < ${FILESDIR}/${P}-perl5-GNUmakefile-gentoo.diff
}
src_compile() {
@@ -33,6 +37,15 @@ src_compile() {
then
myconf="$myconf --with-perl"
fi
+ if [ "`use python`" ]
+ then
+ myconf="$myconf --with-python"
+ fi
+ if [ "`use java`" ]
+ then
+ myconf="$myconf --with-java"
+ export JAVA_HOME="/opt/java"
+ fi
if [ "`use nls`" ]
then
myconf="$myconf --enable-locale"
@@ -40,9 +53,6 @@ src_compile() {
try autoconf
try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
--enable-syslog $myconf
- cp Makefile.global Makefile.orig
- sed -e "s:-O2:${CFLAGS}:" \
- Makefile.orig > Makefile.global
try make
}