summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2004-10-23 21:19:15 +0000
committerDan Armak <danarmak@gentoo.org>2004-10-23 21:19:15 +0000
commit43079378e1b4a1dc28ca5fa47c569865914a49cc (patch)
treeb4dfd9f3c9bf688d08b97cadd7a8512d1ef23f0d /dev-db/qt-unixODBC
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-43079378e1b4a1dc28ca5fa47c569865914a49cc.tar.gz
gentoo-2-43079378e1b4a1dc28ca5fa47c569865914a49cc.tar.bz2
gentoo-2-43079378e1b4a1dc28ca5fa47c569865914a49cc.zip
separate ebuild for qt odbc plugin. see bug 14178. this is hardmasked because would overwrite the same plugin as installed by x11-libs/qt, and this version isn't as verified, so be cautious if emerging.
Diffstat (limited to 'dev-db/qt-unixODBC')
-rw-r--r--dev-db/qt-unixODBC/ChangeLog9
-rw-r--r--dev-db/qt-unixODBC/Manifest2
-rw-r--r--dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.31
-rw-r--r--dev-db/qt-unixODBC/metadata.xml5
-rw-r--r--dev-db/qt-unixODBC/qt-unixODBC-3.3.3.ebuild59
5 files changed, 76 insertions, 0 deletions
diff --git a/dev-db/qt-unixODBC/ChangeLog b/dev-db/qt-unixODBC/ChangeLog
new file mode 100644
index 000000000000..3b926d904bbe
--- /dev/null
+++ b/dev-db/qt-unixODBC/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-db/qt-unixODBC
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/ChangeLog,v 1.1 2004/10/23 21:19:15 danarmak Exp $
+
+*qt-ODBC-3.3.3 (23 Oct 2004)
+
+ 23 Oct 2004; Dan Armak <danarmak@gentoo.org> qt-ODBC-3.3.3.ebuild:
+ First created. A separate ebuild for the QT unixODBC plugin to fix #14178.
+ \ No newline at end of file
diff --git a/dev-db/qt-unixODBC/Manifest b/dev-db/qt-unixODBC/Manifest
new file mode 100644
index 000000000000..630b73d2207b
--- /dev/null
+++ b/dev-db/qt-unixODBC/Manifest
@@ -0,0 +1,2 @@
+MD5 f4aa8d565ff76ea21db6bfd9f38ae61f qt-unixODBC-3.3.3.ebuild 1416
+MD5 4fc68ca52659787e90f0de57b43e943b files/digest-qt-unixODBC-3.3.3 72
diff --git a/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.3 b/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.3
new file mode 100644
index 000000000000..4d86db2e2cbb
--- /dev/null
+++ b/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.3
@@ -0,0 +1 @@
+MD5 3e0a0c8429b0a974b39b5f535ddff01c qt-x11-free-3.3.3.tar.bz2 14424812
diff --git a/dev-db/qt-unixODBC/metadata.xml b/dev-db/qt-unixODBC/metadata.xml
new file mode 100644
index 000000000000..01a5c2875e0d
--- /dev/null
+++ b/dev-db/qt-unixODBC/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+</pkgmetadata>
diff --git a/dev-db/qt-unixODBC/qt-unixODBC-3.3.3.ebuild b/dev-db/qt-unixODBC/qt-unixODBC-3.3.3.ebuild
new file mode 100644
index 000000000000..dfb183190847
--- /dev/null
+++ b/dev-db/qt-unixODBC/qt-unixODBC-3.3.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/qt-unixODBC-3.3.3.ebuild,v 1.1 2004/10/23 21:19:15 danarmak Exp $
+
+inherit eutils
+
+SRCTYPE="free"
+DESCRIPTION="QT version ${PV}"
+HOMEPAGE="http://www.trolltech.com/"
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.bz2"
+IUSE=""
+LICENSE="|| ( QPL-1.0 GPL-2 )"
+SLOT="3"
+KEYWORDS="~x86"
+
+DEPEND="~x11-libs/qt-$PV
+ dev-db/unixODBC"
+
+S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+export PLATFORM=linux-g++
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+}
+
+src_compile() {
+ export QTDIR=${S}
+ export SYSCONF=${D}${QTBASE}/etc/settings
+
+ # Let's just allow writing to these directories during Qt emerge
+ # as it makes Qt much happier.
+ addwrite "${QTBASE}/etc/settings"
+ addwrite "$HOME/.qt"
+
+ export YACC='byacc -d'
+
+ ./configure -sm -thread -stl -system-libjpeg -verbose -largefile \
+ -qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
+ -system-libpng -lpthread -xft -platform ${PLATFORM} -xplatform \
+ ${PLATFORM} -xrender -prefix ${QTBASE} -fast ${myconf} \
+ -dlopen-opengl -plugin-sql-odbc -L${QTBASE}/lib || die
+
+ export QTDIR=${S}
+
+ cd $S/plugins/src/sqldrivers/odbc
+ emake || die
+}
+
+src_install() {
+ mkdir -p $D/$QTBASE/plugins/sqldrivers
+ cp $S/plugins/sqldrivers/libqsqlodbc.so $D/$QTBASE/plugins/sqldrivers/ || die
+}