summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2007-12-23 16:30:37 +0000
committerMasatomo Nakano <nakano@gentoo.org>2007-12-23 16:30:37 +0000
commit9bcbb33cde1a247924b84dcccf3d586c6ca4e4a1 (patch)
treead2c4d145dab2471e708edbe3a28f1a0d1847e03 /dev-db/slony1/slony1-1.2.12.ebuild
parentVersion bump. (diff)
downloadgentoo-2-9bcbb33cde1a247924b84dcccf3d586c6ca4e4a1.tar.gz
gentoo-2-9bcbb33cde1a247924b84dcccf3d586c6ca4e4a1.tar.bz2
gentoo-2-9bcbb33cde1a247924b84dcccf3d586c6ca4e4a1.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-db/slony1/slony1-1.2.12.ebuild')
-rw-r--r--dev-db/slony1/slony1-1.2.12.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/slony1/slony1-1.2.12.ebuild b/dev-db/slony1/slony1-1.2.12.ebuild
new file mode 100644
index 000000000000..a318e54ade4a
--- /dev/null
+++ b/dev-db/slony1/slony1-1.2.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-1.2.12.ebuild,v 1.1 2007/12/23 16:30:36 nakano Exp $
+
+inherit eutils
+
+IUSE="perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+SRC_URI="http://main.slony.info/downloads/1.2/source/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-db/postgresql
+ perl? ( dev-perl/DBD-Pg )"
+
+src_compile() {
+ local myconf=""
+
+ myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
+ myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
+ myconf="${myconf} $(use_with perl perltools)"
+
+ econf ${myconf} || die
+ emake || die
+
+ if use perl ; then
+ cd ${S}/tools
+ emake || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+ dohtml doc/howto/*.html
+
+ newinitd ${FILESDIR}/slony1.init slony1 || die
+ newconfd ${FILESDIR}/slony1.conf slony1 || die
+
+}