summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-27 22:08:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-27 22:08:43 +0000
commite40ea88912e078efe7fdce901110c18941d74cc4 (patch)
tree1d9f6e61ce9286247c3d8ac2a9f2a64884c0ce8e /dev-db/sqlite/sqlite-3.6.16.ebuild
parentamd64 stable, bug #268163 (diff)
downloadgentoo-2-e40ea88912e078efe7fdce901110c18941d74cc4.tar.gz
gentoo-2-e40ea88912e078efe7fdce901110c18941d74cc4.tar.bz2
gentoo-2-e40ea88912e078efe7fdce901110c18941d74cc4.zip
Disable failing tests which were absent in previous versions. Don't check FEATURES (bug #278870).
(Portage version: 13851-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/sqlite/sqlite-3.6.16.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-3.6.16.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/dev-db/sqlite/sqlite-3.6.16.ebuild b/dev-db/sqlite/sqlite-3.6.16.ebuild
index 32b336f55899..c7064d3d196b 100644
--- a/dev-db/sqlite/sqlite-3.6.16.ebuild
+++ b/dev-db/sqlite/sqlite-3.6.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.16.ebuild,v 1.1 2009/06/27 21:31:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.16.ebuild,v 1.2 2009/07/27 22:08:43 arfrever Exp $
EAPI="2"
@@ -23,23 +23,12 @@ RDEPEND="tcl? ( dev-lang/tcl )"
DEPEND="${RDEPEND}
doc? ( app-arch/unzip )"
-pkg_setup() {
- if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl; then
- ewarn "You must enable the tcl use flag if you want to run the testsuite."
- eerror "Testsuite will not be run."
- fi
- fi
-}
-
src_prepare() {
# note: this sandbox fix is no longer needed with sandbox-1.3+
epatch "${FILESDIR}"/sandbox-fix2.patch
+ epatch "${FILESDIR}"/${P}-tkt3922.test.patch
+
epunt_cxx
}
@@ -62,10 +51,18 @@ src_compile() {
}
src_test() {
- if has userpriv ${FEATURES}; then
+ if [[ "${EUID}" -ne "0" ]]; then
local test=test
use debug && test=fulltest
emake ${test} || die "some test(s) failed"
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+
+ if ! use tcl; then
+ ewarn "You must enable the tcl USE flag if you want to run the testsuite."
+ eerror "Testsuite will not be run."
fi
}