summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-08 23:03:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-08 23:03:00 +0000
commitca420456f4c1f0704ca03bfb30acfad9418d4ccf (patch)
tree99f1617f388650e221c1cc49f4c95d986de6eaa5 /dev-db/sqlite
parentx11-apps/x11perf: add missing deps (fixes bug #228201) (diff)
downloadgentoo-2-ca420456f4c1f0704ca03bfb30acfad9418d4ccf.tar.gz
gentoo-2-ca420456f4c1f0704ca03bfb30acfad9418d4ccf.tar.bz2
gentoo-2-ca420456f4c1f0704ca03bfb30acfad9418d4ccf.zip
Version bump.
(Portage version: 13618-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog9
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.10-tcl-install.patch40
-rw-r--r--dev-db/sqlite/sqlite-3.6.10.ebuild90
-rw-r--r--dev-db/sqlite/sqlite-3.6.14.ebuild (renamed from dev-db/sqlite/sqlite-3.6.6.2.ebuild)35
4 files changed, 24 insertions, 150 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 6168461353d2..14b4faf578ec 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.239 2009/05/07 15:58:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.240 2009/05/08 23:02:59 arfrever Exp $
+
+*sqlite-3.6.14 (08 May 2009)
+
+ 08 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -sqlite-3.6.6.2.ebuild, -sqlite-3.6.10.ebuild,
+ -files/sqlite-3.6.10-tcl-install.patch, +sqlite-3.6.14.ebuild:
+ Version bump.
07 May 2009; Raúl Porcel <armin76@gentoo.org> sqlite-3.6.13.ebuild:
arm/ia64/s390/sh/sparc stable wrt #267528
diff --git a/dev-db/sqlite/files/sqlite-3.6.10-tcl-install.patch b/dev-db/sqlite/files/sqlite-3.6.10-tcl-install.patch
deleted file mode 100644
index b390c2fd36d7..000000000000
--- a/dev-db/sqlite/files/sqlite-3.6.10-tcl-install.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- Makefile.in
-+++ Makefile.in
-@@ -457,7 +457,7 @@
- libtclsqlite3.la: tclsqlite.lo libsqlite3.la
- $(LTLINK) -o $@ tclsqlite.lo \
- libsqlite3.la @TCL_STUB_LIB_SPEC@ $(TLIBS) \
-- -rpath "$(libdir)/sqlite" \
-+ -rpath "$(libdir)/sqlite3" \
- -module -avoid-version
-
- sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
-@@ -754,9 +754,11 @@
- $(TEMP_STORE) -o $@ $(TESTFIXTURE_SRC) $(LIBTCL)
-
-
--install: sqlite3$(BEXE) libsqlite3.la sqlite3.h ${HAVE_TCL:1=tcl_install}
-+lib_install: libsqlite3.la
- $(INSTALL) -d $(DESTDIR)$(libdir)
- $(LTINSTALL) libsqlite3.la $(DESTDIR)$(libdir)
-+
-+install: sqlite3$(BEXE) lib_install sqlite3.h ${HAVE_TCL:1=tcl_install}
- $(INSTALL) -d $(DESTDIR)$(bindir)
- $(LTINSTALL) sqlite3$(BEXE) $(DESTDIR)$(bindir)
- $(INSTALL) -d $(DESTDIR)$(includedir)
-@@ -765,8 +767,13 @@
- $(INSTALL) -d $(DESTDIR)$(pkgconfigdir)
- $(INSTALL) -m 0644 sqlite3.pc $(DESTDIR)$(pkgconfigdir)
-
--tcl_install: libtclsqlite3.la
-- $(TCLSH_CMD) $(TOP)/tclinstaller.tcl $(RELEASE)
-+pkgIndex.tcl:
-+ echo 'package ifneeded sqlite3 $(RELEASE) [list load $(libdir)/sqlite3/libtclsqlite3.so sqlite3]' > $@
-+tcl_install: lib_install libtclsqlite3.la pkgIndex.tcl
-+ $(INSTALL) -d $(DESTDIR)$(libdir)/sqlite3
-+ $(LTINSTALL) libtclsqlite3.la $(DESTDIR)$(libdir)/sqlite3
-+ rm -f $(DESTDIR)$(libdir)/sqlite3/libtclsqlite3.a $(DESTDIR)$(libdir)/sqlite3/libtclsqlite3.la
-+ $(INSTALL) -m 0644 pkgIndex.tcl $(DESTDIR)$(libdir)/sqlite3
-
- clean:
- rm -f *.lo *.la *.o sqlite3$(TEXE) libsqlite3.la
diff --git a/dev-db/sqlite/sqlite-3.6.10.ebuild b/dev-db/sqlite/sqlite-3.6.10.ebuild
deleted file mode 100644
index 1567365a8bbd..000000000000
--- a/dev-db/sqlite/sqlite-3.6.10.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.10.ebuild,v 1.7 2009/02/26 20:03:46 ranger Exp $
-
-EAPI="1"
-
-inherit versionator eutils flag-o-matic libtool
-
-DESCRIPTION="an SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha ~amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug doc soundex tcl +threadsafe"
-RESTRICT="!tcl? ( test )"
-
-RDEPEND="tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )"
-
-pkg_setup() {
- # test
- if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl; then
- ewarn "You must enable the tcl use flag if you want to run the testsuite."
- eerror "Testsuite will not be run."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/sandbox-fix2.patch
- epatch "${FILESDIR}"/${P}-tcl-install.patch
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- # not available via configure and requested in bug #143794
- use soundex && append-flags -DSQLITE_SOUNDEX=1
-
- econf \
- $(use_enable debug) \
- $(use_enable threadsafe) \
- $(use_enable threadsafe cross-thread-connections) \
- $(use_enable tcl)
- emake all || die "emake all failed"
-}
-
-src_test() {
- if has userpriv ${FEATURES}; then
- local test=test
- use debug && tets=fulltest
- emake ${test} || die "some test(s) failed"
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die
- fi
-}
-
-pkg_postinst() {
- elog "sqlite-3.6.X is not totally backwards compatible, see"
- elog "http://www.sqlite.org/releaselog/3_6_0.html for full details."
-}
diff --git a/dev-db/sqlite/sqlite-3.6.6.2.ebuild b/dev-db/sqlite/sqlite-3.6.14.ebuild
index 9aa3ea8648a3..fa5151176b55 100644
--- a/dev-db/sqlite/sqlite-3.6.6.2.ebuild
+++ b/dev-db/sqlite/sqlite-3.6.14.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.6.2.ebuild,v 1.10 2009/01/31 20:11:20 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.14.ebuild,v 1.1 2009/05/08 23:02:59 arfrever Exp $
EAPI="1"
-inherit versionator eutils flag-o-matic libtool
+inherit eutils flag-o-matic multilib versionator
DESCRIPTION="an SQL Database Engine in a C Library"
HOMEPAGE="http://www.sqlite.org/"
@@ -15,7 +15,7 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz
LICENSE="as-is"
SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="debug doc soundex tcl +threadsafe"
RESTRICT="!tcl? ( test )"
@@ -24,13 +24,12 @@ DEPEND="${RDEPEND}
doc? ( app-arch/unzip )"
pkg_setup() {
- # test
- if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
+ if has test ${FEATURES} ; then
+ if ! has userpriv ${FEATURES} ; then
ewarn "The userpriv feature must be enabled to run tests."
eerror "Testsuite will not be run."
fi
- if ! use tcl; then
+ if ! use tcl ; then
ewarn "You must enable the tcl use flag if you want to run the testsuite."
eerror "Testsuite will not be run."
fi
@@ -41,28 +40,31 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ # note: this sandbox fix is no longer needed with sandbox-1.3+
epatch "${FILESDIR}"/sandbox-fix2.patch
- elibtoolize
epunt_cxx
}
src_compile() {
+ # Enable column metadata, bug #266651
+ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
# not available via configure and requested in bug #143794
- use soundex && append-flags -DSQLITE_SOUNDEX=1
+ use soundex && append-cppflags -DSQLITE_SOUNDEX=1
econf \
$(use_enable debug) \
$(use_enable threadsafe) \
$(use_enable threadsafe cross-thread-connections) \
$(use_enable tcl)
- emake all || die "emake all failed"
+ emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
}
src_test() {
- if has userpriv ${FEATURES}; then
+ if has userpriv ${FEATURES} ; then
local test=test
- use debug && tets=fulltest
+ use debug && test=fulltest
emake ${test} || die "some test(s) failed"
fi
}
@@ -70,20 +72,15 @@ src_test() {
src_install() {
emake \
DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)" \
+ TCLLIBDIR="/usr/$(get_libdir)/${P}" \
install \
|| die "emake install failed"
doman sqlite3.1 || die
- if use doc; then
+ if use doc ; then
# Naming scheme changes randomly between - and _ in releases
# http://www.sqlite.org/cvstrac/tktview?tn=3523
dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die
fi
}
-
-pkg_postinst() {
- elog "sqlite-3.6.X is not totally backwards compatible, see"
- elog "http://www.sqlite.org/releaselog/3_6_0.html for full details."
-}