summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-27 09:31:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-27 09:31:45 +0000
commit2499cf31385034ee7ddc2d08310b9e679fcc73fa (patch)
treed30373c9ffc54ef7757c33307bb0927406d54e24 /dev-db/tokyocabinet
parentRe-Keywording for ppc. (diff)
downloadgentoo-2-2499cf31385034ee7ddc2d08310b9e679fcc73fa.tar.gz
gentoo-2-2499cf31385034ee7ddc2d08310b9e679fcc73fa.tar.bz2
gentoo-2-2499cf31385034ee7ddc2d08310b9e679fcc73fa.zip
Bump, closes #290701
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/tokyocabinet')
-rw-r--r--dev-db/tokyocabinet/ChangeLog8
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.36.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index 54ba6e8a6583..eec33fdc418f 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.5 2009/10/26 20:34:55 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.6 2009/10/27 09:31:45 patrick Exp $
+
+*tokyocabinet-1.4.36 (27 Oct 2009)
+
+ 27 Oct 2009; Patrick Lauer <patrick@gentoo.org>
+ +tokyocabinet-1.4.36.ebuild:
+ Bump, closes #290701
26 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
tokyocabinet-1.4.35.ebuild:
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.36.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.36.ebuild
new file mode 100644
index 000000000000..d0b8ae603c36
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.36.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.36.ebuild,v 1.1 2009/10/27 09:31:45 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://1978th.net/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~ppc-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ dodoc example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ dodoc doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}