summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-08-21 14:07:40 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-08-21 14:07:40 +0000
commit01925018eaf220953bfabc971562afc8de541e0b (patch)
tree5ee4b5901ccdcace31ce6b5ccb4094fa4cb232b8 /dev-db
parentkeyworded ~arch for amd64, bug 234953 (diff)
downloadgentoo-2-01925018eaf220953bfabc971562afc8de541e0b.tar.gz
gentoo-2-01925018eaf220953bfabc971562afc8de541e0b.tar.bz2
gentoo-2-01925018eaf220953bfabc971562afc8de541e0b.zip
new version. fixes issue with PHP warnings enabled. fixes bug #234767. discussed commit with robbat2 and trapni
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog9
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.11.8.1.ebuild63
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 4638a94c5963..5fef72486b29 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.323 2008/08/09 21:30:41 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.324 2008/08/21 14:07:39 cardoe Exp $
+
+*phpmyadmin-2.11.8.1 (21 Aug 2008)
+
+ 21 Aug 2008; Doug Goldstein <cardoe@gentoo.org>
+ +phpmyadmin-2.11.8.1.ebuild:
+ new version. fixes issue with PHP warnings enabled. fixes bug #234767.
+ discussed commit with robbat2 and trapni
09 Aug 2008; Christian Hoffmann <hoffie@gentoo.org>
phpmyadmin-2.11.8.ebuild:
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.11.8.1.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.11.8.1.ebuild
new file mode 100644
index 000000000000..2566eea088c1
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.11.8.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.11.8.1.ebuild,v 1.1 2008/08/21 14:07:40 cardoe Exp $
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages-utf-8-only"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use crypt ctype pcre session unicode \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "ctype pcre session unicode"
+ eerror
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "mysql or mysqli if using dev-lang/php-5"
+ eerror
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.11.5-custom-cert.patch
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog
+ rm -f LICENSE CREDITS INSTALL README RELEASE-DATE-${MY_PV} TODO
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.8.0.txt
+ webapp_hook_script "${FILESDIR}"/reconfig-2.8
+ webapp_src_install
+}