summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-12-19 12:05:13 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-12-19 12:05:13 +0000
commit0ba69107bd8b20113ce81e51bec23b9ac2c1580a (patch)
tree848905e4a7da555d6c6d208378dcc8d96ae88b17 /dev-db
parentMake building work without tcl installed using the amalgamation tarball from ... (diff)
downloadgentoo-2-0ba69107bd8b20113ce81e51bec23b9ac2c1580a.tar.gz
gentoo-2-0ba69107bd8b20113ce81e51bec23b9ac2c1580a.tar.bz2
gentoo-2-0ba69107bd8b20113ce81e51bec23b9ac2c1580a.zip
Fix a couple QA issues with the last commit.
(Portage version: 2.2_rc54/cvs/Linux i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog5
-rw-r--r--dev-db/sqlite/sqlite-3.6.21.ebuild15
2 files changed, 12 insertions, 8 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 40a5179171b8..7a8900c58c6f 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.300 2009/12/19 11:57:01 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.301 2009/12/19 12:05:13 betelgeuse Exp $
+
+ 19 Dec 2009; Petteri Räty <betelgeuse@gentoo.org> sqlite-3.6.21.ebuild:
+ Fix a couple QA issues with the last commit.
19 Dec 2009; Petteri Räty <betelgeuse@gentoo.org> sqlite-3.6.21.ebuild:
Make building work without tcl installed using the amalgamation tarball
diff --git a/dev-db/sqlite/sqlite-3.6.21.ebuild b/dev-db/sqlite/sqlite-3.6.21.ebuild
index 77459a339b8e..efd1e1c834aa 100644
--- a/dev-db/sqlite/sqlite-3.6.21.ebuild
+++ b/dev-db/sqlite/sqlite-3.6.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.21.ebuild,v 1.3 2009/12/19 11:57:01 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.21.ebuild,v 1.4 2009/12/19 12:05:13 betelgeuse Exp $
EAPI="2"
@@ -12,11 +12,11 @@ DOC_BASE="$(get_version_component_range 1-3)"
DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
+ tcl? ( http://www.sqlite.org/${P}.tar.gz )
+ !tcl? (
test? ( http://www.sqlite.org/${P}.tar.gz )
!test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
+ )
doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
LICENSE="as-is"
@@ -26,9 +26,9 @@ IUSE="debug doc fts3 icu +readline soundex tcl +threadsafe test"
RDEPEND="icu? ( dev-libs/icu )
readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )
- test? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
DEPEND="${RDEPEND}
+ test? ( dev-lang/tcl )
doc? ( app-arch/unzip )"
src_prepare() {
@@ -72,7 +72,8 @@ src_configure() {
econf \
$(use_enable readline) \
$(use_enable threadsafe) \
- $(use tcl && echo --enable-tcl)
+ $(use tcl && echo --enable-tcl) \
+ $(use !tcl && use test && echo --disable-tcl)
}
src_compile() {