summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-04-04 09:31:24 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-04-04 09:31:24 +0000
commit12d7afdc35ac67e5ccc0b67a012cd3c084f731dc (patch)
tree24dc9204875dda2722626e147582a380a096fdc7 /dev-db
parentAdd myself as a maintainer. (diff)
downloadgentoo-2-12d7afdc35ac67e5ccc0b67a012cd3c084f731dc.tar.gz
gentoo-2-12d7afdc35ac67e5ccc0b67a012cd3c084f731dc.tar.bz2
gentoo-2-12d7afdc35ac67e5ccc0b67a012cd3c084f731dc.zip
Remove old version.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/ChangeLog5
-rw-r--r--dev-db/redis/redis-1.2.5.ebuild119
2 files changed, 4 insertions, 120 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index 3b2fc137ad91..0aa04e3aaa3f 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.9 2011/04/04 09:28:26 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.10 2011/04/04 09:31:24 djc Exp $
+
+ 04 Apr 2011; Dirkjan Ochtman <djc@gentoo.org> -redis-1.2.5.ebuild:
+ Remove old version.
04 Apr 2011; Dirkjan Ochtman <djc@gentoo.org> metadata.xml:
Add myself as a maintainer.
diff --git a/dev-db/redis/redis-1.2.5.ebuild b/dev-db/redis/redis-1.2.5.ebuild
deleted file mode 100644
index 53cd2693010d..000000000000
--- a/dev-db/redis/redis-1.2.5.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-1.2.5.ebuild,v 1.4 2010/05/17 21:32:23 lu_zero Exp $
-
-EAPI=2
-
-inherit autotools eutils
-
-DESCRIPTION="Persistent distributed key-value data caching system."
-HOMEPAGE="http://code.google.com/p/redis/"
-SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="test? ( dev-lang/tcl )"
-
-REDIS_PIDDIR=/var/run/redis/
-REDIS_PIDFILE=${REDIS_PIDDIR}/redis.pid
-REDIS_DATAPATH=/var/lib/redis
-REDIS_LOGPATH=/var/log/redis
-REDIS_LOGFILE=${REDIS_LOGPATH}/redis.log
-
-pkg_setup() {
- enewgroup redis 75 || die "problem adding 'redis' group"
- enewuser redis 75 -1 ${REDIS_DATAPATH} redis || die "problem adding 'redis' user"
-}
-
-src_prepare() {
- # Borrowed from debian
- epatch "${FILESDIR}"/01-dont-print-pid-on-startup.diff
- # Now autotoolize this
- cp "${FILESDIR}"/configure.ac-1.02 configure.ac
- mv Makefile Makefile.in
- sed -i \
- -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:ARCH:GCC_ARCH_FLAG:g' \
- -e 's:PROF:GCC_PROF_FLAG:g' \
- Makefile.in \
- || die "sed failed!"
-
- eautoreconf
-}
-
-src_install() {
- # configuration file rewrites
- insinto /etc/
- sed -r \
- -e "/^pidfile\>/s,/var.*,${REDIS_PIDFILE}," \
- -e '/^daemonize\>/s,no,yes,' \
- -e '/^# bind/s,^# ,,' \
- -e '/^# maxmemory\>/s,^# ,,' \
- -e '/^maxmemory\>/s,<bytes>,67108864,' \
- -e "/^dbfilename\>/s,dump.rdb,${REDIS_DATAPATH}/dump.rdb," \
- -e "/^dir\>/s, .*, ${REDIS_DATAPATH}/," \
- -e '/^loglevel\>/s:debug:notice:' \
- -e "/^logfile\>/s:stdout:${REDIS_LOGFILE}:" \
- <redis.conf \
- >redis.conf.gentoo
- newins redis.conf.gentoo redis.conf
- fowners root:redis /etc/redis.conf
- fperms 0640 /etc/redis.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd" redis
-
- dodoc 00-RELEASENOTES BETATESTING.txt BUGS Changelog README TODO
- newdoc client-libraries/README README.client-libraries
- dohtml doc/*
-
- dobin redis-benchmark redis-cli
- dosbin redis-server
-
- diropts -m0750 -o redis -g redis
- keepdir ${REDIS_DATAPATH} ${REDIS_LOGPATH} ${REDIS_PIDDIR}
-}
-
-src_test() {
- local PORT=$(((RANDOM % 32767)+32768))
- local PIDFILE=redis-test.pid
- einfo "Preparing redis test config"
- # The port number is hardcoded in lots of places
- sed -r <redis.conf >redis-test.conf \
- -e "/^pidfile/s~ .*~ ${PIDFILE}~" \
- -e '/^daemonize/s~ no~ yes~' \
- -e "/^port/s~ [0-9]+~ ${PORT}~" \
- -e '/^(# )?bind/s,^,#,g' \
- -e '/\<bind\>/abind 127.0.0.1' \
- || die "Failed to build test server config"
- # The port number is hardcoded in lots of places
- for i in test-redis.tcl redis.tcl ; do
- sed -r <$i >${i/.tcl/-${PORT}.tcl} \
- -e "/^source redis.tcl/s,redis.tcl,redis-${PORT}.tcl,g" \
- -e "/6379/s~6379~${PORT}~" \
- || die "Failed to build test client config ($i)"
- done
- einfo "Starting test server"
- ./redis-server redis-test.conf
- rc1=$?
- sleep 2
- [[ $rc1 -ne 0 ]] && die "Failed to start redis server!"
- pidof redis-server | fgrep -f ${PIDFILE}
- rc1=$?
- [[ $rc1 -ne 0 ]] && die "Could not find started redis server!"
- unset rc1
-
- einfo "Starting redis tests"
- tclsh test-redis-$PORT.tcl
- rc1=$?
- kill -9 $(<${PIDFILE})
- rc2=$?
- [[ $rc1 -ne 0 ]] && die "Failed testsuite"
- [[ $rc2 -ne 0 ]] && die "Failed to shut down redis server"
-}