summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2011-05-15 22:16:46 +0000
committerAlex Legler <a3li@gentoo.org>2011-05-15 22:16:46 +0000
commit1c99b134b73a23bef857660a684e41fe5d6a17dc (patch)
tree88397be1c5d6c49ce9d83aff97fa90cbf3f8f5f0 /dev-db
parentClean up old revision. (diff)
downloadgentoo-2-1c99b134b73a23bef857660a684e41fe5d6a17dc.tar.gz
gentoo-2-1c99b134b73a23bef857660a684e41fe5d6a17dc.tar.bz2
gentoo-2-1c99b134b73a23bef857660a684e41fe5d6a17dc.zip
Version bump. The installation of the PMA setup utility can now be controlled via the 'setup' USE flag.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog9
-rw-r--r--dev-db/phpmyadmin/files/postinstall-en-3.1.txt3
-rw-r--r--dev-db/phpmyadmin/metadata.xml8
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-3.4.0.ebuild64
4 files changed, 82 insertions, 2 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 0a8280112a7b..a0c09349a685 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.413 2011/01/05 15:25:36 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.414 2011/05/15 22:16:45 a3li Exp $
+
+*phpmyadmin-3.4.0 (15 May 2011)
+
+ 15 May 2011; Alex Legler <a3li@gentoo.org> files/postinstall-en-3.1.txt,
+ +phpmyadmin-3.4.0.ebuild, metadata.xml:
+ Version bump. The installation of the PMA setup utility can now be controlled
+ via the 'setup' USE flag.
*phpmyadmin-3.3.9 (05 Jan 2011)
diff --git a/dev-db/phpmyadmin/files/postinstall-en-3.1.txt b/dev-db/phpmyadmin/files/postinstall-en-3.1.txt
index 29a8dc77ba7a..4e72581eb82d 100644
--- a/dev-db/phpmyadmin/files/postinstall-en-3.1.txt
+++ b/dev-db/phpmyadmin/files/postinstall-en-3.1.txt
@@ -2,7 +2,8 @@ If this is a new installation:
1. Configure ${PN}:
-a) Create config.inc.php. You can use the web-based installer:
+a) Create config.inc.php. You can use the web-based installer
+ (this requires the 'setup' USE flag to be enabled):
mkdir ${MY_INSTALLDIR}/config
chown ${VHOST_SERVER_UID}:${VHOST_SERVER_UID} ${MY_INSTALLDIR}/config
diff --git a/dev-db/phpmyadmin/metadata.xml b/dev-db/phpmyadmin/metadata.xml
index ec867187f02e..fb25c5886ffe 100644
--- a/dev-db/phpmyadmin/metadata.xml
+++ b/dev-db/phpmyadmin/metadata.xml
@@ -6,4 +6,12 @@
<email>a3li@gentoo.org</email>
<name>Alex Legler</name>
</maintainer>
+ <use>
+ <flag name="setup">
+ Installs the phpMyAdmin setup utility.
+ Users who don't use the utility should disable this USE flag
+ for security reasons as the setup tool was the target of various
+ exploits in the past.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/dev-db/phpmyadmin/phpmyadmin-3.4.0.ebuild b/dev-db/phpmyadmin/phpmyadmin-3.4.0.ebuild
new file mode 100644
index 000000000000..8820bd445de4
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-3.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.4.0.ebuild,v 1.1 2011/05/15 22:16:46 a3li Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ <dev-lang/php-5.3[spl,pcre]
+ >=dev-lang/php-5.3
+ )
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog || die
+ rm -f LICENSE CREDITS INSTALL README* RELEASE-DATE-${MY_PV} TODO
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpmyadmin setup utility has been removed."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}