summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-05-25 18:00:14 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-05-25 18:00:14 +0000
commit243d83949d2b1583cc3d52908ae7abc06da983fc (patch)
treebe38cc5621cd9ad9ac6d7b79e88e202a1559eca6 /dev-db
parentApplied all amd64 changes but forgot to keyword ;-) (Manifest recommit) (diff)
downloadgentoo-2-243d83949d2b1583cc3d52908ae7abc06da983fc.tar.gz
gentoo-2-243d83949d2b1583cc3d52908ae7abc06da983fc.tar.bz2
gentoo-2-243d83949d2b1583cc3d52908ae7abc06da983fc.zip
Fixed problem about installing jdbc driver.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog5
-rw-r--r--dev-db/postgresql/postgresql-7.4.2-r2.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 0683354eaa01..19c7ece3ce1e 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.98 2004/05/25 15:57:26 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.99 2004/05/25 18:00:14 nakano Exp $
+
+ 25 May 2004; Masatomo Nakano <nakano@gentoo.org> postgresql-7.4.2-r2.ebuild:
+ Fixed problem about installing jdbc driver.
25 May 2004; Masatomo Nakano <nakano@gentoo.org>
files/pg_autovacuum.init-7.4.2, postgresql-7.4.2-r1.ebuild,
diff --git a/dev-db/postgresql/postgresql-7.4.2-r2.ebuild b/dev-db/postgresql/postgresql-7.4.2-r2.ebuild
index aaae0e898664..2f67bb688c17 100644
--- a/dev-db/postgresql/postgresql-7.4.2-r2.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.2-r2.ebuild,v 1.5 2004/05/25 15:57:26 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.2-r2.ebuild,v 1.6 2004/05/25 18:00:14 nakano Exp $
inherit eutils gnuconfig flag-o-matic
@@ -102,7 +102,7 @@ src_compile() {
use tcltk && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
- use jave && myconf="$myconf --with-java"
+ use java && myconf="$myconf --with-java"
use ssl && myconf="$myconf --with-openssl"
use nls && myconf="$myconf --enable-nls"
use libg++ && myconf="$myconf --with-CXX"
@@ -158,8 +158,12 @@ src_install() {
exeinto /usr/bin
if [ "`use java`" ]; then
+ # we need to remove jar file after dojar; otherwise two same jar
+ # file are installed.
dojar ${D}/usr/share/postgresql/java/postgresql.jar || die
-# rm ${D}/usr/share/postgresql/java/postgresql.jar
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+ dojar ${D}/usr/share/postgresql/java/postgresql-examples.jar || die
+ rm ${D}/usr/share/postgresql/java/postgresql-examples.jar
fi
dodir /usr/include/postgresql/pgsql