summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-30 12:20:51 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-30 12:20:51 +0000
commit3900336b8e6c86bdbc69ddf541b6f80e9ef8e336 (patch)
tree166eb62c014c57854a8274e23be26f60c1483ae5 /dev-db
parentDrop ~sparc-fbsd KEYWORD (diff)
downloadgentoo-2-3900336b8e6c86bdbc69ddf541b6f80e9ef8e336.tar.gz
gentoo-2-3900336b8e6c86bdbc69ddf541b6f80e9ef8e336.tar.bz2
gentoo-2-3900336b8e6c86bdbc69ddf541b6f80e9ef8e336.zip
Version bump to 1.1.0 ebuild and cmake patch from Jorge (jmbsvicetto) updated by me to not cause any error. Tested and confirmed working with libreoffice.
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql-connector-c++/ChangeLog14
-rw-r--r--dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-disable-tests.patch14
-rw-r--r--dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch85
-rw-r--r--dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0_pre814-libdir.patch42
-rw-r--r--dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0.ebuild59
-rw-r--r--dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0_pre814.ebuild85
6 files changed, 170 insertions, 129 deletions
diff --git a/dev-db/mysql-connector-c++/ChangeLog b/dev-db/mysql-connector-c++/ChangeLog
index 0d42c90b75ff..bc206a2852fc 100644
--- a/dev-db/mysql-connector-c++/ChangeLog
+++ b/dev-db/mysql-connector-c++/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-db/mysql-connector-c++
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-connector-c++/ChangeLog,v 1.4 2010/03/25 18:59:39 robbat2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-connector-c++/ChangeLog,v 1.5 2011/07/30 12:20:51 scarabeus Exp $
+
+*mysql-connector-c++-1.1.0 (30 Jul 2011)
+
+ 30 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -mysql-connector-c++-1.1.0_pre814.ebuild, +mysql-connector-c++-1.1.0.ebuild,
+ +files/mysql-connector-c++-1.1.0-disable-tests.patch,
+ +files/mysql-connector-c++-1.1.0-fix-cmake.patch,
+ -files/mysql-connector-c++-1.1.0_pre814-libdir.patch:
+ Version bump to 1.1.0 ebuild and cmake patch from Jorge (jmbsvicetto) updated
+ by me to not cause any error. Tested and confirmed working with libreoffice.
25 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
mysql-connector-c++-1.1.0_pre814.ebuild:
diff --git a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-disable-tests.patch b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-disable-tests.patch
new file mode 100644
index 000000000000..e6345c046b63
--- /dev/null
+++ b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-disable-tests.patch
@@ -0,0 +1,14 @@
+diff -urNad mysql-connector-c++-1.0.6~r754~/CMakeLists.txt mysql-connector-c++-1.0.6~r754/CMakeLists.txt
+--- mysql-connector-c++-1.0.6~r754~/CMakeLists.txt 2009-08-20 22:25:35.000000000 +0200
++++ mysql-connector-c++-1.0.6~r754/CMakeLists.txt 2009-08-20 22:25:57.000000000 +0200
+@@ -241,10 +241,6 @@
+ ADD_SUBDIRECTORY(cppconn)
+ ADD_SUBDIRECTORY(driver)
+ ADD_SUBDIRECTORY(examples)
+-ADD_SUBDIRECTORY(test)
+-ADD_SUBDIRECTORY(test/framework)
+-ADD_SUBDIRECTORY(test/CJUnitTestsPort)
+-ADD_SUBDIRECTORY(test/unit)
+
+ IF(DEFINED CMAKE_SYSTEM_NAME AND ${CMAKE_SYSTEM_NAME} STREQUAL "SunOS")
+ # see also README
diff --git a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch
new file mode 100644
index 000000000000..d32fa07f1e0b
--- /dev/null
+++ b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch
@@ -0,0 +1,85 @@
+diff -urN mysql-connector-c++-1.1.0.old/CMakeLists.txt mysql-connector-c++-1.1.0/CMakeLists.txt
+--- mysql-connector-c++-1.1.0.old/CMakeLists.txt 2011-07-30 13:15:44.000000000 +0200
++++ mysql-connector-c++-1.1.0/CMakeLists.txt 2011-07-30 13:16:18.000000000 +0200
+@@ -232,7 +232,7 @@
+ "install_manifest.txt")
+ SET(PRJ_COMMON_IGNORE_FILES ${COMMON_IGNORE_FILES} "ANNOUNCEMENT_102_ALPHA" "ANNOUNCEMENT_103_ALPHA" "ANNOUNCEMENT_104_BETA" "ANNOUNCEMENT_105_GA" "ANNOUNCEMENT_110_GA" "ANNOUNCEMENT_DRAFT" )
+
+-SET(CPACK_SOURCE_IGNORE_FILES ${PRJ_COMMON_IGNORE_FILES} "./cppconn/config.h$" "./driver/nativeapi/binding_config.h$")
++SET(CPACK_SOURCE_IGNORE_FILES ${PRJ_COMMON_IGNORE_FILES} "${CMAKE_CURRENT_SOURCE_DIR}/cppconn/config.h$" "${CMAKE_CURRENT_SOURCE_DIR}/driver/nativeapi/binding_config.h$")
+ SET(CPACK_PACKAGE_IGNORE_FILES ${PRJ_COMMON_IGNORE_FILES} "something_there" )
+ SET(CPACK_SOURCE_GENERATOR "TGZ")
+
+diff -urN mysql-connector-c++-1.1.0.old/cppconn/CMakeLists.txt mysql-connector-c++-1.1.0/cppconn/CMakeLists.txt
+--- mysql-connector-c++-1.1.0.old/cppconn/CMakeLists.txt 2011-07-30 13:15:44.000000000 +0200
++++ mysql-connector-c++-1.1.0/cppconn/CMakeLists.txt 2011-07-30 14:10:34.000000000 +0200
+@@ -55,7 +55,7 @@
+
+ SET(MYSQLCPPCONN_INSTALL_HEADERS
+ build_config.h
+- config.h
++ ${CMAKE_CURRENT_BINARY_DIR}/config.h
+ connection.h
+ datatype.h
+ driver.h
+diff -urN mysql-connector-c++-1.1.0.old/driver/CMakeLists.txt mysql-connector-c++-1.1.0/driver/CMakeLists.txt
+--- mysql-connector-c++-1.1.0.old/driver/CMakeLists.txt 2011-07-30 13:15:44.000000000 +0200
++++ mysql-connector-c++-1.1.0/driver/CMakeLists.txt 2011-07-30 13:20:36.000000000 +0200
+@@ -26,6 +26,9 @@
+
+ INCLUDE_DIRECTORIES(${MYSQLCPPCONN_SOURCE_DIR})
+ INCLUDE_DIRECTORIES(${MYSQLCPPCONN_SOURCE_DIR}/cppconn)
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR})
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR}/cppconn)
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR}/driver/nativeapi)
+ INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BOOST_INCLUDE_DIRS})
+ MESSAGE(STATUS "BOOST_INCLUDE_DIRS=${MYSQLCPPCONN_BOOST_INCLUDE_DIRS}")
+
+@@ -149,20 +152,22 @@
+ nativeapi/native_statement_wrapper.h
+ nativeapi/mysql_native_resultset_wrapper.h
+ nativeapi/native_resultset_wrapper.h
+- ../cppconn/warning.h
+- ../cppconn/statement.h
+- ../cppconn/sqlstring.h
+- ../cppconn/resultset_metadata.h
+- ../cppconn/resultset.h
+- ../cppconn/prepared_statement.h
+- ../cppconn/parameter_metadata.h
+- ../cppconn/metadata.h
+- ../cppconn/exception.h
+- ../cppconn/driver.h
+- ../cppconn/datatype.h
+- ../cppconn/connection.h
+- ../cppconn/config.h
+- ../cppconn/build_config.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/warning.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/statement.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/sqlstring.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/resultset_metadata.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/resultset.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/prepared_statement.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/parameter_metadata.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/metadata.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/exception.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/driver.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/datatype.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/connection.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/config.h
++ ${CMAKE_CURRENT_BINARY_DIR}/cppconn/config.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/build_config.h
++ ${CMAKE_CURRENT_BINARY_DIR}/cppconn/build_config.h
+
+ )
+
+@@ -271,8 +276,8 @@
+ )
+ ELSE(WIN32)
+ INSTALL(TARGETS mysqlcppconn mysqlcppconn-static
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ )
+ ENDIF(WIN32)
+
diff --git a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0_pre814-libdir.patch b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0_pre814-libdir.patch
deleted file mode 100644
index f0dc154906fd..000000000000
--- a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0_pre814-libdir.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -Nuar mysql-connector-c++-1.1.0~r814.orig/driver/CMakeLists.txt mysql-connector-c++-1.1.0~r814/driver/CMakeLists.txt
---- mysql-connector-c++-1.1.0~r814.orig/driver/CMakeLists.txt 2010-03-09 21:40:43.000000000 +0000
-+++ mysql-connector-c++-1.1.0~r814/driver/CMakeLists.txt 2010-03-24 21:04:44.836622353 +0000
-@@ -234,13 +234,13 @@
-
- IF(WIN32)
- INSTALL(TARGETS mysqlcppconn mysqlcppconn-static
-- RUNTIME DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- )
- ELSE(WIN32)
- INSTALL(TARGETS mysqlcppconn mysqlcppconn-static
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- )
- ENDIF(WIN32)
-
-diff -Nuar mysql-connector-c++-1.1.0~r814.orig/thread/CMakeLists.txt mysql-connector-c++-1.1.0~r814/thread/CMakeLists.txt
---- mysql-connector-c++-1.1.0~r814.orig/thread/CMakeLists.txt 2010-03-09 21:40:43.000000000 +0000
-+++ mysql-connector-c++-1.1.0~r814/thread/CMakeLists.txt 2010-03-24 21:05:49.059949215 +0000
-@@ -52,13 +52,13 @@
-
- IF(WIN32)
- INSTALL(TARGETS mysqlcppconn_thread mysqlcppconn_thread-static
-- RUNTIME DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- )
- ELSE(WIN32)
- INSTALL(TARGETS mysqlcppconn_thread mysqlcppconn_thread-static
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- )
- ENDIF(WIN32)
-
diff --git a/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0.ebuild b/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0.ebuild
new file mode 100644
index 000000000000..1e0f076f63f0
--- /dev/null
+++ b/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0.ebuild,v 1.1 2011/07/30 12:20:51 scarabeus Exp $
+
+EAPI=4
+
+inherit eutils cmake-utils flag-o-matic multilib
+
+DESCRIPTION="MySQL database connector for C++ (mimics JDBC 4.0 API)"
+HOMEPAGE="http://forge.mysql.com/wiki/Connector_C++"
+URI_DIR="Connector-C++"
+SRC_URI="mirror://mysql/Downloads/${URI_DIR}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug examples gcov static-libs"
+
+DEPEND=">=virtual/mysql-5.1
+ dev-libs/boost
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-cmake.patch"
+ "${FILESDIR}/${P}-disable-tests.patch"
+)
+
+src_configure() {
+ # native lib/wrapper needs this!
+ append-flags "-fno-strict-aliasing"
+
+ mycmakeargs=(
+ "-DMYSQLCPPCONN_BUILD_EXAMPLES=OFF"
+ "-DMYSQLCPPCONN_ICU_ENABLE=OFF"
+ $(cmake-utils_use debug MYSQLCPPCONN_TRACE_ENABLE)
+ $(cmake-utils_use gcov MYSQLCPPCONN_GCOV_ENABLE)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # static lib has wrong name so we need to rename it
+ if use static-libs; then
+ mv "${ED}"/usr/$(get_libdir)/libmysqlcppconn-static.a \
+ "${ED}"/usr/$(get_libdir)/libmysqlcppconn.a || die
+ else
+ rm -f "${ED}"/usr/$(get_libdir)/libmysqlcppconn-static.a
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*
+ fi
+}
diff --git a/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0_pre814.ebuild b/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0_pre814.ebuild
deleted file mode 100644
index 6db65d0a21dc..000000000000
--- a/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0_pre814.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-connector-c++/mysql-connector-c++-1.1.0_pre814.ebuild,v 1.3 2010/03/25 18:59:39 robbat2 Exp $
-
-EAPI="2"
-
-inherit base cmake-utils flag-o-matic
-
-DESCRIPTION="MySQL database connector for C++ (mimics JDBC 4.0 API)"
-HOMEPAGE="http://forge.mysql.com/wiki/Connector_C++"
-
-DEBIAN_PV=1
-MY_PV="${PV/_pre/~r}"
-MY_P="${PN}_${MY_PV}"
-DEBIAN_URI="mirror://debian/pool/main/${PN:0:1}/${PN}"
-DEBIAN_PATCH="${MY_P}-${DEBIAN_PV}.diff.gz"
-DEBIAN_SRC="${MY_P}.orig.tar.gz"
-SRC_URI="${DEBIAN_URI}/${DEBIAN_SRC} ${DEBIAN_URI}/${DEBIAN_PATCH}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug examples gcov static"
-
-DEPEND=">=virtual/mysql-5.1
- dev-libs/boost
- dev-libs/openssl"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P/_pre/~r}"
-
-# cmake config that works ...
-CMAKE_IN_SOURCE_BUILD="1"
-
-src_unpack() {
- unpack "${DEBIAN_SRC}"
-}
-
-src_prepare() {
- EPATCH_OPTS="-p1" epatch "${DISTDIR}"/"${DEBIAN_PATCH}"
- for i in $(<"${S}"/debian/patches/00list) ; do
- epatch "${S}"/debian/patches/${i}*
- done
- epatch "${FILESDIR}"/${PN}-1.1.0_pre814-libdir.patch
-}
-
-src_configure() {
- # native lib/wrapper needs this!
- append-flags "-fno-strict-aliasing"
-
- mycmakeargs=(
- "-DMYSQLCPPCONN_BUILD_EXAMPLES=OFF"
- "-DMYSQLCPPCONN_ICU_ENABLE=OFF"
- $(cmake-utils_use debug MYSQLCPPCONN_TRACE_ENABLE)
- $(cmake-utils_use gconv MYSQLCPPCONN_GCOV_ENABLE)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- # make
- cmake-utils_src_compile mysqlcppconn
-
- # make static
- use static && cmake-utils_src_compile mysqlcppconn-static
-}
-
-src_install() {
- # install - ignore failure for now ...
- emake DESTDIR="${D}" install/fast
-
- # fast install fails on useflag [-static-libs]
- # http://bugs.mysql.com/bug.php?id=52281
- insinto /usr/include
- doins driver/mysql_{connection,driver}.h || die
-
- dodoc ANNOUNCE* CHANGES* README || die
-
- # examples
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins "${S}"/examples/* || die
- fi
-}