summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-05-25 15:57:26 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-05-25 15:57:26 +0000
commit404faa3ac3dd87781dd2d7df3926feb7ea68e43f (patch)
tree805a90e69b3a1df8b1cefeb3727b812f66493af1 /dev-db
parentpatch for 64bit systems where size_t != unsigned int, ~amd64 (Manifest recommit) (diff)
downloadgentoo-2-404faa3ac3dd87781dd2d7df3926feb7ea68e43f.tar.gz
gentoo-2-404faa3ac3dd87781dd2d7df3926feb7ea68e43f.tar.bz2
gentoo-2-404faa3ac3dd87781dd2d7df3926feb7ea68e43f.zip
Fixed a reference to pg_autovacuum document(#51723). Fixed Java problem on
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog8
-rw-r--r--dev-db/postgresql/files/pg_autovacuum.init-7.4.24
-rw-r--r--dev-db/postgresql/postgresql-7.4.2-r1.ebuild3
-rw-r--r--dev-db/postgresql/postgresql-7.4.2-r2.ebuild23
4 files changed, 22 insertions, 16 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index d3614a29653b..0683354eaa01 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.97 2004/05/14 14:56:58 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.98 2004/05/25 15:57:26 nakano Exp $
+
+ 25 May 2004; Masatomo Nakano <nakano@gentoo.org>
+ files/pg_autovacuum.init-7.4.2, postgresql-7.4.2-r1.ebuild,
+ postgresql-7.4.2-r2.ebuild:
+ Fixed a reference to pg_autovacuum document(#51723). Fixed Java problem on
+ amd64.
14 May 2004; Guy Martin <gmsoft@gentoo.org> postgresql-7.4.2-r2.ebuild,
files/postgresql-7.4.1-hppa-testandset.patch:
diff --git a/dev-db/postgresql/files/pg_autovacuum.init-7.4.2 b/dev-db/postgresql/files/pg_autovacuum.init-7.4.2
index e1d1677adef5..a2e8445a26be 100644
--- a/dev-db/postgresql/files/pg_autovacuum.init-7.4.2
+++ b/dev-db/postgresql/files/pg_autovacuum.init-7.4.2
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/files/pg_autovacuum.init-7.4.2,v 1.1 2004/03/11 20:11:28 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/files/pg_autovacuum.init-7.4.2,v 1.2 2004/05/25 15:57:26 nakano Exp $
depend() {
need postgresql logger
@@ -20,7 +20,7 @@ start() {
eerror " stats_start_collector = true"
eerror " stats_row_level = true"
- eerror "Please read /usr/share/doc/postgresql-7.4.1/contrib/README.pg_autovacuum for details."
+ eerror "Please read ___DOCDIR___/contrib/README.pg_autovacuum for details."
eend 1
fi
}
diff --git a/dev-db/postgresql/postgresql-7.4.2-r1.ebuild b/dev-db/postgresql/postgresql-7.4.2-r1.ebuild
index 6b74786e9077..08c4a19298ea 100644
--- a/dev-db/postgresql/postgresql-7.4.2-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.2-r1.ebuild,v 1.3 2004/05/04 09:34:34 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.2-r1.ebuild,v 1.4 2004/05/25 15:57:26 nakano Exp $
inherit eutils gnuconfig flag-o-matic
@@ -181,6 +181,7 @@ src_install() {
exeinto /etc/init.d/
newexe ${FILESDIR}/postgresql.init-${PV} postgresql || die
newexe ${FILESDIR}/pg_autovacuum.init-${PV} pg_autovacuum || die
+ dosed "s:___DOCDIR___:/usr/share/doc/${PF}:" /etc/init.d/pg_autovacuum
insinto /etc/conf.d/
newins ${FILESDIR}/postgresql.conf-${PV} postgresql || die
diff --git a/dev-db/postgresql/postgresql-7.4.2-r2.ebuild b/dev-db/postgresql/postgresql-7.4.2-r2.ebuild
index fa5b76e5ee04..aaae0e898664 100644
--- a/dev-db/postgresql/postgresql-7.4.2-r2.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.2-r2.ebuild,v 1.4 2004/05/14 14:56:58 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.2-r2.ebuild,v 1.5 2004/05/25 15:57:26 nakano Exp $
inherit eutils gnuconfig flag-o-matic
@@ -29,9 +29,9 @@ DEPEND="virtual/glibc
readline? ( >=sys-libs/readline-4.1 )
tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
- python? ( !mips? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base ) )
- java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3
- dev-java/java-config ) )
+ python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+ java? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3
+ dev-java/java-config )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
nls? ( sys-devel/gettext )"
# java dep workaround for portage bug
@@ -41,7 +41,7 @@ RDEPEND="virtual/glibc
tcltk? ( >=dev-lang/tcl-8 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 )
- java? ( !amd64? ( >=virtual/jdk-1.3* ) )
+ java? ( >=virtual/jdk-1.3* )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
PG_DIR="/var/lib/postgresql"
@@ -94,17 +94,15 @@ src_unpack() {
src_compile() {
filter-flags -ffast-math
- if [ "`use java`" -a ! "`use amd64`" ]; then
+ if [ "`use java`" ]; then
check_java_config
fi
local myconf
use tcltk && myconf="--with-tcl"
- use python && use mips || myconf="$myconf --with-python"
+ use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
- if [ "`use java`" -a ! "`use amd64`" ]; then
- myconf="$myconf --with-java"
- fi
+ use jave && myconf="$myconf --with-java"
use ssl && myconf="$myconf --with-openssl"
use nls && myconf="$myconf --enable-nls"
use libg++ && myconf="$myconf --with-CXX"
@@ -159,9 +157,9 @@ src_install() {
exeinto /usr/bin
- if [ "`use java`" -a ! "`use amd64`" ]; then
+ if [ "`use java`" ]; then
dojar ${D}/usr/share/postgresql/java/postgresql.jar || die
- rm ${D}/usr/share/postgresql/java/postgresql.jar
+# rm ${D}/usr/share/postgresql/java/postgresql.jar
fi
dodir /usr/include/postgresql/pgsql
@@ -185,6 +183,7 @@ src_install() {
exeinto /etc/init.d/
newexe ${FILESDIR}/postgresql.init-${PV} postgresql || die
newexe ${FILESDIR}/pg_autovacuum.init-${PV} pg_autovacuum || die
+ dosed "s:___DOCDIR___:/usr/share/doc/${PF}:" /etc/init.d/pg_autovacuum
insinto /etc/conf.d/
newins ${FILESDIR}/postgresql.conf-${PV} postgresql || die