summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-14 08:16:19 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-14 08:16:19 +0000
commit5c9ed561bd99819863d5b2a2329abd14f24a67f0 (patch)
tree98934776f7b8c67658ef9053f891fe9aa8e3e904 /dev-db
parentInitial import of Delta (diff)
downloadgentoo-2-5c9ed561bd99819863d5b2a2329abd14f24a67f0.tar.gz
gentoo-2-5c9ed561bd99819863d5b2a2329abd14f24a67f0.tar.bz2
gentoo-2-5c9ed561bd99819863d5b2a2329abd14f24a67f0.zip
Add patch by Francisco José Cañizares Santofimia to fix building with newer versions of flex #110167.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/unixODBC/ChangeLog9
-rw-r--r--dev-db/unixODBC/files/unixODBC-2.2.11-flex.patch19
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild16
3 files changed, 33 insertions, 11 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index 44f0a98b213b..3b623faa2638 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/unixODBC
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.53 2005/10/02 11:49:50 agriffis Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.54 2006/01/14 08:16:19 vapier Exp $
+
+ 14 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/unixODBC-2.2.11-flex.patch, unixODBC-2.2.11-r1.ebuild:
+ Add patch by Francisco José Cañizares Santofimia to fix building with
+ newer versions of flex #110167.
02 Oct 2005; Aron Griffis <agriffis@gentoo.org> unixODBC-2.2.11-r1.ebuild:
Mark 2.2.11-r1 stable on ia64
diff --git a/dev-db/unixODBC/files/unixODBC-2.2.11-flex.patch b/dev-db/unixODBC/files/unixODBC-2.2.11-flex.patch
new file mode 100644
index 000000000000..80652cd035ca
--- /dev/null
+++ b/dev-db/unixODBC/files/unixODBC-2.2.11-flex.patch
@@ -0,0 +1,19 @@
+--- unixODBC-2.2.6/sqp/lex.l.orig Wed Oct 17 18:40:32 2001
++++ unixODBC-2.2.6/sqp/lex.l Thu Jul 10 11:23:35 2003
+@@ -178,6 +178,7 @@
+
+ '[^'\n]*$ {
+ yyerror( "Unterminated string" );
++ YY_FLUSH_BUFFER;
+ }
+
+ /***************************************
+@@ -236,8 +237,6 @@
+ void yyerror( char *s )
+ {
+ sprintf( g_szError, "%s processing '%s' on line %d", s, yytext, g_nLineNo );
+-
+- YY_FLUSH_BUFFER;
+ }
+
+ /**********************************************************************
diff --git a/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
index d113ae2e20c2..93385cad974f 100644
--- a/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.10 2005/10/02 11:49:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.11 2006/01/14 08:16:19 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.unixodbc.org/"
@@ -22,11 +22,12 @@ DEPEND="virtual/libc
# the configure.in patch is required for 'use qt'
src_unpack() {
unpack ${P}.tar.gz
- cd ${S}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-flex.patch #110167
# braindead check in configure fails - hack approach
- epatch ${FILESDIR}/${P}-configure.in.patch
- epatch ${FILESDIR}/${P}-Makefile.am.patch
+ epatch "${FILESDIR}"/${P}-configure.in.patch
+ epatch "${FILESDIR}"/${P}-Makefile.am.patch
aclocal && \
libtoolize -c -f && \
automake && \
@@ -43,9 +44,6 @@ src_compile() {
myconf="--enable-gui=no"
fi
- # Detect mips systems properly
- gnuconfig_update
-
./configure --host=${CHOST} \
--prefix=/usr \
--sysconfdir=/etc/unixODBC \